No Internet access after 5.4.189068.135 update [Merged]

Moderator Headnote: CIS/CFW 5.4.189068.1354 has an [url=;msg514670#msg514670]acknowledged issue[/url] with the ARP Protection

The Fix Will Be Released Monday

Temporary Fix: Disable “Protect ARP Cache” in Firewall Settings

I updated the CIS software today to the latest version but it seems there is some nuisance I am having with it.

After the update and reboot it seems it takes about 30 second longer for my network/internet connection to come active then before the update where as soon as the windows was rebooted my internet was up. It seems maybe something in the new update(perhaps the firewall maybe) is slowing or interfering with my network and internet connection. Any help is appreciate it.

The version I am talking about is 5.4.189068.1354

We would very much appreciate it if you would edit your first post to create an issue report in line with the bug forum guidelines and format here. You can copy and paste the format from this topic.

To understand the reasons why we ask you to follow these guidelines please see below.

Bugs/issues can be impossible or very time consuming to fix if developers don’t have enough information to reproduce them. Since CIS is free, development time is limited. So if you want your issue fixed, please use the format below to describe it.

To avoid clutter, issues not described in the format below your post will not be moved to the ‘moderator verified’ issues topic. This means that the developers may not look at it.

Best wishes and many thanks in anticipation


Hello tomorrow there was an update for the CIS Premium after the update and an required reboot i have no longer an working internet connection, i use an wireless connection and also with the cable no connection i get an 169.xx ip.

When removing CIS i have wireless connection so what is going wrong after the update i dot not know how to handle but the update is causing many problems please help me to fix this. ???

This problem has been resolved i have done the following simple steps:

  1. Completely removing CIS and done an full register cleaning
  2. Re-Installed the 64 bit CIS version and after the installation rebooted
  3. Installing the AV updates and done an fullscan
  4. Problem resolved

Maybe it would help another users also when this problem occurs after an upgrade fro CIS. :slight_smile:

Can’t select stealth my connection to everyone or else I wouldn’t be able to get valid ip to access the internet.

Svchost is actually blocked by CIS. So does Windows operating system.

I can circumvent this using stealth my PC on case per case basis but I don’t understand why the old setup now wouldn’t work like they used to.

I had the same problem and resolved it the same way.

Hello i have problem Comodo CIS is fully blocking mine dsl connection, i have the old version completely removed and done an full register clean and register defrag and i have run comodo system cleaner and ccleaner.

I have after the installing of CIS and rebooting no dsl connection i get only an 169. ip when completely removing CIS i have connection, what is causing the problem i have no only running Comodo anti virus and pctools firewall plus but i want the Comodo firewall back and working the new versions causing many problems.

How to resolve this. ??? :cry:

I just installed the update for Comodo Firewall and now am not able to access the Internet with the firewall enabled. I even tried setting it to Training mode, but that didn’t help. The only way I can get to the web is to completely disable the firewall. I made no other changes. The installation of the update is the only thing that has changed. Any thoughts?

shure but when i come home and start mine pc no connection again so must i everytime remove CIS and reinstalling it no there is an serious problem whith the update and one of the Comodo experts must take a look i have it completely removed until there is an solution. :-TD :-TD :-TD :-TD :-TD :-TD >:(

this update is the worse. It has slowed my network and internet connecting at start up so much that takes 30 second more for the internet to get connected instead of instead connection before. I do not like this version and have uninstall it. Its heavy and buggy I think.

I did even initiate a geekbuddy session for a problem but the comodo tech guy after remotely working on my pc caused my window to crash and constant re-boot up crash (BSOD). Thanks god I had comodo time machine to revert back to save.

Now since I uninstalled comodo my network and internet connection at window startup is back to normal and is instant rather then taking a 30 second more to become active because of the new CIS update.

I am disappointed at comodo right now.

Hello All

Can you follow No network connection after using Stealth Ports Wizard (DHCP Broken)

If that doesn’t help; Try This Method

Mine was fine now gone too. What I did was define my trusted network as was before update then block all incoming seems ok now.

I’m not using DHCP on this PC. Still, after the latest update, with Firewall enabled I get no access. It doesn’t even work in Training mode. It was working fine prior to the upgrade.

Can you please take a screenshot of Firewall Events and Your Global Rules?

Kind Regards

Here you go. Thanks!

[attachment deleted by admin]

What happens when uncheck “Protect ARP Cache”?
Also; Are you intending to block any and all SSL/TLS Connections?

Hello all,

Just updated to the most recent CIS without changing any previous settings

Later, restarted and attempted to connect to internet with no success.

Changed the stealth port from “block all incoming…” to “alert me …” and was able to connect.

Changed back to “block all…” and again, not able to connect.

“Block All incoming…” worked fine prior to update. What happened? and how can I use the feature again?

I thank you in advance

win xp sp 3

Hello cmc,

Can you check your global rules and make a screenshot?

Also; How are you connected to the internet? ( Your Computer is connected to a router/another computer etc)

Also; Just by curiosity, Do you have Protect ARP Cache in (Firewall Settings > Advance) - If so disable it;

Kind Regards

Hello and thanks for the reply

1- Protect ARP Cache was enabled. Disabling it did the trick Thank you. I was under this false assumption that updating the application would have left the options unchanged. Can you tell me what else might have been altered due to the latest update?

2- Computer connects to the net via router

3- I have attached screenshot of the global rules for your review. As I do not understand any of it, would you kindly give any recommendation you see fit?

I greatly appreciation your assistance and your contribution to the forum.


[attachment deleted by admin]

Hey CMC,

Are you still having the original issue?

I’m confused :slight_smile:

Kind Regards