No Internet access after 5.4.189068.135 update [Merged]

Jacob,

As stated in previous post, disabling “Protect ARP Cache” solved the problem.

Thanks for the solution

I’ll try unprotecting the ARP cache. Where did you see that I was blocking SSL/TLS? I didn’t add any rule like that. If there is such a rule in place, it must have somehow appeared after the update. I use SSL daily and often.

Your Welcome! :slight_smile:

IF you have any other questions don’t be afraid to ask! :slight_smile:

Kind regards

I unprotected the ARP cache and re-enabled the Firewall. It seems to be working now, including SSL. That’s really odd, isn’t it?

It’s a Bug! If you don’t mind filling a bug report
Follow these guidlines pease :slight_smile:

Certainly. I just tried re-enabling ARP cache protection and it broke web access again, so that definitely seems to be the problem.

Thank you for your time and Patience! :slight_smile:

Kind Regards

Hello;

Please Make sure “Protect ARP Cache” is uncheck in (CIS>Firewall >Firewall Settings > Advance)

Then try again

Kind Regards

Thanks for that information but would that compromise my security?

Ah t’s a bug with ARP cache protection. Hope it will be fixed soon. Thanks Jacob.

In Version 5.4.189068.135 there is a bug; You need to disable ARP Protection;

Will be fixed on Monday (Egemen Reports)

Egemen Acknowledged the bug here

https://forums.comodo.com/news-announcements-feedback-cis/comodo-internet-security-541890681354-released-t72243.0.html;msg514670#msg514670

Will be fixed monday

There is an acknowledged issue with ARP cache protection.

Temporarily disable it until it is fixed; a fix is in the making. Automatic updates are suspended until Monday.

I will move this to the Firewall Help Board.

Merged;

Thanks for the news guys. Looking forward to Monday.

I have just installed the latest update 5.4 and have enabled the protection of the ARP cache and blocking gratuitous ARP frame but this results in breaking my internet connection. I chacked the logs and this is what it is showing.

Windows operating system
blocked
UDP
Source IP 192.168.1.1
Source port 67
Destination IP 255.255.255.255
Destination port 68

Windows operating system
blocked
UDP
Source IP 198.168.1.1
Source port 67
Destination IP 198.168.1.2
Destination port 68

Should I be creating a firewall rule to allow these?

Known Bug;

Comodo will release a bug fix update on monday

I set my router to always assign same IP 192.168.0.2 to my PC’s Mac address.

Then manually configured my PC to use that IP, subnet 255.255.255.0 and default gateway 192.168.0.1 (router) - instead of automatically obtaining.

Also manually configured DNS address on my PC.

This fixed the problem on mine with out turning off ARP, is also faster to get online and always gives you the same IP.