MS edge beta crashes on launch

Tried it one more time. Prevented Edge Beta from starting. Instantly removed. Bye.

IF your running Edge Beta, it’s likely that the files won’t be recognized. Simply whitelisting them as Trusted in the Unrecognized File list should resolve that. CIS will do an automatic analysis of unknowns.

Anyway, if you decide to try it again, just check the Unrecognized files and ensure you do the reboot after the initial scan.


CIS didn’t alert me and it wasn’t listed as unrecognized. It even blocks proper installation of beta (and even dev and canary).

Hi Zee64,

We will check this issue immediately.

Hi Zee64,

It should be fixed now. Could you please restart your machine and check. We could launch edge beta without any problem. If you still have this issue, then kindly check if you see any unrecognized files at File list and provide us the logs requested via PM.

Nope, still blocked. Even installation was partially blocked, even though I gave installer unlimited access. The app didn’t appear in File List.

Assuming you have Auto Containment enabled could you check what happens when you disable Auto Containment?

Even if I disable every protection layer it still fails.

Try setting Firewall in training mode, HIPS off and check (attachments) if your software is blocked.

I don’t want to install software I don’t need but I did it now.

Edge Beta I could install, but

problem 1 (pop ups of Windows): Cannot download Edge Beta - do proof your internet connection. Solved: “Unblock Applications” (look attachments)

problem 2: Installation stopped (look problem 1)

Then beta had installed. Now I uninstall it again.

Foprgotten: My configuration was one of the more restricted.

Sorry but CIS can not block anything when all real-time components are disabled, sounds like either your CIS install is corrupt or something is conflicting with the operation of CIS, whether its a kernel mode driver or a .dll that is being injected into every process which interferes with CIS guard dll. You can try adding edge executable to don’t detect shellcode injections.

Here is video of the issue:

Things to note:

  1. Edge should be pinned to taskbar after installation, but it’s not.
  2. Edge should start after installation, but it does not.
  3. You can briefly see Windows Error Reporting tool in Task Manager.
  4. You can also see Edge being force closed every time I try to open it.

One important information I forgot to mention: Beta was previously fine and only Dev and Canary were affected. But since they moved v90 to Beta channel, now that is affected too. So it stands to reason that whatever changes Microsoft made in that version is causing this and once it hits stable channel it’ll be blocked as well.

At Zee64. I installed the latest beta, 90.0.818.27, on Windows 10 20H2 x64 (19042.867) and it works straight from the box.

Could you try a factory default configuration and see if the problem reproduces or not? This may point the finger to a settings issue. Also could you respond to futuretech’s suggestions whether you have program(s) installed that interfere as futuretech described.

The reason we ask those things is to help narrow down where your problem is because it may be a particular issue with your system. We need your active participation to get a clearer view on what is causing this. Please bear with us.

Sorry, I totally missed his message. My bad.

His suggestion worked. Now it works, thankfull. Still, that’s a workaround and not a fix.

What version of Windows are you on?

His suggestion worked. Now it works, thankfull. Still, that's a workaround and not a fix.
It's a beta build of a third party's software. Demanding a fix would be jumping the gun. The workaround is an established way of making program compatible with CIS when they get offended by the protection against shellcode injections.

I checked your video again and saw you are using the online installer. Correct? I was using the offline installer.

Windows 10 v2010

Yes, but this is well known software that is widely used. And as I mentioned only version 90 is affected and once that one hits stable channel - opps.

Yes, it’s online.

Most probably Microsoft Edge (like Mozilla FireFox is already doing for some time now) is kicking out dll injections (such as guard dll injected by CIS) from their processes to improve security and stability of their product which may cause nasty side effects when attempting to remove the injections.
It’s a battle of giants, there is nothing you can do . . . other than what futuretech already told you.

I cannot find a Windows 10 with version number 2010. However there is an office Insider build with this build number. So. what is your Windows build? Run winver from the start menu and see.

Yes, but this is well known software that is widely used. And as I mentioned only version 90 is affected and once that one hits stable channel - opps.
Hence why we try investigate what the issue is.
Yes, it's online.
Could you try uninstalling and then installing the beta with the offline installer and see if the problem resists? Don't forget to remove the entries in the exceptions for shellcode injections before. You can find the offline installer here: .

It’s 20H2. I just YYMM numbering.

Please read my previous post, the one you are reacting to, and get the version number using the winver command as described.

That is version number. What you want is build number and it is 19042.906.