[merged topic]Translating with the built-in translator is not working

That extension appears to be still working OK on my system.
Note: Click the icon and not the translate button for it to function.

I have been informed that there is a communication issue with the Dragon translate function and the Google servers used for the inbuilt translator.
This is intended to be fixed sometime in the near future.

Thank you for your patience.

Thanks, captainsticks! really help me

You are welcome, I am glad that helped.

It doesn’t work for me either & although I have been in direct contact with GeekBuddy Support Team, they have given up trying to help me, which is unprofessional & unhelpful. :-TD

I have the same problem for over a month :-\

I’m pretty sure that this problem is a dirty move from google against chromium based browsers that use the google translate service; I tried “most” of cromium based browsers to investigate the issue, the only working one was “Titan browser” which is owned by a US software company and in their homepage a google search embedded bar and a big " POWERED BY GOOGLE" on top of it.
Other browsers that didn’t translate:
-Epic browser
-SRWare Iron
-CD of-course
-Baidu Spark

Comodo Dragon not translate more pages, the translation bar says translated but the pages remain in the same language.


Comodo team must solve this program i have sent message to staff and admin here . i hope they will give answer and will solve it.

I use rutube.ru and the translation tool used to work fine from russian to english.
I can’t tell when it happened really as i don’t go often on rutube.ru.
I use Dragon Version
So when i open the russian page, Dragon offers me to translate the page from russian to english,
then it says that the page has been translated, but it’s still in russian, the page stays exactly the same in russian language.
I post a screenshot, maybe it can help.

[attachment deleted by admin]

Known bug…let’s hope they will fix it in the next release…if there would be any…

Merged numerous topics on the same subject matter into one topic.

The chrome extension is working as expected and is a decent workaround (you have to click on the icon for it to translate)

I just recently decided to try Comodo Dragon and I absolutely love it. However, I encountered a show stopper when I tried to use the translation feature built into all Chromium browsers. Whether prompted or automatic, the browser reports it has successfully translated the web page, but nothing is changed. I’m more competent than most with computer troubleshooting, and nothing I’ve tried fixes it. I’ve gone through the language settings, re-installed it, and disabled AV to no avail. Dragon is significantly faster, more attractive, and friendlier than Chromium, so I really hope this can be resolved. P.S. I’m using Windows 7 x64 updated.

Hi and welcome keepmada,
I have merged your topic into this topic.
I hope the issue is resolved with future versions, in the mean time there is a workaround at reply 15 of this topic.

Kind regards.

Sorry for my english.

My COMODO Dragon does not translate.
So in 4 my computer.
Dragon translate does not work…about 2 month.

Thank for the help.

Bye bye from Italy.


Known bug.

Merged the above topic on the same subject matter into this topic.

Comodo Dragon Version the translator does not work. Do you plan to fix it? I need it and can not find good alternatives.

You could try: XTranslate - Chrome Web Store ,which works for me using CD. Though there are plenty to choose from at the chrome web store.