Manual Steps to uninstall Comodo AntiVirus

Manual Un-installation Method for Comodo AntiVirus

This manual Un-installation can be used under the following conditions

  1. User doesn’t see any entry of CAV in “Control
    Panel->Add/Remove Programs” section.

  2. When user tries to un-install CAV from “Add/Remove
    Programs” section, but not able to do so as nothing
    happens after clicking on 'Change/Remove" link in it.

Steps for Manual Un-Installation

I. Go to “Start->Run” and type “cmd” in combo box and
press OK button. It will open DOS console window.

II. Use 'cd" DOS command to change directory to CAV
installation directory, which is by default
‘[Program Files Folder]\Comodo\Comodo AntiVirus’,
so if you have OS installed in ‘C’ drive, it should
be “C:\Program Files\Comodo\Comodo AntiVirus”.

III. Two methods are there to remove the windows socket layer.

    A. You can find a “WinSock2_backup.reg” file in CAV 
       installed directory. This file contains the backup 
       of your registry keys before CAV installation. 
       Just double click the file and it will restore the 
       registry entries prior to CAV installation. 

    B. Type in "InstLsp.exe -u" and press "Enter" key. 
       This will un-install the windows socket layer.

IV. To remove the driver and service just double click the
file “uninstCavasmDrv.cmd” in the CAV installed folder.
This will remove the service and driver from your system.

V. Above method removes Comodo Antivirus configuration from 
   system, but still files will be there in installation 
   directory that you can delete manually. 

VI. One more thing it does not remove Comodo Launch Pad from 
    system, in case you have CAV as the only installed product 
    and want to un-install "Comodo Launch Pad" also, you will 
    have to delete CLP files manually.
    CLP is installed at following location:
    [Program Files Folder]\Comodo\LaunchPad

If anybody is experiencing any problem with setup not mentioned 
above,please add your problem and we will try to help as much 
as we can.

Currently we are working on our own installer, we will be releasing 
CAV with its own installer soon.

Hey Ruban,

You can’t fool me - you’re no newbie!! LOL

If the above steps will categorically fix the uninstall problem, is there any chance of these steps being put into a script to make it easier for Mr.and Mrs. Average to do, if they have to?

Would the following do the job?

@echo off
cd “\program files\comodo\comodo antivirus”

echo Restoring previous WindowsSockets
run winsock2_backup.reg /w

rem alternatively
rem run InstLsp.exe -u /w

echo Windows Sockets restored
echo Press any key to continue removal
pause >nul:

echo Removing driver and service
run uninstCavasmDrv.cmd /w
echo Driver and Service stoppedand removed
echo Press any key to continue manual removal
pause >nul:

echo Removing subdirectories and files
cd …
del “c\program files\comodo\comodo antivirus*.* /s”
echo Subdirectories and files removed
echo Press any key to continue
pause >nul:

echo Removing Anti Virus folder
cd …
rd “comodo antivirus”

echo Manual removal complete - please reboot your system
pause >nul:

Please note - I haven’t tested this script - use at your own peril! There is no error trapping no nothing, just raw removal with a handful of pauses just so you can go “Oops!” halfway through, rather than at the end. LOL

P.S. If we’ve dropped to DOS in step 2, won’t we find it rather hard to double click anything in step 3A? :wink:

Hope this helps,
Ewen :slight_smile:
(WCF3) (WCF3) (WCF3)

Newbee, Right…LOL… dude your too much on the money… simplifing the uninstall, I did not realize there was a copy of registry… Thank you,

I guess I am confused, Support (Which still has not contacted me after 6 days) could have mentioned that fact a long time ago and saved every one mental CPU Time !!!

I think your support in Sheeps Clothing…ROFLMAO

No, Ruban is no noob. Yes, Ruban is part of Comodo as well.

As a result of the many questions support has been getting concerning this topic, we decided to go straight to one of the sources on this one and have him post the answer directly to the gang.

Politicallyfactuallyincorrect! :slight_smile:
You have been getting help from Comodo support and developers directly!


I stand corrected then, non of the forum folks identified themselfs as support, So I was not aware they were responding… I appologise for my FactuallyIncorrect status. 1 million years ago, I could have placed my tail between my legs, so please accept my rose coloured glass approach…

No worries:-)

we are here to help and there are quite few people from developers to support teams that are taking part and helping.
our goal is: No question will go unanswered!


As a newbi with all these cmd promts as such. I am having problems following what to do starting with step 2. Can anyone make if more simple like exactly what to type at each screen or step?

Rick24: Sorry to hear you’re having uninstallation issues.

We’ve created a file (attached to this post) that should help you. Essentially, it’s a batch file that will automatically do the manual steps we’ve outlined below. (Panic: Tx and note minor modification to the *.bat.)

Pls do the following:

  1. Download the ‘uninstall’ file to your desktop
  2. Double click on file to uncompress it. Pls select your desktop as a destination for the unzipped file.
  3. You should now have a new file on your desktop called ‘uninstall CAV.bat’. Pls double click it.
  4. This will launch a new window (DOS) and uninstall CAV automatically.
  5. Pls remember to reboot your PC after uninstallation is completed. The window will have a message within it stating ‘Manual removal complete - please reboot your system’.

This should resolve your issue. Pls let us know how this goes.

[attachment deleted by admin]

I ran the file that you attached. I did get the message at the end ‘Manual removal complete - please reboot your system’. After boot my system will not boot normally. I am in safe mode once again. I continue to get a small window that keeps popping up that says

Please wait while windows configures Comodo Anti-Virus 1.1

Screenshots of process attached.

[attachment deleted by admin]

rik24: Please unzip the file first, then run the batch file, as this is the optimum way of running the batch file. Although unlikely, and I’m not sure how, it’s possible that skipping steps 2 and 3 influence this uninstallation. Either way, I’ve notified the lead CAV developer of your predicament, and have asked him to jump into this thread to resolve this - he’s out of the office right now, but you should hear from him within 24 hours at the latest.

The file was unzipped. The first 3 screenshots are step by step. I could only upload a limited number of screenshots that is why I skipped some shots until the completion message.

Hi rick24,
It seems that the CAV product identifier is not removed from the registry by this automated removal tool and hence windows installer tries to reinstall CAV on your system. Shortly we give you a utility which will fix this issue.


Hi rick24,
You have already run ‘uninstall CAV.bat’ but still you are facing the problem of interruption of windows installer to reinstall Comodo AntiVirus 1.1. To fix this problem we have created a utility and the same is attached here.
Pl follow these steps

  1. Download the 'Remove Registry entry after manual file to your desktop
  2. Double click on file to uncompress it. Pls select your desktop as a destination for the unzipped file.
  3. You should now have a new file on your desktop called ‘RemoveReg.exe’. Pls double click it.
  4. You will get message "Registry entry related to CAV has been successfully removed. Reboot your machine…
  1. Reboot your system.

This will resolve your issue. Pl let us know.


[attachment deleted by admin]

Well your utility does not work. Please help with this issue promtly.

Bloody hell!!
what have you done Rick, soldered the AV onto your motherboard!!! :slight_smile: (don’t flame me… just joking…)

Ok this is not good. Pls ask Paulo to get you somoene in dev to help u.

sorry for the inconvience…


I have the same problem and it’s driving me crazy. I’ve downloaded the the file and it’s not working. I downloaded 6 copies of that but I could,t open any of them. Even it’s very small, when I was opening it it gained in size till 900 mega (I tried to open it with different programs and theresponse was the same :frowning: )

Evere time I try to install something, uninstall, work with command line or msconfig etc. it keeps opening the install file for comodo. What should I do?

These 2 utilities have not solved the problem for me either. It is really getting irritating, that I can’t get this thing off my system. Any more ideas, how to get rid of this thing?

I have tried unsuccessfully to install CAV 5 times, last two times get same symptom:
Seems to be ok, prompts for a reboot, but on reaching desktop flashes a blue screen FAST (no time to read it - caught the word KERNEL) then auto reboots.
rinses and repeats…
and repeats…
in the meantime generating disk errors 32MB of 321 file fragmentsn in four folders

I am using W2k Pro SP4 with all updates on a PII 256MB multi boot test machine.

I had to boot to safe mode, found that I couldn’t use add/remove programs to uninstall as the installer is not available in safe mode, so I uninstalled MANUALLY

I Deleted the AV folders, and refs in common (after copying the backup reg file - ty for that tip)
used X-Setup to remove TWO (!!) references to CAV in add/remove (there are two CPFs there too for some odd reason)

I rebooted to the 98SE half of the system to remove the three locked files remaining, rebooted back to 2K pro, had to cancel an attempt to configure a non existant CAV THREE times.

All looked good at desktop, so I ran two registry cleaners WINDOC, and EasyClean.
Then I manually cleaned the registry

I got my trashed system back

HOWEVER, I would not recommend this method for the inexperienced.

A BETTER method is to take precautions first… before installing a beta, backup the registry and/or create a restore point (I didn’t bother this time, as this was a test machine) then if you need to uninstall CAV, delete the folders and replace the registry with the backup or restore to the saved point.

I think I will now wait for version 2, and see if that works ok (I am not giving up, as Comodo looks interesting, I want to try it out)

I am still using CPF with no problems, apart from an earlier version asking multiple permissions about the same thing (ie it was NOT remembering the answers you gave, even though the box was ticked). But it seems to have settled down now, after a recent update.

Keep up the good work lads. (:WAV) (:NRD)

Hi Kail,
Did you get any success/error message after running this ‘RemoveReg.exe’?