Main Service For CrashPlan Cannot AutoStart Or Connect To Server [M1254]

A. THE BUG/ISSUE (Varies from issue to issue)
Can U reproduce the problem & if so how reliably?:
Every time.
If U can, exact steps to reproduce. If not, exactly what U did & what happened:
1: Install Crashplan from this link:
2:Note that when crashplan starts with Windows the crashplan program is not able to connect to server. It shows a popup warning that it is not able to connect to the server.
3:Even choosing to reconnect is not able to get it to be able to connect.
4: Further digging shows that when crashplan is installed there is a service installed called “CrashPlanService” (CrashPlan Backup Service, auto start), which does not auto-start with Windows.
One or two sentences explaining what actually happened:
When installing Crashplan it installs a service called “CrashPlanService” (CrashPlan Backup Service, auto start), but when I install CIS 7, 8 beta or Firewall 7, 8 beta (I look install only Firewall 7, 8 beta) the “CrashPlanService” service does not auto-start. Even adding it as an exclusion in the Firewall, and an exclusion for the Auto-Sandbox, is not able to get it to work. Uninstalling CIS is able to get this working correctly.
One or two sentences explaining what you expected to happen:
Crashplan, and its services, should be able to auto-start with Windows. They should also be able to connect to the internet when CIS is installed.
If a software compatibility problem have you tried the advice to make programs work with CIS?:
Any software except CIS/OS involved? If so - name, & exact version:
VM VirtuallBox: almost empty no Antivirus program only Firewall 7.
Any other information, eg your guess at the cause, how U tried to fix it etc:
When Crashplan fails to connect to the server it gets an error message Code42. Mesage: “Unable to connect to the backup engine, retry? No, Yes”.

Exact CIS version & configuration:
Firewall 7, 0, 317799, 4142
Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
Internet Security: partially limited. Hips d.
Have U made any other changes to the default config? (egs here.):
In firewall enabled all security settings. ARP … Disabled trust certificates and the installer. It is also set to Custom Ruleset.
All alerts are enabled. Included in the maximum display 999. Sound disabled :slight_smile:
Have U updated (without uninstall) from CIS 5 or CIS6?:
I installed 7 Firewall version after removing 6 Firewall.
if so, have U tried a a a clean reinstall - if not please do?:
I uninstalled and reinstalled on a clean Win XP Pro SP3 on VM VirtuallBox
Have U imported a config from a previous version of CIS:
Yes on my real system, but only from Comodo Firewall Version 7 to Comodo Firewall Version 7. However, for the VM Comodo Firewall 7 installation on VM VirtualBox I did not import a config. I modified the settings manually.
if so, have U tried a standard config - if not please do:
I have not tried it with default settings.
OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
Win XP Pro SP3 32bit. Administrator on real PC on VM VirtualBox. VM VirtualBOX Win XP Pro SP3 32bit no updates. Real PC Win XP Pro 32bit SP1 + SP2 + SP3 + many updates.
Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
a=nothing in VM VirtualBox b=nothing in VM VirtualBox

[attachment deleted by admin]

As you are running the Beta it’s probably best if you submit this bug report in the Bug Reporting section for the Beta versions. That bug report is here and the required format is provided here.

Please create this report in that section and let me know if you have any questions. I will now move this report to Resolved as you are going to create a new one in that board.

Thank you.

No sense in making new reports in them there is nothing that will help you understand why. You need to look in the code Comodo or in the program code, Crashplan behavior is the same in version 7 and 8. I can copy the theme in the desired section by removing replacing words “Comodo version 7” on “Comodo version 8 beta”. Why do it? Consider that I use 7 version installed in the virtual machine, version 7 firewall. I can remove the word beta 8. To be honest I’m tired of writing the same thing me suggest to do it in 3 times. Twice I already wrote.

Me copy the text in the section 8 beta?

I should first clarify. I am a volunteer moderator. I am managing the bug reporting board, and essentially acting as an intermediary. Thus, I have no direct access to the code.

Also, the real reason I mentioned creating it in the Beta board instead of the regular board, is because the required format for reporting Beta bugs is simpler than that for reporting them for stable versions. Thus, I was just trying to save you a bit of work.

Also, are you saying that you have already created a bug report for this? If so, please link to that so I can take a look.

Let me know if you have any questions.

Thanks. logs Comodo Firewall v 7. Logs for Firewall 8 beta version there is no sense to create.

Are you saying that you would prefer to submit this bug report for V7?

I will give a link to this topic supports product of CrashPlan (Code42), if need create a new theme let they do it (employee Code42) and explore the work of the two programs. They know English well, I translate programmatically. Software translates bad. Code42 this more need than me.

I made the logs only 7 version. I not did the logs from the 8 version. Beta I have only to look. Next the company Cod42 deals with this problem if they need it. VM VirtualBox is available to all free of charge is version for Linux and Windows.

I will move this bug report back to the main bug reporting section. I have just pasted the required format into the first post. Please fill it out to the best of your ability. Just replace the question marks with your responses. If there’s anything I can do to help please feel free to ask.

Thank you.

Thank you very much for filling out the format in the first post. Am I understanding correctly that the main issue here is that CrashPlan is not able to auto-start if CIS is installed? Also, CrashPlan is not able to connect when CIS is installed?

Are these the two main issues you are experiencing?

Also, do you mind if I make some edits to your first post?

Thank you.

“Am I understanding correctly that the main issue here is that CrashPlan is not able to auto-start if CIS is installed? Also, CrashPlan is not able to connect when CIS is installed?” Yes. When CIS, Firewall is installed “service” (not program) crashplan not start in the manual start, not start in the automatic start mode. Program (not service) crashplan auto start, but cannot connect to the server Code42.

“Are these the two main issues you are experiencing?” Relating to the program crashplan, yes only this.

“Also, do you mind if I make some edits to your first post?” Give me your version of the edited text in the mail or privat message and I will say exactly. Or write what you want to change.

When I edit it I’ll make sure to save the original so if there are any issues it can easily be returned.

Okay, so the program can auto-start, but the main service does not auto-start and it cannot connect to the server. Is that correct?


“Okay, so the program can auto-start, but the main service does not auto-start and it cannot connect to the server. Is that correct?” Yes, exactly. And when I force start the main service, the main service (gif video) not start.

Thank you. I have modified the first post and the title. Please let me know if everything looks correct. If something is incorrect please let me know.

Also, can you please post a link to CrashPlan so the devs can more easily identify the program?
In addition, please let me know of any security software which is installed, or used to be installed, on the real system as well.
Also, please create and attach a diagnostics report to your first post. Instructions on how to do that can be found here.

Let me know if you have any questions. Thank you.

Text normaly. The old text can be removed.

Thank you, I have done so.

Also, please provide the information I have requested here:

Let me know if you have any questions.

Thank you.

PM reminder sent.

Than not satisfied these logs

Sorry, I had not realized that all the information was contained in that zip file.

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again.

I forgot to write the firewall settings: Custom Ruleset. Logs should be translated. They are translated normaly.