Installation of CFW leads to instant BSOD [M716]

A. THE BUG/ISSUE (Varies from issue to issue)
[ol]- Summary – Installing CFW leads to BSOD Give a clear summary in the topic subject, NOT here.

  • Can U reproduce the problem & if so how reliably?: Yes. Happens every time.
  • If U can, exact steps to reproduce. If not, exactly what U did & what happened:
    a: Installed CFW in the normal way with Administrative privileges. All other Security SW turned off.
    b: Installation ends in BSOD
    c: The machine becomes non-bootable. Runs only in Safe Mode
  • If not obvious, what U expected to happen: Install ending normally
  • If a software compatibility problem have U tried the conflict FAQ?: No SW conflicts (?)
  • Any software except CFW/OS involved? If so - name, & exact version: hswpan.sys driver version (Ozmo WPAN Protocol Driver, Ozmo Inc.)
  • Any other information, eg your guess at the cause, how U tried to fix it etc: Have tried to install several times. Always have to restore Image type of back-up.

B. YOUR SETUP (Likely the same for each issue, so you can copy forward)
[ol]- Exact CFW version & configuration: 6.3.302093.2976

  • Modules enabled & level. HIPS, Firewall, actually did not come this far.:
  • Have U made any other changes to the default config? (egs here.): No
  • Have U updated (without uninstall) from a CIS 5?: No
    [li]if so, have U tried a a clean reinstall - if not please do?: Yes
    [/li]- Have U imported a config from a previous version of CIS: No
    [li]if so, have U tried a standard config - if not please do: Yes
    [/li]- OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used: Windows 7 Professional (FI), SP1, 64-bit, Admin, No VM
  • Other security/s’box software a) currently installed b) installed since OS: a= avast! 2014 Antivirus, WinPatrol, SUPERAntiSpyware, Malwarebytes Anti-Malware, Spybot Search & Destroy, SpywareBlaster (all latest versions/releases) b= Some of the attached files have cryptic names due to the fact that I accidentally deleted and overwrote them. Tried to recover them. If not useful, then will recreate the problem once more. :frowning:


 Both dumps are in compressed format (*.zip).

 Attached a Process Explorer view of the running processes during installation. Process Explorer (itself) was 
 [b]not[/b] running during the installation. All other processes (including the CFW Installer) were running.

A Complete Dump can be downloaded from here:!183&ithint=file,.zip&authkey=!ABPz4uDyeY79hOc

[attachment deleted by admin]

Please upload a full dump to a file sharing site, such as this one and post the download link. The devs have informed me that it is nearly always necessary for them to have a full dump, and not just a mini-dump, in order to figure out what is causing the BSOD and fix it.

Thank you.

Thanks for the instructions.

Uploaded the mini dump and the full memory dump in the address now provided at the bottom of the original report.

Both dumps are in compressed format (*.zip).

Okay. Only one more thing in now required. I did not see a process list in the zip file. Unless I missed it, can you please also attach a list of the running processes on your computer? After that I can forward this to the devs.

Thank you.

Do you mean the processes that were running on the workstation just before the BSOD took place?

Usually there are more processes running on the workstation, but before installing SW I reduce the number of running processes.

I guess you mean the processes that were running just before the BSOD took place. The Comodo installer will not be on the process list unless I rerun the beginning of the installation and stop the installation before the BSOD takes place.

So does the Comodo installer need to be in the memory as well?

All processes which were running, excluding the installer, will be fine. It should serve as a good baseline so the devs know what else was running.

Thank you.

Attached a Process Explorer view of the running processes during installation. Process Explorer (itself) was not running during the installation. All other processes (including the CFW Installer) were running.

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may not communicate with you in the forum or by PM/IM, depending on time, availability, and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again.

You are welcome. Thanks also for the support in reporting the issue.

Any progress on fixing this issue?

Cannot use Comodo Firewall at all until fixed.

At the moment I have no new information. Hopefully this will be fixed in the next version.

The devs have informed me that they are unable to reproduce your issue. Are you still experiencing this problem?

If so please configure your computer to create what is known as a Complete Memory dump in the case of a BSOD. Instructions on how to do this can be found here. Let me know if you have any questions at all.

Just so you are aware, this dump file will be quite large. However, you should still be able to compress it and upload it to a file sharing site as before.

Once you have completed this, or have any questions, respond to this topic.

Thank you.

PM sent inquiring whether the issue is still experienced for CIS version 7.0.313494.4115.

Yes, still experiencing the same BSOD for Comodo Firewall version 7.0.313494.4115.

Will upload the full dump to an uploading site. Will inform when it is done. Takes some time, since the full dump is quite large even when it is compressed.

A couple of small files are attached.

Will attach file of running processes list as well as soon as I get the laptop back in business.

[attachment deleted by admin]

Thank you. By Full Dump do you mean Complete Dump? If so, how large is the file?

Thanks again.

Here is the link to the compressed full dump (complete dump)

The compressed file size is ca 225 MB, and the uncompressed file size is ca 837 MB.

Attached the list of running processes as Process Explorer sees them. (Process Explorer itself should of course be excluded from the list. It was not running when the BSOD took place.)

The abnormal ending takes place at the same module as before, i.e. hswpan.sys, which is a driver for the cordless Wi-Fi mouse on the laptop workstation.

[attachment deleted by admin]

Thank you. I have updated the first post, and also updated the tracker.

Have sent the requested file (hswpan.sys) to the Comodo engineer, who requested it by email.

Will attach the file here as well.

Will attach the file compressed, since your mail server falsely detected the uncompressed file as “Klez Virus”.

[attachment deleted by admin]

Hi Semper_Fidelis,

Devs have marked this issue as “Fixed”. Please verify.


Hi qmarius,

According to the Comodo tech rep the issue will be fixed in CIS8.0, which will be released on September 30, 2014.

Will be able to confirm after that whether fixed or not.