How to uninstall Comodo Firewall?

No way to uninstall firewall because the REMOVE button is unavailable in “ADD/REMOVE PROGRAMS”. Some weeks ago I’ve tried to uninstall it manually but registry was corrupted and XP don’t starts anymore (tanks to Acronis Trueimage I’ve saved my data).
My question is: how can I do to safely remove (and reinstall) Comodo Personal Firewall if the REMOVE button isn’t available? I heard somewhere about a script…

1- CD to personal firewall installation folder
2- type “fwconfig -uninstall” from the command line
3- restart Windows
4- Manually delete all files

I have a situation where the folders no longer exist and some registry entries have been removed but system still thinks the Firewall is running. I can’t connect to internet and I can’t figure out what else to remove. Please help! I esentially have a non-internet system now.

In deep do

I have been in similar situations with other software (not from Comodo), an have resolved it by doing the following:

(1) Installing the software again, and reboot. This should then recreate the filesystem and registry entries.

(2) Uninstalling the software. First try the Add/Remove Programs screen; otherwise try egemen’s advice above.

Hope this helps.


I hate to bump and old thread, but I don’t want to flood the forums with 214532 threads with the same cause. I have installed the latest version of CPF and used my .reg backup file from the 2.3Beta version of CPF, which caused lots of problems and I had to uninstall it. I don’t see “Comodo” anywhere in the Add/Remove and when I try to reinstall, it says that CPF is already installed and asks if I want to uninstall it. When I press YES, nothing happens. I tried this:

It asked me if I want to uninstall CPF, I answered YES, rebooted and when I came back it was still considered as installed and I couldn’t reinstall it.

What do I do?

Oh, nevermind.

I just opened up regedit, searched for all “Comodo” and removed it all.

Reinstalling Comodo PF as we speak. :slight_smile:

Don’t know if this is of any help, but i use CrapCleaner to check out inconsistencies in the registry & its Tools>Uninstall interface to uninstall programs. So far it works for me.

braindrained (R)

I also have trouble uninstalling CPF. The situation in my case is like this:

a) Cannot see the Comodo entry in Add/Remove Programs
b) When I try to reinstall I get a message saying that CPF is already installed and asks if I want to uninstall it. When I press yes, NOTHING happens
c) There is no Comodo Folder in Program Files. I have deleted it as it was empty anyway.

From what I have figured out by reading relative posts, I have to manually delete some registry entries. Since I don’t want to do that blindly, can anyone tell me what those registry entries might be?

Do you still have this issue? (I ask since we were discussing GRC in the other topic)


No problem is solved. I manually deleted all comodo entries from the registry and reinstalled. Now it works fine.

I am having the same problem have used regedit to search for comodo it only came up with 2 files which I deleted and I still have the problem when trying to reinstall it says program already installed do I want to uninstall and when selected nothing happens. ???

I am not an expert but there should have been a lot more than 2 entries…

Have you tried Egemen’s steps from his reply (reply #1) in this thread?


PS: And yes, there are a lot more registry entries than just two… What were you using as the search field in regedit? (ie, Comodo, CPF, etc)

greetings mates!

My problem with comodo firewall is a little different! I tried to uninstall comodo , but when the comodo’s uninstaller started the uninstallation process , it told me that it can not stop comodo’s service and it stopped! I installed it again and tried to uninstall it in safe mode! The uninstall process completed , but still windows think that the program is running! I installed it again and tried to uninstall it using uninstallers , such as smarty uninstaller , ashampoo and your uninstaller! But some traces left and I used some registry editors to remove comodo files manually! Although I have searched and deleted everything related to comodo , windows still think that comodo is running! Need some help here , I am going crazy with this firewall!



I see no one replied to you, and I apologize. Are you still hanging in limbo, or have you been able to resolve the problem?

I’m here to help, if you are still in need.


I have been through a similar process as thanatosades. I found three registry entries called Comodo Network Engine. RegEdit would not allow these to be deleted, but I (apparently) deleted them using a different program (VAS Free System Tools). However, as soon as a looked away then came back to the same folder, the entry reappeared (not deleted at all).
Has anyone any idea how to delete the Comodo Network Engine entries?
Can it be done from a login specifically for administrator? My admin login doesn’t work, but I can take the computer to someone who has other admin logins.

Welcome to the forums, Builder!

Yes, you will need the appropriate Administrative Privileges, in order to be able to do what you’re trying to do.

You also want to make sure (prior to removing the registry entries) that you stop the Firewall Service and Driver:

Service is: CmdAgent
Driver is: CmdMon
I recommend ServiWin as an easy way to do this. Simply change the Startup Type to “Disabled.”

Also remove the startup entry for CPF - Go to Start/Run, type “msconfig”. Go to the Startup tab, find the entry for CPF, and uncheck the box. Click Apply, then OK.

Then reboot the computer.

Hope that helps,


Thanks LM. Comodo no longer exists in Services, so there was nothing to disable. I am long past that point, thanks to advice from other support staff.

There is no startup tab for CPF in msconfig. That would seem to make sense (what you suggested), to remove the startup engine so that new version of CPF will not believe that an old version is still installed. However, apparently I am past that point as well. No CPF representation in msconfig.

I still have a few registry entries for “Comodo Network Engine”, the perpetrator. I have admin privileges, so I should have access to the entries to delete them But I can’t delete them.

(1) Can I change their values somehow so that the new CPF Pro will not recognize the old registry entries? I can’t change these entries with anything I know. I can’t even rename them now with what I know.

(2) Can I access the uninstall file from the old version from the Comodo web site? A support person sent that file via email to a friend, who cannnot access it at this time because he has a motherboard problem or he would send it to me. Or is the uninstall file posted somewhere I can grab it? Maybe it would clean out the last few registry entries.

(3) Any other suggestions? I apparently have the engine starting at startup, with nothing to run. But the new CFP sees the engine running and determines that an old version of CPF is still installed. The file fwconfig is gone from my computer, if that counts for anything.

CFP is working SO well in my other computer. This whole issue began with an error I made with the activation code in the old version. Thank God that’s gone with CFP 2.4


In the first page of this thread, there are command-line instructions from Egemen for manually uninstalling CPF. If you’ve already followed those with no joy, then you might try this, so that you can delete those stubborn registry entries.

Open Device Manager.

Go to View, select Show Hidden Devices.

Scroll down to the Non-Plug and Play Drivers.

You should see two entries for Comodo:
Comodo Application Engine
Comodo Network Engine

Disable if they’re still active. Reboot your computer. Now see if you can delete those registry entries. BTW, are you using RegEdit, or some 3rd party registry tool?


Thanks Little Mac. My wife’s computer is now the proud possessor of the spanking clean new CFP 2.4 The tentacles are out from the old version.

It is worth nothing that while I could disable Comodo Network Engine (Comodo Application Engine was not in the machine any longer) using Device Manager, I could not later delete the files using RegEdit (not a 3rd party registry editor). I returned to device manager to see that the engine was disabled, right clicked, and learned that I could delete the engine from there. It left peaceably with no fuss and after a reboot was permanently gone.

Thanks to you and other Comodo staff support for your patience and good suggestions. Though I must admit, you gave the straight answers while the others directed me to forum discussions that had no practical bearing on my problem. Still very prompt replies though, everyone. (:CLP)