How to uninstall Comodo Firewall?

Great, Builder, I’m glad that worked out! (:CLP)

As far as the answers, well, we all have different ways of looking at things. Sometimes a different perspective is the one we need… :wink:

Sometimes I’m out in left field, sometimes I nail it… The good thing is, you got where you needed to go.

Glad to help,


I got where I needed to go, but I emphasize that everyone at Comodo support was willing to help and to give more if what they advised was not enough.

Through the whole agonizing process of over three days (about 30 hours all told), I always had confidence that I would get through the problem. I had no experience at removing stuff from a registry and had been warned many times about it. But the Comodo guys walked me through it step by step, as if it was a driving lesson.

Great job, everyone! :■■■■

I’m hoping somebody can help me. I’m having similar problems uninstalling Comodo Firewall as well. I’ve tried EVERYTHING in this thread and I’m still not having any luck. It uninstalls “fine,” but Windows Security Center always says Comodo is still running, even after it has been uninstalled. I’ve re-installed, disabled the services, and uninstalled several times, all with no luck. Also, I’ve been unable to delete the Comodo Application Agent using regedit. It’s not a permissions issue, b/c I’m logged in as the Administrator and I can delete other registry entries. Does anyone have any more suggestions? This is getting VERY FRUSTRATING. I use Comodo on my own PC, but I’m trying to remove it from a family member’s and I’m running into this problem. Thanks for the help.

I’ve had continuous problems with 2.4 so wanted to go back to 2.3 but i am having no success to delete those legacy_cmdagent, legacy_inspect,etc entries in the register using regedit. I tried everything mentioned here but to no avail. Uninstall works alright but not able to delete these entries for a clean install.

Any suggestions please


Those registries are easy to delete. Right click on the key entries (not the key values) in question and select the properties/permissions and grant yourself full control. Then you can delete them. I think by default windows sets all legacy keys this way.

Thanks soyabeaner, that was the trick.
That’s another thing I like about comodo. There are lots of experts here and I have learned a lot and still learning.

My appreciation goes to all

P.S. After deleting those entries I installed 2.4 again to try it once more. And so far it’s jolly good.



If soyabeaner’s tip for the registry keys doesn’t help, you might need to rebuild the Security Center Repository. This is easily accomplished and we can help you with that.

Once the reg keys are gone, see if WSC is still saying CFP is active, and we’ll go from there…


Thanks for the suggestions everyone. I’ll have access to this PC again this weekend, so I’ll post back with the results.

I’m reviving this thread because this is exactly what is happening with me.

I’ve removed Comodo completely. No reg entries, no folders, no device manager instances, no services, yet Windows Security Center still shows Comodo is running as the firewall.

I’ve reinstalled and uninstalled and downloaded the unistaller.

Can someone please help me out?


Hello bustermattie

Welcome to Comodo

  1. stop the WMI Service
  2. delete the “repository” folder in C:\windows\system32\wbem
  3. start the WMI Service. Starting the service rebuilds the deleted folder and the database.


The windows security center is useless (as stated many times before). For one thing, it’s already been proven the false alert that CFP is still on your computer. For another, you don’t need a service from M$ to tell you that your firewall or antivirus is running or not - you can see it yourself from the system tray. Other times, because it’s a Windows service, it usually loads before your security programs do, and some people think during that short boot-up sequence that their security programs aren’t on 88).

Hello, the name is Jose. Sorry but I’m new to this=/
I’ve been reading a lots of comments about C-O-M-O-D-O firewall.
Which I heard so many great things about it. So, here recent I’ve downloaded the software.
Which I got an error. So, I tried to un-install the firewall and reinstall it, but I get a message says.
“Comodo firewall is already install in your system.” Alas, I don’t know what to do.
I would love to run this software on the PC but I need help with it.

I would surly appreciated if someone can help me.
Thank you=)

I am having the same problem as epikal. I just installed Comodo. And when i restarted it said the program could not start up . Because it was missing …something. Cant remember exactly what. But now if i got to delete it . In Add/ Remove. It just says unable to delete , access denied.

And i am the admin on this computer. So i dont know why my access is denied.

Also when i try and uninstall it using the comodo uninstaller . It doesnt do anything.

Any help would be greatly appreciated. And my Computer know how is not that great. Just an FYI.

I guess it’s not AmigaOS 4


not even MorphOS

but, anyway, stay with REBOL

I read this post but I quess I’m an idiot because I didn’t understand what to do. On the first step CD to personal Firewall folder…problem is I don’t have a folder for it, it was deleted, but for some reason I still have it running in Control Panal>Security Center>firewall.

Can you please help me with this

okiegal ~

Here’s a link to something a little easier to understand, I think.;msg39350#msg39350

In this post by pandlouk, he has attached a batch file (labeled as “comodo”), it shows right below the red line towards the bottom of the post. You download and unzip that file, run it, etc. Just follow his instructions. If you have any questions, please ask. We’re here to help.


PS: I’d suggest disconnecting from the web (unhook your internet cable), and exit/shut down CFP, if it’s running (just the icon in systray, if it’s there). Even better yet, reboot into SafeMode (commonly accessed by pressing F8 once per second once your BIOS splash screen shows when rebooting). In SafeMode the firewall won’t be running, so there shouldn’t be any conflict issues.

why would you install it in the first place???

just kiddin.

you can’t my friend.

install fresh windows will be easier.

Hello everyone
I’ve got quite the same problem as some of you. My comodo update didn’t work so i uninstalled it hoping to install it again. I did that through Control Panel and now i can’t see it among the other programs in “Programs and Features” (the Vista’s version of add/remove programs). I still had the comodo firewall running when i go to your forum and followed the steps written above. I deleted all the data in program files, (i think i) deleted all the registry related files, BUT when i try to run the installation file it says that Comodo firewall is already installed and asks me whether i’d like it to be uninstalled. When i click Yes nothing happens. I’ve tried that ZIP file from the other topic and it doesn’t work… (maybe because i don’t have the files anymore).
Btw, i’ve got Vista.
What shall i do? Please help me, because i’ve become really fond of Comodo - it’s such a nice firewall.
Thank you very much for your help
Kind regards,

Thanks for JJasper, Little mac (February 05 2007) and Soyabeaner (February 05 2007) recomendations. It really worked. Comodo firewall has been completely uninstalled from my pc and Windows Security Center has no references about Comodo Firewall now. I uninstalled it when i was trying to find for something that was not working well at my computer. Surely after I finish doing this, I will install Comodo Firewall again. As others say: it is a nice firewall.
As a little contribution to the forum, here is what I found about deleting, renaming or rebuilding the repository. You can seek for aditional information at:
Thanks to all of you.

I wanted to start a new topic, but I cannot find how to start a new topic. I have searched using the search block no help. I have the problem that I cannot remove COMODO. I have uninstalled it via the control Panel uninstall progams, it is still there. I went into the regedit and removed all references to COMODO but I cannot remove parts of the program in the program. Will not let remove some of the items. It has stopped me from updating my antivirus program, even in safe mode I cannot remove it. I know longer want any part of comodo. Just want it permanently removed from my computer. Appreciate any help I can get. I will try it out on my old test computer and see if I can learn to make it work as it should. Do not have time on this computer to fool around with a program that I do not understand. Thanks