How to Recover your Drive, if CTM made it not boot

Excuse me for playing the roll of technical support, for all those whose computer would not boot after uninstallying CTM. The bug(s) seem to result in corrupting the MBR (master boot record), and/or the partition table that tells your computer where on a disk to find your partitions, and bootable operatiing systems.

After my drive did not boot, I found that many partition management and recovery programs did not even recognize my main hard drive. If this happens, even if you have a backup you can not restore it, because restore software needs to find the disk, and where on the disk to put the restored files or image!

I found the wonderful free utility, testdisk, saved me from reinstall of windows and data loss. Get it here:
Partition Recovery and File Undelete
Test can repair the generic code in your MBR, find the lost bootable partition(s), and rewrite the partition table to tell software where to find the partitions on your disks. In my case, testdisk told me my driver was incorrectly reporting the numbers of cylinders per sector (240 instead of 255). Testdisk repaired this error in disk geometry as well. (The program is free so I am not trying to ``sell’’ you all on it).

Here is a brief summary of what testdisk can do:

TestDisk is a powerful free data recovery software! It was primarily designed to help recover lost partitions and/or make non-booting disks bootable again when these symptoms are caused by faulty software, certain types of viruses or human error (such as accidentally deleting a Partition Table). Partition table recovery using TestDisk is really easy.

I’ve been using AyRecovery and CTM since December 2008 without incident on an XP desktop and Vista laptop. However, having said that, this sounds like a great tool. How did you use it, with their boot CD? Thank You!

Thanks for the great info. I had a ‘disk read error’ after installing ctm. Rebooting and attempting to restore resulted in the same.
I was able to uninstall ctm successfully, but that didn’t change the read error.

I tried UBCD4win, Windows install cd, nothing would detect that there was even a hard drive installed.
Finally used BootIT next generation boot cd and was able to delete/wipe partition and MBR, then I created new partition/mbr, and reinstalled windows as usual.

Now here’s the difference I want to point out for those that it may help. I have ctm installed and running great on several machines, only this one the other night took a dump on me. When I setup the other machines I installed windows fresh, then all drivers, then I install ctm, then anti-virus, updates etc.

With the machine that failed I did it the other way, I had everything just the way I wanted it then I installed ctm very last thing and it failed. So it may make a big difference to get ctm onboard early.

If you are installing on a good working machine that doesn’t need a windows reinstall then maybe uninstalling all security first would work, but I haven’t tested that yet.

For now I think I will go back to just imaging my windows installs to a separate drive until I can test ctm more.
It’s a great convenience when it works.

It seems, as if nobady is reading here the best information for solving the CTM problem. - Since TestDisk really works!!!

Rewriting the MBR as well as the partition table did not only let my system (XP pro, sp3) reboot again but also removed the ctm console program. - I only had to clean up my system and the registry of course.

My system crashed when I tried to reset the baseline after 3 snapshots with a bsod and ‘Unmounted_boot_Volume’ (Stop error …) message.

Besides, every snapshot caused a chkdsk run when booting up…?! -
If somebody could explain why this happens???

Maybe its no good idea, to install ctm on AMD CPU machines (see ctm manual) with SATA AHCI enabled and more than one partition on a hard disk…?

Any ideas???

Thanks & Greetz from Germany

Will TestDisk work on a 64 bit Vista computer?

Yes, pls try to run CTM as Administrator, then take snaphost.
In fact, Windows has a flag to show whether it is shutdown normally, and CTM need to set it when take a snapshot. However, if CTM do not have administrator privileges, then the flag can not be seted by CTM, so this problem happens.

After installing CTM and letting it try to reboot, I can’t boot at all and cannot access Windows RE It goes into CTM menu, but that is all I can do. Nothing there fixes it.

Do I need to be very experienced with computers to properly use TestDisk? Is there anyplace where I might find a step-by-step procedure to restore my MBR? Anything using Windows RE brings me to the blue screen of death.

I am trying to fix a Vista 64 bit computer if that makes any difference.


I do not know it exactly for Vista, but it should be similar as for win7.

Boot Vista from CD drive; access repair mode - prompt; now use bootrec…

  1. bootrec /fixmbr (to write a master boot record)
  2. bootrec /fixboot (to create a new boot sector/loader)
  3. bootrec /rebuildbcd (!!! only needed, if you have more op systems running)

A good idea is - to run - bootrec /ScanOs - to see, if your vista installation can still be found…

If the partition table is corrupted, then you might have to use testdisk (maybe with a deeper search). There are good instructions available on the net how to use testdisk properly and with care…!!!

Best and easierst way I found (in my case) was connecting the resp. hard disc externally (via USB) onto another pc; then using the windows version of testdisk running it under windows (xp in my case).

good luck

While, I’m not a complete novice, I don’t really know a lot about all this. I have changed HDs on several computers, but have no idea as to how I could connect my HD to another computer via USB. All I have to connect to is my laptop, but how would I go about that? Sorry to be such a pain.

I am sorry, I forgot…
you must of course put your hard disk into an ext. case with IDE or SATA connectors depending on your hard drive you use and connect this case (available from 10 up to 40 dollars) via USB (or eSATA connector if present) to any pc or notebook. Just google for external hard disk case and you will see.
If Vista finds a hard disk and if the partition table is still ok you may find a ‘mass storage device’ with a new drive letter under ‘‘my computer’’. Do NOT let Vista initialize and/or partition your disk… in no way!

Again, please use testdisk with care; hope, you have a backup of your data!
Leave your HD untouched when in any doubt, because restoring the wrong partition-data can really ■■■■■ it all up.

The basic instructions for TestDisk you can find here… TestDisk Step By Step - CGSecurity, you probably have that already…

I would recommend you to stay away from this software for some significant time, at least for Win7, I am sorry to say but this software is not fit to be released, at least for Windows 7, from my experience.

A perfectly healthy machine was rendered unbootable by this software and only through several repeating painstaking recovery processes with Win 7 installation disks did I finally manage to recover the situation.

The whole point in installing Time Machine was to make the system more secure and provide backup in the event of failure and yet it caused the failure.

I am not impressed at all. It is not the first time that I have experienced major issues with Comodo products and I have come to the conclusion that whilst they have a wide range of products they are only POTENTIALLY great and that compared with many other companies they are in effect releasing alphas and betas but as production software - and that we users are therefore their large army or alpha and beta testers.

That’s fine strategy for product development and user engagement but Comodo really need to get their procedures together to allow a very stable and highly tested end product for production release.

I have a really bad taste in my mouth from this TM experience. >:(

I reset my baseline and now I lost the ability to boot into the operating system that I reset the baseline in. I have Windows 7 and Vista dual boot. I reset the baseline in 7 and when it rebooted, it went into the recovery to fix boot options which it could not fix. It won’t boot into 7 anymore. I can boot into Vista (in it now) but CTM will not operate and says it is not installed correctly.

I tried the Vista recovery console and it asks me which OS I would like to repair (sees both) I go to prompt and bootrec /scanos and it reports that it found 0 OSs,so I am afraid to do a fixmbr, fixboot, etc.

I can see the Windows 7 partition and all the data from Vista, just can’t boot into it. I tried to reinstall CTM but all I get is the ability to remove it.

I guess my question is, if I remove CTM, will I just have my old dual boot system or could I lose everything. Not sure which way to go.

You can use another solution, a little bit more user friendly.;msg412391#msg412391

How can you download and/or install the test disk or ANY program…if youir computer is dead? It can’t come through the airways.

hovey, of course, I’m talking about a second computer, from where you can execute that actions.
We, users, ask for a live CD of Comodo, where we can perform actions like uninstall/restore snapshots, etc. The programmers read that. Although I’m not sure they could work on it or if it is a priority.

i think the best possible advice here is to not use CTM and keep your computer healthy…there that was a simple solution everyone.have a nice day.bye.

Hi , Too for me DARREN.1972 is this is possible ( for my modest opinion ) Kind regards

Was it a question? “is this possible” what ?


Even though there’s a long time gone, just want to say thanks for that hint - which was very helpful for me.
Best regards,