Help Needed Comodo Firewall is UNABLE to recognize the wireless internet modem!

When I installed Comodo firewall I found out that it cannot detect the wireless Virgin BroadBand 2go modem! In the network zone I haven’t seen anything except loop zone!?
When I ran a firewall test over on the ports were stealthed.But the firewall haven’t logged in any incoming connections/attempts!?? Other firewall’s have this option where they can automatically detect any connection/network and secure it properly! Pls comodo fix this thanx!

Comodo has this feature too. Go to:

Firewall > Firewall Behavior Settings - check on Automatically detect private networks.

Make to chose one from Home/Work/Public (don’t close dialogue window).

Network settings will be added automatically, that’s it.

By default, CIS doesn’t log intrusions attempts, he blocks them silently. But if you want to have them logged it is easy to do. Go to Global Ruels, right click on the rule blocking incoming connections(= Block ip in from MAC any to MAC any wher protocol is Any) > edit > check “Log as firewall event if this rule is fired” > ok or apply (depending on the version you’re using)> ok. Now every incoming connection attempt will be logged.

Thanks for the help guys! I have resolved the logging issues! But I am still working on the wireless modem!
No matter what I do Comodo cannot and or is unable to see Virgin BroadBand2go modem!?? However the connection/my ip is being protected,judging by grc firewall test It is being protected and all ports are being stealthed!

This is what I see and I’m not sure if I should choose the other option which is…Unsecured wireless Network Only? By default it was,but I have switched it to the other option and still nothing!?

[attachment deleted by admin]

Are you directly connecting to the modem? Is this a modem only (it does not come with added router functionality)?

It is a Wireless USB Stick/Modem and if you want too see the pic of it please go to…When I log into the windows there’s no internet connection but,when I fire up Virgin BroadBand or click on the icon/connect that’s when the internet connection kick in! And it is 3g/4g it usually runs on WIMAX network adapter! take look at the pic!

[attachment deleted by admin]

Can you tell in what IP range the IP address is that your connection give you? Is it a private IP address (typically in the 10. or 192.168. range) or a public IP address?

If the connection hands out an IP address in a private range then CIS should detect automatically detect that network. If it gets an IP address in a public range then it won’t.

You adapted your Global Rules so the firewall would be logging what it is blocking. Do the logs of the firewall show it is blocking incoming traffic?

You are showing the Properties of Local Area Connection 54 which does not show the Comodo Firewall driver. Can you also show the Properties of Local Area Connection 55?

Can you explain what the function if of Local Area Connection 54? It states it is a Wimax connection and as such it could be related to your wireless connection from Virgin. But it shows it is connected but the dial up connection is not connected.

But when I look at the name of Local Area Connection 55 it states it is U600 EVDO network adapter. This name is the same as for the dial up connection. at first sight I would say these two belong together.

In short, I am confused about your network connection and I am not sure what I am looking at.

It is 10. …Just saw a firewall log and it is blocking Dhcp/cannot renew it lol.About the ip… ip keeps on changing every time I get online!?
Firewall seems to be blocking an incoming connection’s/attempts! Take look at the pics!
When I inserted the USB stick/modem to the pc it had installed EVDO Modem and WIMAX adapter!

This is a Wireless Connection! It is not a dial up! When I loose 4g connection/signal then Evdo adapter kicks in and let’s me run on 3g!

[attachment deleted by admin]

Thanks for this information.Its good to know. :-TU

There is no Comodo Firewall Driver Installed on that adapter’s connection. Comodo won’t talk to it at all but web browsers should work and other internet applications and you have no comodo firewall. You maybe firewalled by the windows firewall. Not sure why it’s all stealthed with no driver installed…unless windows firewall is active.
see my attached pic notice the Comodo Internet Security Firewall Driver Is Installed. In your Pictures it’s not.

Maybe click install and see if you can manually add it.
Don’t know why Comodo has not installed the driver on your adapter.

What does the properties of the 3G adapter i see there show no comodo driver either?

[attachment deleted by admin]

Windows firewall is disabled and I ran PCflank test also! Everthing seems to be stealthed!? Nmap online tools was detected by comodo fireewall and all the scans have been stopped/logged in! Ping isn’t responding either!? So maybe you are right,I am being protected by just one part of a firewall haha? can someone confirm this please? What is going on here???

What’s in the 3g adapter properties. did you try to install a driver like i said form the nic properties to see if comodo firewall driver was listed as a choice?

As far as I remember CIS doesn’t install a driver for XP the way it does with Vista and above, hence it appears to be missing.

If that’s true that CIS 6 doesn’t install a driver on windows xp i didn’t know that.

Are you running Windows XP Service Pack 3??

If you’re asking me?

[attachment deleted by admin]

No i meant the person we are trying to help I should have been more specific.

Windows XP service pack 3! Heres another pic! It shows that comodo is watching local connection 54 which is Wimax adapter!???

[attachment deleted by admin]

It’s entirely possibly CIS simply doesn’t recognise WIMAX connections…


If your main concern is not having a Network zone for the WIMAX connection, you can create one manually.