Fully Virtualized Sandbox Limits Chromium Engine Frame-rate [M669]

A. THE BUG/ISSUE (Varies from issue to issue)
[ol]- Summary - Give a clear summary in the topic subject, NOT here.

  • Can U reproduce the problem & if so how reliably?: On my system I can reproduce it with 100% reliability.
  • If U can, exact steps to reproduce. If not, exactly what U did & what happened:
    a: Start opera.exe or chrome.exe etc outside of the sandbox and go to a site that shows the framerate (might need a 120Hz monitor to see difference, I will be supplying sites further down)
    b: Do “a:” but start the browser as Fully Virtualized.
    c: Compare the results, for me the FV browser shows no visual difference from 60 and 120 FPS while on another test it didn’t even detect anything above 30Hz, while the browser which is not sandboxed shows a clear difference between 60 and 120 FPS and the other test detects up to 120Hz.
  • If not obvious, what U expected to happen: I expected the fully virtualized environment to be able to show frame rates up to the framerate of the monitor used, which it does not (or it detects the wrong monitor)
  • If a software compatibility problem have U tried the conflict FAQ?: Don’t think so.
  • Any software except CIS/OS involved? If so - name, & exact version: Opera and Comodo Dragon, however only browser since they are the only I really know how to test, if anyone knows a program that tests this I can try that too. :S
  • Any other information, eg your guess at the cause, how U tried to fix it etc: My guess is that the FV sandbox either deliberately limits the framerate to whatever or detects the wrong monitor in multi-monitor setups.

B. YOUR SETUP (Likely the same for each issue, so you can copy forward)
[ol]- Exact CIS version & configuration: CIS 6.3.297838.2953 , My own configuration.

  • Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV: HIPS on Safe mode, BB turned off, Firewall on Custom, AV on stateful.
  • Have U made any other changes to the default config? (egs here.): Ooooh yes, lots.
  • Have U updated (without uninstall) from a CIS 5?: No.
    [li]if so, have U tried a a clean reinstall - if not please do?: N/A
    [/li]- Have U imported a config from a previous version of CIS: Yes
    [li]if so, have U tried a standard config - if not please do: Yes, didn’t help.
    [/li]- OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used: Windows 8.1 64bit, UAC turned off completely through registry, Administrator account, not a virtual machine.
  • Other security/s’box software a) currently installed b) installed since OS: a= AntiLogger Free b= Windows Defender & Windows Firewall 88)

I’m going to speak somewhat more freely here.

In Screenshot 1.png you will to the left see the sandboxed Opera and that the website doesn’t detect a refresh rate over 30Hz and on the right side you’ll see the non-sandboxed opera and how it shows up to 119 FPS (I took the screenshot a little early so it didn’t have time to go up to 120FPS and show the Hz)

In Screenshot 2.png you can’t really see anything special since you can’t see the refresh rate in action from a screenshot, but I’ll explain. You can see that the balls have their own names: A1, A2, B1, B2. I’ll start by explaining them, A1 is a ball that shows in 60FPS in the virtualized browser, A2 is a ball that shows in 120FPS in the virtualized browser, B1 is a ball that shows in 60FPS in the non-virtualized browser, B2 is a ball that shows in 120 FPS in the non-virtualized browser. I should also clarify that I have a 120Hz monitor. So the problem here is that A1 and A2 looks exactly the same to the viewer, a bit stuttery as if they both showed in sub 60 FPS while B1 and B2 shows a BIG difference where B1 looks pretty much the same as A1 and A2 but B2 shows muuch smoother, so to clarify, A2 looks like A1 and B1 while it SHOULD look like B2.

I believe this might be the source of some of my issues I’ve seen with browsers in FV sandbox, I generally feel they are slower in the GUI, a bit stuttery perhaps.

[attachment deleted by admin]

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again.

Not fixed in CIS version 6.3.302093.2976

Thanks for checking this.

I have updated the tracker.

Not fixed in CIS 7.0.308911.4080 BETA

Thanks for checking. I have updated the tracker.

I just tried Comodo IceDragon and a game called Killing Floor in the FV sandbox and neither of them were limited, so it seems that this issue is only with Chromium based browsers as I’m seeing this with CD, Google Chrome and Opera.

Thank you. I’ve added that additional information into the tracker.

Can I request a title change to Fully Virtualized Sandbox Limits Chromium Engine Frame-rate or similar? Key part being mentioning that it’s only about Chromium engine.

Sure, I’ve updated the title both for this report and for the entry in the tracker.


Not fixed in CIS 7.0.313494.4115

The devs have informed me that apparently the Fully Virtualized environment cannot support the same FPS as a real environment. If I am understanding them correctly, they are saying that they cannot fix this.

I will therefore move this to Resolved. Let me know if you have any questions.

Thank you.

That’s funny, because FF runs in a perfect 120FPS however Chromium engine gets limited to 30 FPS… I’m calling ■■■■■■■■ on this one.

And I’ve even run games like Killing Floor in the FV sandbox in a perfect 120FPS+

This has so far only affected the Chromium engine.

I have now re-opened this in the tracker and asked them to re-investigate this issue. I will also move this report back to Format Verified. Thank you for responding. I will let you know when I receive any new information.


Not fixed in CIS 7.0.315459.4132

Thanks for checking this. I’ve updated the tracker.

Not fixed in 7.0.317799.4142

Thanks for checking this. I’ve updated the tracker.

Sanya. Does this occur only for certain video file formats or for all?

There is a path length problem running (IIRC) .wmf videos on FV Dragon and Chrome from some sites (exceeds 254/5 chars)

The sandbox prefix is added to the standard long chrome paths and bubs your uncle.

I only know this because of programming the deletion tool. Maybe thinks become inefficient as this limit is approached?

Probably unrelated but I just though I would mention it.

Best wishes