Fully Virtualized Sandbox Limits Chromium Engine Frame-rate [M669]

The limit is for the actual browser, like eveyrthing, not just specific video content.

Chrome family browsers in general create long path lengths. It’s just that in playing .wmf file the OS limit (in relation to some operations) is exceeded in the S/b.

(If we can work out what the cause of this irritating issue is we might get it fixed :slight_smile: ).

Best wishes


But it still limits the frame rate for the whole browser, not just video contents. Simply scrolling is horrible because it’s locked to 30 FPS on a 120Hz monitor.

Yes, its possible the path length would affect that too. But only possible.

I have just tested using Dragon FV and NV (outside Kiosk) on a 60 Hz monitor. Sorry I don’t have a 120Hz monitor

I get 60 fps offered and valid in FV and NV on testUFO.com, and max speeds and numbers of UFOs

48 and 60 fps ‘spheres on sunset’ motions with no blur are discernibly different on the http://frames-per-second.appspot.com/ in both FV and NV. Possibly a bit more in NV, but I am not sure.

So this is presumably only clearly discernible on 120 hz monitors? Weird though that you are only offered 30Hz though on testufo, as I am offered 60Hz.

Best wishes


I do not believe it is specific to 120Hz monitor as I have tested it on my 60Hz monitor and see the same thing, my point is that the change is more obvious on a 120Hz monitor as 30 is half of 60 but a quarter of 120 meaning if you are used to 60Hz then you may notice that it is performing half as good while if you’re used to a 120Hz monitor then you will notice that it is only running a quarter as good as normally.

I have for testing purposes unplugged my secondary monitor and tried again, still locked to 30 fps so likely it is not related to multi-monitor setups.

What other hardware do you have?

The card is an AMD Radeon 6700 series. Not a very fast version.

Monitor is Dell U4124 - a 24 inch 1900x1200 LCD, set at 60Hz

Single monitor

Do you get a similar effect in Sandboxie? If inherent to virtualisation as the devs say you should.

I’m using an Nvidia GTX 780, do you perhaps have any nvidia card you could test on?

I don’t have sandboxie installed.

Im using the same card as Sanya and getting the same results. Im on a 60hz 1920x1200 monitor but when i run dragon virtualized im only getting 30 fps

I never asked the QA person I was talking with. He may have been using AMD? Perhaps it’s specific to Nvidia cards/drivers?

OK I don’t have that card. Or any card like that. I’ve one on ATI and one on AMD.

Is your a multi-monitor set up Wasgij?

Maybe this is a driver/sandbox issue. Sandboxed apps cannot install or load drivers. Comms to drivers may be restricted too.

Yes it is a multi monitor setup I can try it with just my primary monitor if that would help. My secondary monitor is 1280x1024 at 30 hz I think maybe 60

My primary monitor is 1920 x 1080 @ 120Hz and my secondary is 1920 x 1080 @ 60Hz, I’ve tried with only my primary plugged in and I’ve tried with only my secondary plugged in, no difference. I’ve also tried setting my primary to 60Hz in Nvidia control panel, no difference, Chrome/CD is still locked to 30Hz in FV sandbox. So most likely not related to multi-monitor setups.

Thanks for the follow-up wasgij6. Sanya has already tried removing a monitor. Possibly if you were able to disable this in the graphics card and rebooted and retested it might tell us something?

Hi Sanya.

It got closed again so I am now requesting a discussion with the head of QA via an internal appeals process.

This is the pertinent text, to see if you have anything to add:

However I do agree with Chiron that a better explanation would be helpful. Not least because the devs reason - that frame rates are necessarily slower under virtualization, doe not seem to be a sufficient explanation. Let me summarise the contrary evidence 1. It happens in Chrome family browsers not elsewhere, with videos *and* other usages (not just videos) 2. Part of the problem seems to be that the max FPS capability of the graphics card is not detected. (See the text under the heading 'screenshot 1' at the bottom of this post) 3. It appears to affect only one family of graphics cards, the Nvidia family, and specifically those with multi-monitor capability, not others (like ATI). So far replication has been on: Nvidia GTX 780. See these posts: https://forums.comodo.com/format-verified-issue-reports-cis/fully-virtualized-sandbox-limits-chromium-engine-framerate-m669-t99455.0.html;msg755528#msg755528 https://forums.comodo.com/format-verified-issue-reports-cis/fully-virtualized-sandbox-limits-chromium-engine-framerate-m669-t99455.0.html;msg755482#msg755482

Overall it looks to me like maybe Chrome picks up the max FPS data from some key or file, and that key or file is not accessible in FV.

I would also note that it has been replicated now by another expert user wasgij.

And that it affects Dragon, which Comodo should be particularly concerned about.

One thought is for you or wasgij to test it in Sandboxie, as that would help determine if this is in any way inherent to virtualization as a concept. (If you have already my apologies - it is getting to be a long trace). You can install Sandboxie with CIS temporarily - at least you could in CIS 6. Wold not recommend permanently as there can be some weirdness).

Sorry I cannot test myself - wrong adapter.

Best wishes. Mike

I’ll take a look at sandboxie, as long as it doesn’t require payment.

Just tried it with Sandboxie and the issue does not replicate, running in a clear 120 FPS on my 120 Hz monitor.

[attachment deleted by admin]

Thanks, that should help persuade QA. I will discuss with the manager, and see if he can discuss with the devs. Thanks again for testing. Best wishes. Mike

I did a restore of a completely clean Windows 8.1 image and then installed CIS and CD and still the same problem with 30Hz limit, so we’ve now ruled out any kind of third party application interference (if I hadn’t already, can’t remember)

If ANYONE else has the same issue, PLEASE tell us your setup according to the format below!