Forza Horizon 3 crashes to desktop after initial splash screen[M2226]


The newest build version of “Forza Horizon 3 PC” v1.0.39.2 crashes on start to the desktop by many users with the AV programs.
Here by me with CIS10.

Nvidia GTX 980 // driver = 372.90 and the newest tested.

When i deinstall CIS10, Forza Horizon 3 PC works again.

Please, fix this.

Many thanks!

Best regards…


Hi angel-ch,

Thanks for reporting.
Could you please submit the detected file at
Comodo Firewall | Get Best Personal Firewall Software for $29.99 A Year.

Pavithran G


Sorry, not detected file was found.

First, the game load in windows mode.
5 secs. after, crashes the game to desktop.

Show Forum for FH3:

Best regards…



There is still no solution ?

Best regards…


Hi angel-ch,

Can you please try to follow these steps and check if it solves the issue.

Open CIS, go to Advanced settings, File Rating, File List and add it as trusted file. After, in the advanced settings go to HIPS, HIPS Settings, search for “Detect shell code injections” and add the application to Exclusions.

Thanks and regards,

Hello Ionel,

Yes, i add the Process-Name from “Forza Horizon 3” in the exclusion list of HIPS settings.
Now, its working.

You are great!
Many thanks!

Best regards…


A. THE BUG/ISSUE (Varies from issue to issue)
Can you reproduce the problem & if so how reliably?:
Yes, always
If you can, exact steps to reproduce. If not, exactly what you did & what happened:
1:Launch Forza Horizon 3 from Microsoft when CIS is installed - it’s irrevelant which if any of its modules are turned on.

One or two sentences explaining what actually happened:
Forza Horizon 3 used to work with CIS perfectly. Now, every time I launch it, it displays the initial splash screen for a few seconds, then the program quits back to the desktop with no error messages. Event Viewer lists it as a faulting application with code 0xc0000005.
One or two sentences explaining what you expected to happen:
The game should display the MS text, then the Turn 10 logo, then the main menu screen. I have reinstalled it from scratch three times.
If a software compatibility problem have you tried the advice to make programs work with CIS?:
Any software except CIS/OS involved? If so - name, & exact version:
Forza Horizon 3 (Microsoft Opus
Any other information, eg your guess at the cause, how you tried to fix it etc:
Some sort of conflict with low-level CIS driver? Uninstalling CIS completely means the game works perfectly again on the exact same setup. Turning off any/all modules in CIS makes no difference. Other Windows UWP apps such as Forza Apex work flawlessly with CIS, it’s only FH3 which crashes.

Exact CIS version & configuration:
CIS Pro 10,, database version currently 26979
Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
Firewall - but seems to be irrelevant to crash
Have you made any other changes to the default config? (egs here.):
Have you updated (without uninstall) from CIS 5, 6 or 7?:
if so, have you tried a a a clean reinstall - if not please do?:
Yes, several times
Have you imported a config from a previous version of CIS:
if so, have you tried a standard config - if not please do:
OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
Windows 10.0.15063 64-bit, UAC disabled, Administrator, no virtual machines
Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
a=None b=None

C. ATTACH REQUIRED FILES (delete this section (section C) after attaching required files)
Always attach the diagnostics file (instructions on how to do this provided here) and the KillSwitch Process List (instructions on how to do that provided here) and put the resulting file in a zip file. Both should then be attached to your post.
Note that additional information may be requested by the processing Moderator.

Files attached. Also, here is the full Event Viewer error code for FH3:
Faulting application name: forza_x64_release_final.exe, version:, time stamp: 0x58d0fe52
Faulting module name: unknown, version:, time stamp: 0x00000000
Exception code: 0xc0000005
Fault offset: 0x000000020f842750
Faulting process ID: 0x7ec
Faulting application start time: 0x01d2bd649bea89fd
Faulting application path: C:\Program Files\WindowsApps\Microsoft.OpusPG_1.0.58.2_x64__8wekyb3d8bbwe\forza_x64_release_final.exe
Faulting module path: unknown
Report ID: c313258c-4b9d-4639-af12-8a56f50fb751
Faulting package full name: Microsoft.OpusPG_1.0.58.2_x64__8wekyb3d8bbwe
Faulting package-relative application ID: OpusReleaseFinal

Can you try adding C:\Program Files\WindowsApps\Microsoft.OpusPG_1.0.58.2_x64__8wekyb3d8bbwe\forza_x64_release_final.exe to the exclusions of detect shellcode injections and see if that allows it to work.

I’d already set that. But I double-checked and re-added it just to be sure. No dice, unfortunately

Try adding All Applications to shellcode detection exclusions. Just to double-check.

Wouldn’t you know it, that actually worked. Thanks a lot! Feel free to scrub this report and I’ll advise people on the Forza Horizon 3 forums having the same problem to follow these steps. Thanks again.

Not really a solution. Consider it a work-around. Kind of. It would be great if they could fix it. Is there any free/demo/trial version available?

Oh well. Found a demo. Let’s see.

// bug 2226

I don’t want to open a new thread.
Exactly the same issue, but Comodo Firewall.
Game is crashing with the same Exception code (0xc0000005). It works after uninstalling, but I rather don’t want to lose firewall only for one game… So I’m waiting for update/bug fix.

So, do you maybe have another solutions? I have expected the same issue with Forza Horizon 3 and I am unable to play the game :frowning:

Welcome to the forums, Januszex. I’m not familiar enough with the game, W10 to provide a more exact solution (other than one mentioned at Reply #3). In general, you add game folder or/and dependencies (eg which belong to Windows Store).

Make sure you add exclusions & not disable option (as it disables exclusions, not feature).

By default, shellcode injection protection is enabled for all applications on your computer. Use this setting to define applications which you do not want to be monitored for shellcode injections.

I found the final release version of forza in may 2017 still crashes without comodo logging any items.

The only solution i found to work was including the executable in the shell code exception list for the HIPS area.

Seems dcom and runtime broker cert authentication are not giving privileges to cis.exe and its dcom compartment.

Forza runs under the trusted installer tag ,and comodo isnt not included in this dcom attribute.

Seems comodo although acting as part of the system cannot interact or isnt authorised to.
No amount of dcom fiddling in win10 can change this at present.

Could be a escurity compartment issue with ms or authorisation on cis,looks like a cis dcom update would fix this .

Other microsoft applications are no problem ,but with forza’s dcom launch requirements it was a problem.


Hi tegrous1,

Thanks for reporting.
Could you please submit the detected file at
Comodo Firewall | Get Best Personal Firewall Software for $29.99 A Year.

Aravindhraj J

The file is forza horizon 3 final edition ,this is a microsoft product in their store.

Dcom in windows is logging consistently as the runtime broker is being blocked by COMODO
but comodo isnt logging ,so no files from COMODO to submit.

This is the only ms store item that this is occurring on.

This has only occurred since the ms product update post march 20th 2017 .