"Fix the Bugs" time for CAVS :-) (need your help... please read...)

I have recently installed CAVS, and find that it keeps locking up, seemingly due to (primarily) email scanning (seems like it takes a while for it to occur - it works fine, then it locks). When this occurs, Task Manager does not show it as an actively-running program. However, in the processes, CAVSN.EXE is locked at 100% of resources. I have seen multiple instances of CAVSN.EXE in the processes - two, to be exact, each at 50%. When I closed one, the remaining jumped immediately to 100%. I see in the list that there’s an unhandled exception error for CAVSN.EXE, and the item of the scanner locking up, but I do not know if these are the same thing that I’m experiencing. I’m running XP v2002 (OEM), SP2, 1.6 GHz processor, 504 MB RAM.

Will the next beta be recognized by WSC ?


I believe CAVS 2 should support WSC, yes.


Thanks Mike.

You’re welcome. :wink:


Perpetual rebooting, when trying to install CAV

I have searched the forum for this problem, but couldn’t find anything.

I posted once (briefly) in the thread about uninstalling CAV. there I reported that W2K Pros disk checker had 321 file fragments in four folders, totaling 32mb.

After uninstalling manually, clearing out the registry I got a clean system back, and decided to install CAV again, this time making a full registry backup, to make the job of uninstalling easier (even though it’s a test machine, manually editing the registry is a real pain)

EDIT: ^^^^^ This didn’t work as planned ^^^^^
(had to edit registry maunually again *** sigh *** )

This time I let the perpetual reboots run for about an hour.
I ended up with 1,729 file fragments in 28 folders totalling 285MB, and it was still finding errors on each reboot, with no sign of them stopping.

Anyone else met this problem?

There is a brief blue screen just before each reboot, but it flashes up so fast I cannot read it. I will try and borrow a digicam to take a screenshot, and post back if it is useful.

I note that you are going to use your own installer soon, great!!! as it is annoying trying to uninstall, only to be told that the uninstaller is not available in safe mode. However I did note in another post that someone had a “fix” that allowed use of it, but no details were given. Pity

Uninstalling should have been easier using a full registry restore afterwards, instead of manually editing the registry, but I got errors doing that, I am not certain I have found the optimum method, I’ll post in the Uninstall CAV thread when I do. I think the problem lies with the bloody Windows Installer, best to wait, for now, until Comodo get their own installer in the next Beta release.

No further testing of CAV (for me) until a solution is found.


Kishor ackowledged the fault here (stating that it had been found & fixed), the problem is described by various users on the pages before that post.

Fix for MS Installer in safe mode? SafeMSI here.


I think that the problem described is similar too, but not the same as the one I am experiencing. I had found those posts in a previous search of the forum, but they did not describe my circumstances exactly (my test computer does not lock up, like the others describe, it quite happily reboots ad infinitum) - and it has not been fixed yet, at least in the latest download of CAV 1.1.
To quote Kishork “Its is in QA and will come shortly.” He then describes a work around.

So I am waiting for CAV 2 in a few weeks time, now.

Thanks anyway

Ty also for the link for the Safe mode MSI Installer, I’ll check that out…

Actually, maybe you’re lucky… I think it would take days for my system to actually get around to rebooting. :wink:

So I am waiting for CAV 2 in a few weeks time, now.

Me too.

Ty also for the link for the Safe mode MSI Installer, I'll check that out....

No problem… But, just for you, something a little extra. Does the same thing as SafeMSI & a lot more. And I do recommend the beta.

Actually I was having that same “outcome”, where on reboot - the machine would find a couple error fragments after the scan. then I would let it run through the start-up again where it would run through your cycle again and again adding those couple error frags each time. My solution (as it worked for me) was to reboot into safe mode, run msconfig and uncheck related entries in start-up and services. Then I reboot (without any problems or hesitation) de-install the Anti-V, re-boot and reinstall the Anti-V - Then let it run through the update and Taa-Daa. Everything should be “Kosher” now.

I really do jhope that is yuour solution as it was mine.

Gl, Rm


Here ya go, you’ll have to unzip it, can’t upload .exes on this forum.

It’s a TFTP server daemon.

I’m also getting false positives on mIRC and VNC.

[attachment deleted by admin]

There is still the problem that Windows doesn’t pick it up as a AV!

This will be resolved (very soon) with Beta 2.


CAVS prevents CVSNT from running (search this board for “CVSNT” for more info).

This is a real problem!

Hi Melih,

I installed CAVS on my desktop system and on my laptop and had the same experience with both. They are both running Windows XP Professional SP2 with all of the latest patches. When I open EXPLORER.EXE (not IE), the system freezes for a very long time and the hour glass just cranks away.


Mine, I have the problems with MS Outlook with CAV. Facing difficulties in sending mails. Have to click on the Send button for 3-5 times before the mails go through. Have disable “Outgoing mails scan” but problem still persist. Outlook works fine if I turn off CAV.

Apache / CAVS conflict not on list. See https://forums.comodo.com/index.php/topic,3160.0.html


I found that CAVS freezes when attempting to open large (>10 mb) Microsoft PPT files. Uninstallation of CAVS fixed this.

Hello Melih,

I just joined your forum (and have a post appended in the A/V section. I’ve been using the current Firewall ( for a few weeks now; I’d tried it some months ago, but found some problems. One of your technical people, Jonathan, suggested I wait for the next version, which I did: it is superb.

Alas, I’m also one of those who has had difficulties with CAV - it won’t run on my computer (Dell Inspiron 8200; P-4m, 1.8 GHZ; Win XP Pro, SP2 with all updates, and now running I.E. 7 - though I plan to start using Firefox and Thunderbird soon). Again, it was Jonathan who suggested that I wait for the next version; that was on 8 Oct. I noticed that you’d said CAV Beta 2 should be out soon, and am looking fwd to the release!

On a more personal note, I noticed in your bio that you’re an EE. An former math professor introduced me to a fellow countryman of your, Oliver Heaviside - an unsung hero who should be far better represented in the textbooks of math and physics (for example, that the four eqns we learn as “Maxwell’s Eqns” are actually Heavside’s Eqns, AFTER Maxwell…). I tip my hat to the living memory of a great man.

Take care.

Thanks AJNorth.

Nice to have you with us.