First impressions of CTM 2.9

Right now I’m running CTM 2.9 beta in my Windows 7 32 bits system.
Some new features were added:

  1. Lost scheduled tasks seems to be working.
  2. Quick access to operations by the system tray icon.
  3. Timeout for the console to load (spash screen at boot).


  1. The hourly scheduler seems to put the options not intuitive (time to start and time to end).
  2. Seems that we can’t compact snapshots manually anymore :stuck_out_tongue: Why?
    Is the command line available yet?

[attachment deleted by admin]

CHANGED: Run snapshot compact automatically in background without user interaction.

Hi, tech
You are right.
You cannot compact snapshots from ctm main gui or command line,
however, you can do it from sub-console.


hi, Tech

The problem 1 will be fixed in next release. The start time “N” and the end time “N” means taking scheduled snapshot in the Nth hour, and the start time “N” and the end time “N+1” means taking scheduled snaoshot in the Nth and b[/b]th hour.

You can compact manually in sub console. We have deleted compact in GUI and command line.

Best Regards,

In fact, number 1 was not a problem… I think it was a solution… I mean, lost snapshots are run on next time (for instance, after resuming from sleep mode).

But why did you take out the compact option? :cry:

I mean this “problem 1”.


It is for improving usability. Users need not pay much attention on compact because CTM will do it automatically.

Well… We do not like features/configurability that are removed or dropped…
I hope you have improved a lot the free disk space management as some users lost all their system due to lack of free space…

Suggestion: center the text of the panel that arise when a scheduled snapshot is taken.
Translated text isn’t centered as well.


Unfortunately my impression is not very impressive:

I tried to install CTM several times, after the first reboot during installation CTM is installed, accessible and working,but after a (normal) shutdown and reboot of the PC CTM has vanished:

CTM de-installs itself, the installation folders created during the installation procedure of CTM on C:\program files are empty (but still they are existent) !!!???

Welcome to the forum Commodore. :slight_smile:

Could you please do a full bug report in the Bug Report topic, with full details of your system.

Commodore67, did you use System Restore from Windows?

JamesFrance and Tech, thanks for your warm welcome and quick response.

I should add that once I had CTM 2.7 installed (and deinstalled, after which MBR was a little “confused”, but it could be repaired “by Windows”). CTM 2.7 worked fine for me, by the way.

Yes, indeed, in between the de-installation of CTM 2.7 and the installation of CTM 2.9 I once used System Restore from Windows, restoring to a system restore point which had been created after the de-installation of CTM 2.7.

I am currently using Windows XP Home SP 3.

JamesFrance, is there any additional bug report created by Windows?

No I was meaning could you post a bug report here:

Never mind :slight_smile:

Hi. I noticed this quote in the forums.
Does this engine help protect against, for example TDSS Rookits? and apparently Flykite from Comodo said not in this version.

Perhaps someone from Comodo can confirm that an upcoming or final version will protect from rootkits bypassing Ctm?.


I think CTM is not prepared yet to protect itself from these rootkits.
The code needs to become rock solid. And, in fact, it’s near but it’s not there yet.
The antirootkit protection could come in the future. But, really, it will start to come with CIS and not with CTM.
My personal opinion only.

Another points about 2.9 Beta:

  1. The reset the baseline is very very fast. Did you change the code so deeply?

  2. On contrary, the restore of a snapshot is very slow on Beta 2.9. It usually takes less than 10 minutes, now it’s taking 25-30 minutes. The snapshot is from yesterday…

  3. I’m worried about free space management. On version 2.8 it could take a 3-5 days for me to run in few space (I take snapshots hourly, and automatically delete the unlocked after 3 days). Now in 2-3 days the disk is going to be full… Is there something different in the beta?

1.True ,now its really fast :smiley:

2.On my PC restore of a snapshot takes 4 minutes


  1. One of the snapshots (unblocked) is not deleted when I choose to delete all unblocked.
  2. The sum of all snapshots size is much much less than the total space used. As I am experiencing, from version 2.8 to 2.9 there is a very worse space management… What did really changed in CTM?
  3. Why can’t we start a new thread in the beta forum?

[attachment deleted by admin]