Diagnostics have found some errors and could not fix them [M2437]

i uploaded it here:

i dont know how to do that :-/

i did that. the file is here:

But i dont know what to do now. im no expert in this. that’s why i asked for help.

Regarding diagnostics issue…

More people are having the same issue with diagnostics feature at this moment, including me on Windows 7.
The issue is on the priority list (tagged with [M2437]) and the CIS devs are working on it.
Here is the reported bug:

Diagnostics have found some errors and could not fix them [M2437]


Here is the analysis of your report which shows an output problem on the CMC network that does not affect protection

ok, cool. thanks for the info.

Like @CISFan said, ever since the Diagnostics bug appeared, I indulged myself one day in checking out the exported diagnostic .xml’s myself, and it turns out it’s (apparently) just CIS/CAV/CFW having problems phoning home to some COMODO servers, like @ZorKas said. At least in my case.

No reference to corrupt system files or registry keys though, which I’d guess would be of a higher priority to keep the program functional.

Of course, this is me, someone unaffiliated with COMODO and with zero access to the software’s source, simply making an educated guess. And we all know how effective “self-diagnosis” can be. ;D

Anyway, I do not think these Diagnostics error reports are something alarming, for the time being. Given of course, that there isn’t indeed an issue at hand, e.g. some corrupted installation files.

I believe it’s ultimately up to COMODO staff to determine whether there is any cause for concern, on a per-case basis, but I’m positive that @Patrick2903’s installation is fine.

Also, been a CFW user for over a decade - first post after lurking on the forums since 2017. Yay. :smiley:

I’ve also got the CMC network error, plus a Configurations Status=“Failed” Error=“0x00000005” for good measure. Also, these zipped reports used to be about 20KB, now they’re over 400MB because of the added dump files.

Hi guys,

Database Version 32500
System is functioning properly 100%.

The previous version (since January) was 12.2.6950 Beta 2, due to W10 problems at the time. That also was 100%.

Today I noticed that the CIS version had changed to, at some point in the last 4 months.
So I decided to check CIS diagnostics. I do not remember the last time I did this.
The result was and still is “diagnostics have found some errors and could not fix them automatically”.

I remembered that the downloads.comodo.com was blocked in the hosts file, so I unblocked it and run an update. All was OK.
I run CIS diagnostics again - “diagnostics have found some errors and could not fix them automatically”.

I decided to do a fresh install. Used the “Comodo Uninstaller Tool” with a number of restarts until nothing else was found.
Then I installed CIS
I run CIS diagnostics again - “diagnostics have found some errors and could not fix them automatically”.
I tried this 3 or 4 times with the same results. As I said, CIS is working 100%.

I attach the xml file for your review.


Here are the ‘failures’:

Unless you know there is something wrong with your installation or an error message is shown; there is no need to run Diagnostics or send it in. It is intended to be used when requested by one of the team to assist in finding a the source of a problem

There is a well know and recorded minor issue, where it sometimes generate the message that there are errors, but in fact there is nothing wrong.

It has been fixed and will be part of the next release

Hi Ploget,

BTW I did not bother sending it anywhere. Just thought to ask here in the forum instead.
I just found it weird that there were no obvious problems with the installation.

Thanks for the help

Coming to think of it now,
I did notice something unrelated though, which you may find interesting.
When importing my previous configuration file, overwriting the existing ‘comodo - internet security’ there are times when ‘comodo - firewall security’ is automatically enabled and other times when ‘comodo - proactive security’ is created a second time (‘comodo - proactive security (2)’ ) instead of ‘comodo - internet security’ .
Import seems a bit flaky. Keep in mind.


When you are Exporting & Importing, always start by Exporting whichever Configuration you wish to modify, under a different name. Then import it, make it active and add whatever rules and changes you wish. I would never try to ‘overwrite’ the default Configurations: Personal Configurations

Updated… 4:
( I want to say that that bug’s reported down include custom GPO restrictions ‘and some IE Zone Restrictions’ )

I was doing the diagnostics and that seem to end up finding errors on CIS that couldn’t fix.

After i opened ProcessMonitor to see whats up, it seems to BufferOverFlow on the RegistryQuerys:


Comodo Updating Website Failled:
This include only an Process Monitor Logfile with 100.000 events that followed till the process end.

If im not wrong from what ive seen inside it shows some dns cache over flow with some other overflow on Querys and not only im not talking about Comodo level.
Ive also seen an Window area creation somewhere inside the events if im not wrong that i was saying about in the past that a hidden windows exist in my desktop. I managed to find that it created by Delphi process on Atom Table levels dynamicly and seems like kernel loading from the logs here. In the past ive find this by some bugs i was onto that exist on dynamic object’s and invisible objects such as brightness of screen when moved on the corners applying to the object and similar and with a screen capture program that detect program areas that can apply to hidden objects…
I may deleted this thoe from the 500k log extraction. And no i dont mean Comodos window area im talking about a hidden window.
Also dont get it wrong some object may appear Unkown cause of HIPS. But not all of them…! I mean they also may not.

It also seems like CIS was crashing the NVIDIA Settings and Panel for me.
At least when this bugs start happen.
I want to notify that after a thermal throttle or a timing / volt reboot CIS may start working unexpectedly.

I want to say that notified bugs from me is the one described up and the upload functionality of files that some time does return errors even if in the connection pane i see that network communication is active.

I also found that script trying to run from powershell:

[console]::InputEncoding = [console]::OutputEncoding = New-Object System.Text.UTF8Encoding
$sql = "SELECT System.ItemUrl FROM SystemIndex WHERE scope=‘file:’ AND (System.Kind IS Null OR System.Kind = ‘Video’) AND System.FileAttributes <> ALL BITWISE 0x2 AND NOT System.Ite…

Thank you for reporting.I will report this to our dev team.Once done I will update you.

Still no fix for this ?

Soon friend, i also hope that the next release or beta will have that serius bugs fixed as im a paid user and not using it for now. :slight_smile:

Hello Patrick2903,

Teams are working in it and hopefully it will be reflecting in the upcoming release.