Diagnostics have found some errors and could not fix them [M2437]

running diagnostics always says ( diagnostics have found some errors and could not fix them automatically )

Hello walid assem,

Thank you for reporting.As I informed this to our developers and they are working in it.once resloved let me notify you.

Kind Regards,


edit: proper format in the post below

Whenever i run the diagnostics to see if there is any errors i get this message.

“diagnostics have found some errors and could not fix them”

i tried to uninstall and it wouldn’t, then afterwards i tried to install the new version “on top” of the old, as it was kinda removed. then uninstalled and reinstalled again. (this time it did it without problems)

if i try to uninstall Comodo Secure shopping i get this:
Could not overwrite file “c:\users\user\appdata\local\temp\comodocss_temp_setup\cssstart.exe”. access denied.
I don’t know if it’s supposed to do that? or thats an error too??

Don’t know if it can be related but…
(i also had problems with Comodo dragon, but i think i got that fixed, it seems to work after i ran the “sfc /scannow” command, this was before i checked CIS)

update: cross post
I went through at least 3 uninstall cycles with 2 or more reboots per cycle. It finally uninstalled Comodo FW but now after a reinstall, I have multiple registry errors after running diagnostics. How can I clean this up?

<?xml version="1.0"?>

<RegKey Status=“Failed” Error=“0x00000002” Path=“HKEY_LOCAL_MACHINE:SYSTEM\CurrentControlSet\Services\cmdAgent”>

<RegValue Status=“Failed” Error=“0x00000002” Name=“Group” Type=“String(CaseInsensitive)” Expected=“COM Infrastructure” />
<RegValue Status=“Failed” Error=“0x00000002” Name=“DependOnService” Type=“MultiString(CaseInsensitive)” Expected=“RpcSs” Comparsion=“IgnoreEmptyLines” />

<RegKey Status=“Failed” Error=“0x00000002” Path=“HKEY_LOCAL_MACHINE:SYSTEM\CurrentControlSet\Services\cmdvirth”>
<RegValue Status=“Failed” Error=“0x00000002” Name=“Description” Type=“String(CaseInsensitive)” Expected=“COMODO Virtual Service Manager” />

There is actually nothing wrong as this is showing incorrect failures, for some reason these failed status will always appear even on a complete normal install. So you can ignore the diagnostic report, they are going to fix it in a future release.

A. THE BUG/ISSUE (Varies from issue to issue)
Can you reproduce the problem & if so how reliably?:
Yes, every time.
If you can, exact steps to reproduce. If not, exactly what you did & what happened:
1:I go to “remove programs” (or whats its called in english)
2:Right click on Comodo Internet Security and pick Remove/edit
3:and pick “yes” and then “repair”
One or two sentences explaining what actually happened:
Whenever i run the diagnostics to see if there is any errors i get this message.
“diagnostics have found some errors and could not fix them”

One or two sentences explaining what you expected to happen:
That it either find 0 errors, or is able to fix them.

If a software compatibility problem have you tried the advice to make programs work with CIS?:
I don’t know which program that would be.

Any software except CIS/OS involved? If so - name, & exact version:

Any other information, eg your guess at the cause, how you tried to fix it etc:
I have no clue

Exact CIS version & configuration:
Configuration: proactive

Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
Hips: safe mode
sandbox: enabled, i don´t know which level?
firewall safe mode
av: stateful

Have you made any other changes to the default config? (egs here.):

Have you updated (without uninstall) from CIS 5, 6 or 7?:
sort of, explained in the post above this.
if so, have you tried a a a clean reinstall - if not please do?:
Yes i have.
Have you imported a config from a previous version of CIS:

OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
Windows 10 64 bit, AUC on standart setting (2nd highest), Administrator.

Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
a=Malwarebites antimalware b=SuperAntiSpyware (i think)

EDIT: Oh, I see you attached the file to your post.
I have yet to meet an error that CIS could fix. They tell me some errors can safely be ignored. Try uploading the report to a service like one drive and find a staff member to send a message with a link to the file. I think my last report may have been sent to Dharshu.

V12.2.2.7036 (Firewall only) on Windows 7 Ultimate 64-bit

I would like to know if it is normal behavior that when a clean installation is performed (on a system where no V12.x was installed before) and Diagnostics is run for the first time it then finds issues which it cannot fix and creates a failure zip-report?

During installation I didn’t encounter any problems and everything is working normally (so far that is) so I was wondering why Diagnostics fails and produces a failure report zip-file.

Yes known issue you can ignore it.

Hi guys,
i’ve only problem: diagnostics don’t work now.
Someone help me?

Hello Avos,

Thank you for reporting.It’s an known issue and we are working in it.
Have a nice day!

Kind Regards,

thank you very much :-TU


Probably the same issue, just to add to this bug …

Split and merged all posts regarding this issue, it is a known issue and is being worked on.

Edit: bug 2437

i installed it completely new and get this message from diagnostic tool:

Error log attached here:

Can somebody help me.

I suggest this action:

  • Go to the Windows control panel
  • Add / Remove programs
  • Click on Comodo CIS> then uninstall> Choose Repair
  • Wait for the repair and check if it’s OK


same. still error message. but the program works. should i ignore the message then ?

You must check the error log by exporting it