Defense+ slows down apps & computer


I have been noticing that Comodo Firewall with Defence+ seems to be slowing down my windows 8.1.1 x64 system, this is very noticeable when opening apps & general pauses in the system. I have uninstalled Comodo several times & when reinstalling I set it to proactive config, I have also let it run in training mode for a couple of days & it seems to work fine & there is no slowdown then apps are slow in opening, for example Task Manager can sometimes take up to 30 seconds to open, also happens with Mailwasher v3, browsers (Firefox, Chrome, Chromium & Opera) Games etc.

When I had windows 7 x64 on the system with the older Comodo Firewall v5.10 I never had these issues, it only seems to happen with Comodo v7, Only other security software is Bitdefender AV+ 2014, Spyware Blaster & MBAM free.

System is AMD Sabertooth 990FX motherboard, AMD 8150 8 core CPU, 16GB fast ram, AMD 7870 graphics card, Intel 520 SSD as system drive with Windows 8.1 Pro x64, 1TB Samsung HDD & Samsung 250GB 840 Evo SSD as games drive.

If I put Defence+ in training mode for a couple of days there are no slowdowns, when I put it back to Clean PC mode there no slowdowns for a day or two then they start again, this is driving me up the wall & I’m very close to removing Comodo for good, I have noticed that the CPU has high usage as shown in the attached image.

Any idea’s.

[attachment deleted by admin]

Anyone have any idea’s at all?


Seems that no one cares or can offer any help, guess I will just have to uninstall Comodo Firewall then.

I know HIPS can slow things down at times but having never had these issues before until Windows 8.1.1 x64 & Comodo Firewall v7 I thought the helpful community here could share some knowledge or offer advice, guess I was wrong.

Hi Banzi,
Sorry to hear you are having this issue.
It is not that no-one cares, it is a community based Forum and users will only reply if they know of a solution. :slight_smile:

It maybe worth considering creating a bug report for this issue.
Bug Reports - CIS
Required Format For Reporting Bugs

Thank you.

Sorry captainsticks but your reply wasn’t very helpful.

This & other issues with Comodo firewall are really starting to annoy me.

  1. It forgets hips rules, I ran alien breed in training mode & played for 2 hours & then switched back to safe mode but when I try to load the game the next day I get a alert saying steam wants to load alien breed then another saying it wants shutdown privilege then it wants to monitor keyboard etc despite it being run in training mode the day before. It also does this with non game apps.

  2. Quite often the alerts dialogs are messed up, instead of the correct defence+ alert it says open hosts.bat wants to run notepad.exe & the bottom of the alert is cut off & can sit like that for anywhere between 5 seconds to over 1 minute (see the attached screenshots)

  3. Most times when opening the hips rules section in options the rules are completely blank as shown in screenshot, sometimes I have to close the options & open then again several times to get them to show & other times they only show again after a reboot.

  4. It doesn’t like BitDefender AV+ 2014, I don’t reboot the PC often & when Comodo is installed I get lots & lots of entries in task manager for BitDefender Anti Virus Scanner & BitDefender Security Centre that all take up memory & only vanish when the PC is rebooted, it’s almost as if Comodo wont let the autoscan & security centre processes to quit, remove Comodo & it doesn’t happen.

  5. it seriously lags my reasonably fast system that has Windows on a fast Intel SSD drive, I double click a icon on the desktop & nothing happens for 2-5 seconds then I get the blue spinning cursor then after a long pause the app opens, eg I right click taskbar & click Task Manager & sometimes it can take over 1 minute to open it, same with lots of other apps on my system.

  6. The defence+ alerts as well as not appearing correctly are very laggy, when you move the mouse over either allow, block or treat as it doesn’t highlight them & if I click on remember my answer to tick or untick nothing happens for a while then suddenly the tick mark is applied or removed. If I click on allow the alert can stay on the screen for a while as well & it’s the same with the other options.

  7. With both BitDefender AV+ & Comodo firewall installed I cant use Opera Browser (the new blink version) I open it & the interface opens but it doesn’t do anything, the tab just says loading & if I click on any bookmarks or even click settings another tab opens but it just says loading, remove Comodo & Opera opens fast & shows the speed dial page.

I know computers & I am network+, MCP & MSITPro certified, I have been a user of the firewall right from the early versions & I run a secure safe system, scans with BDAV+ & MBAM & Eset online scanner show no infections. I only use Comodo firewall & disable any virus scan options in the settings like Viuscope & also the behaviour blocker.

I never had any issues like this on Windows 7 with BDAV+ & Comodo 5.10

[attachment deleted by admin]

Well if your wanting to use two security suites, you should pick only one resident shield otherwise you’ll run into the issues your having when the software tries to access each other, which will trigger their self dense because they think malicious software it trying to circumvent their protection and monitoring.

You should add each other to the exclusions.

Thanks for the reply aim4it :slight_smile:

Problem is I’m not using 2 security suites, BitDefender AV+ 2014 is just a anti virus with some privacy features like Wallet which I disable completely both in the BD GUI & using Autoruns to disable the startup items for it & SafePay browser for online banking which I don’t use.

I don’t use CIS, I have only ever used the CPF installer & only use the firewall & HIPS, behaviour blocker, viruscope & any other AV type features are disabled. I had the firewall excluded in BitDefender & had BitDefender excluded in Comodo firewall.

All the issues above have vanished after removing Comodo & installing Private Firewall but I would prefer to stick with Comodo as I know the in’s & out’s of it & how to configure it.

Did you check Defense+ logs?
Some of the issues that you have mentioned are known and forwarded to devs for investigation.


Cheers for the reply qmarius :slight_smile:

Whenever I checked the defense+ logs there was nothing there even though logging was enabled, the same with the firewall. The GUI said there had been some network intrusions but when I checked there was nothing in the logs at all, in fact the only entry in any of the logs was that the log file had been cleaned.

I hope they fix them very soon, I don’t think there has been any updates for few months now.

Did you try a clean re-installation ? (using removal tool)


Did you check the entire time frame period in logs?

@qmarius yeah I have done numerous clean installs of the firewall, uninstalled it using programs & features then rebooted & then rebooted again just in case then ran the comodo uninstaller tool from these forums & rebooted again then reinstalled it, ran it in with HIPS in training mode for a couple of days & there were no issues other than Opera not loading any pages, settings etc. The issues start shortly after I change the HIPS to safe mode but I have also tried clean PC mode as well.

@aim4it the logs have always been blank for some reason other than a entry for cleaning the log file, I tried all the settings for the log viewer but it was always the same.

Really appreciate the help & posts guys :slight_smile:

Please create a restore point and run the removal tool in Safe Mode.

After that, please install using these installers: