Defense+ causes CPU load on apoint.exe (v3.0.16.295) 32bit

Updated to 295 and maybe I am a minority, but D+ after several updates still makes apoint.exe process go high cpu. I shut off D+ and all is okay. Is this something being worked on, or do I need to get a new pc for it to work properly?

I’ve been searching all over to try to find out why apoint.exe was using so much CPU, and you are right. With D+ disabled, it used about 4% (10% max), and with D+ enabled it using around 30%!! Even when I am not using the touchpad at all, it still uses at least ~20%.

I’m using a Dell laptop, and judging by the million hijackthis log files, apoint.exe ships with almost all Dell laptops with touchpads, so this is a widespread problem. I tried adding apoint.exe to my trusted list, but it told me it was already a trusted application. I also tried adding some of the daughter files for that driver, but with the same results.

Anyone have a work-around at least?


Is anything shown in the Defense+ log related to apoint.exe?


Nothing here either. Just eating up the CPU…

Ok, i see. I found your previous report here. So this thread will be moved to Bug Reports.

Btw, can please both of you give some more information (see here).

As a temporarly fix i suggest you to disable D+ log (under “Miscellaneous” settings).
If won’t help, you may try to uncheck items by turn under GUI->Defense+ ->advanced->defense+ settings->monitor settings (see screenshot) to find out if any of these settings cause that issue you described.


[attachment deleted by admin]


I have been exploring this same issue.I can reproduce on Dell laptop, Apoint.exe consumes between approx. 20%>40% cpu, with Firefox, or IE browsers, however with Opera browser this does not happen( devs take note ). this may not be a CFP issue, however this is a production machine, and I wil not experiment further.

Edit, just clarify, This does not happen with D+ disabled.
Edit2, So I tried most internet capable and other apps, including GoogleEarth with looping KML files and this does NOT occur, this appears to be a browser problem.


Dell 600m, 1.4ghz, 2ghz ram
XPhome sp2 fully patched
CBOC 4.25
Antiver premium 7.x fully updated

Here is the additional info you requested:

  1. CPU (32 bit or 64 bit) - 32

  2. Operating System information (including Service Pack Version) - xp pro sp2

  3. Actively-running security and utility applications - avg, windows defender

  4. Specific symptoms of the bug, and steps you can take to reproduce it. - apoint.exe going to ~30%load after some time, maybe ~2hrs after update. No relation noted. If I turn off D+, it goes back to normal. If I turn D+ back on, it immediately causes apoint.exe to jump back up.

  5. Specific steps you have taken to try to resolve it. - Disabled D+ for now.

  6. Brief description of your Defense+ and Firewall+ mode (Custom, Train with safe) plus mention if you modified any setting in ADVANCED section of D+ and F+ - F+ set to ‘Train with Safe Mode’ D+ was at ‘Clean PC Mode’, now disabled.

  7. No error reports or log entries present.

Is there anyone willing to follow goodbrazer’s troubleshooting procedure? This will help devs to find the issue faster…

C’mon (:AGL)

[ at ] goodbrazer you got a PM :-*

Gibran, what did I do to prompt that reply?!? I sent the additional information detailed in the link you sent. As mentioned, there is no dump or log entries to give. What are you looking for?

If you look in advanced\D+ settings\monitor settings you can keep Defence+ partly enabled. goodbrazer posted a screenshot.
You can disable specific D+ monitor settings. The result of this test will point out what part of D+ need to be disabled. This will restrict developers researches only to a specific D+ monitor.

BTW that reply was meant to encourage all those that confirmed this issue to take this test. No harm intended. :slight_smile:

Other few bits of useful infos could be apoint version and an official download site (if applicable)

I cannot even imagine how devs are going to address this if apoint is an hardware related software.
So I guess they will be grateful for each additiona info posted here.

Now I understand… (I thought I was to do the narrowing down, if disabling D+ didn’t work.) I cleared all monitors, turned D+ back on in clean pc mode, and checked/applied each one from top to bottom. It went CPU-hungry on the last one, (figures!), ‘keyboard’. I am leaving D+ on now with that one unmonitored.

The apoint.exe is contained within the Alps driver version 5.3.511.2 which came with my Sony Vaio VGN-T17GP.

Hope this additional info is helpful!

Yep this will narrow down devs searches a lot.

Thanks :-TU

Confirmed on also if you disable Monitor Settings, Keyboard the cpu kernel load drops to 0% for apoint.

Apoint Driver = 5.05.0101.0156


I have the exact same laptop as Serta.(dell 600m)
Comodo version:
apoint version: 5.05.0101.0141

If I enable defense+ (Clean PC mode) apoint start using between 30 and 50% of my CPU.

I use Comodo for a while now and this problem started since a couple of weeks. I didn’t change any of my hardware and didn’t install any new software.

The only solution I found helpfull so far is disabling defense+.
Is there any beter solution?

Thank in advance,



Is apoint.exe (or whatever) allowed to access keybord directly (you can check this looking into computer security policy of Defense+ for apoint.exe permissions)?

If so, does problem disappear if you uncheck “keyboard” under Defense+ → Advanced → Defense+ Settings → Monitor Settings while all other options are checked there?

I am also having this problem with Apoint taking about 20% of my CPU.

I can confirm that the problem disappears when I uncheck keyboard monitoring as just described by goodbrazer.

Dell Inspiron 6000, Intel centrino 1.6Ghz, 2Gb ram
32bit XP Pro with SP2 (build 2600)
CFP version
Apoint version

Having firewall security level at “Custom Policy”
and Defense+ level at “Clean PC” with every monitoring active except keyboard
Apoint.exe is now consuming 0-2% of my CPU.

I have a DELL Inspiron 8500 and canconfirm the exact same behaviour.

APoint version (as reported by Sysinternals Process Explorer - 5.05.0101.0156)

This has XP Home edition SP2 with AVG and Avast anti-virus, Firefox (latest as of April 18th 2008) browser, WinPatrol as well as SpyBot. I am running Doppler.

As soon as I unchecked the keyboard in the Defense+ settings as described in this thread before, processor use dropped stunningly.

I, too, had noticed APoint hogging the CPU for the past few weeks, or is it months - not really sure. I used to remark on how hot my 5 year old laptop was getting and wondered what would happen if the fan stopped functioning!

I am willing to do some troubleshooting if necessary.


Do you have x32 or x64 windows os?
Can you please try latest version of COMODO Firewall Pro and report back with results?

Can anybody else confirm same issue with latest version of CFP (don’t forget to mention details of your system etc.)?

I can confirm that defense + with keyboard monitoring causes a drastic increase in apoint.exe CPU usage on my Vaio FE770G with 2 gigs ram, core2duo 1.83 ghz. With keyboard monitoring engaged apoint was using 10% with keyboard monitoring disengaged it goes back down to 1%. I was wondering what the problem was and a google search brought me to this forum. The version of Comodo is the version 3 that would have been on your servers yesterday. I think it’s a greet product BTW and good luck getting this problem fixed.

p.s. version x32