cvtres.exe (netframework) 99%

firewall ver. (and 364 same problem)
win xp2 sp3

cvtres.exe uses 89-99% constantly and did not load related program wich user .net framework (for me- an application from USB device)

disable (firewall and defence ) - did not help.
uninstalling comodo firewall - helps

no such problems with early version of the firewall

Thanks for help or buf fix

What is cvtres.exe first of all. Did you try putting D+ in training mode? Did you try to manually add that exe to D+?

cvtres i s windows .net framework related program

I try to lunch program from usb device (“keepass.exe” actually). it starts cvc.exe which lunch cvtres.exe and stucks with 99%

cvtres.exe: The resource-to-object converter. This tool is often used to convert a binary resource file to an object file. Native resources usually start life as an .rc file, get compiled to a .res file using rc.exe, get converted to a .obj file using cvtres.exe, and finally get linked into your native application like every other .obj file

csc.exe: The Visual C# compiler.

training code - no help
disabled - no help


manual - cvtres is already a safe application
manual - keepass - without change

Its possible that there is a problem working with USB devises in new comodo ver ?

I experience very similar problem.

Loaded guard32.dll causes some .NET Framework components to not operate properly.

Steps to Reproduce:

  1. install AutoCAD 2008, install CF (Comodo Firewall), set D+ to training mode;

  2. launch AutoCAD, when all CF components (drivers, service, guard32.dll, gui) are up and running;

Actual Results:
Cvtres.exe hits 100% CPU usage and stays there forever (see screenshot), until terminated.

Build & Platform & Other security apps:
XP Home SP3 x32 (all latest updates), CF (fresh install without toolbar), CMF
.NET Framework 2.0 SP1 + RUS language pack.

Additional Information:
Preventing guard32.dll from loading in memory at system startup (renaming, deleting) completely solves problem for me. Note that other system and CF settings are unchanged, what make me think it is definitely related to guard32 library.
Most likely, CF 3.0.21 didn’t have such problem.

[attachment deleted by admin]

Me too.

Install Visual Studio 2008, New | Project | Visual C# | Windows | Windows Forms Application, and Build,
then Cvtres.exe hits 99% CPU usage and stays there forever, until terminated.

Tell me if all you who’ve reported the problem have Comodo SafeSurf installed. Back in the CMF forum I reported a bug of this exact same problem.

Same problem here with this exe; yesterday I updated the firewall to the last version and soon realized that two different processes were loading ramdomly on memory moments after the start up. One of them was the cvtres.exe, with a 25% of CPU usage; the problem was that after this first one, two and finally three more instances were loaded -25% each- so the CPU usage soon reached 100%.
Today I decided to go back to the old version and so far -3 hours later-, everything is working fine.
Even the port 135 seems to be closed now (at least it´s not listed in the “Active conecctions” window: it was “listening” with the new version). Read this report to see what I mean.

BTW, I don´t have installed the Safesurf, and the firewall is running with the default config.

HP Compaq Quad Core Q6600 2.40 Ghz -all programs+drivers updated-
W Vista Home Premium Sp1 x32
3 Mb Ram
Nod32 v3
Defense+ in “Clean Pc mode”

no surfsave instaleed - the problem of cvtres exist

I think that the same happens with java.exe too -very high CPU usage

Uninstall CFP_Setup_3.0.24.368_XP_Vista_x32.exe, and Reinstall CFP_Setup_3.0.22.349_XP_Vista_x32.exe, everything is OK.
MY OS: XP Home SP3 x32 (all latest updates).

Reproduction :
After install CFP_Setup_3.0.24.368_XP_Vista_x32.exe, Defense+ Security Level set to “Disabled”, “Monitor Settings” uncheck all, click Apply button.

Run cmd.exe open a command line window, then save attachment cvtres.txt to anywhere and goto there rename it to cvtres.exe and run it, it will hang.
Uninstall CFP_Setup_3.0.24.368_XP_Vista_x32.exe, and Reinstall CFP_Setup_3.0.22.349_XP_Vista_x32.exe, everything is OK.

Attachment cvtres.txt MD5 hash value:
It’s a C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\cvtres.exe.

[attachment deleted by admin]

No SafeSurf here installed. Didn’t try to disable CMF and it’s driver though, but don’t see any reason, because in my case it is definitely connected to guard32.dll.

Edit: thanks for the tip, maybe one more CF-CMF confict will be revealed (one already reported).
Will try to play with CMF when reach machine with AutoCAD installed.


I have a SOMEWHAT similar problem:

with CFP_Setup_3.0.24.368_XP_Vista_x32.exe or CFP_Setup_3.0.22.349_XP_Vista_x32.exe installed if I try to build a project in Visual Studio 2008 the build process runs forever (VS gets frozen); the cvtres.exe process (launched by devenv.exe, i.e. by VS) takes 50% CPU time; CF does not show any messages and does not ask any questions; if I kill the cvtres.exe process visual studio becomes responsive (but the build remains incomplete, of course). This happens even if d+ is not installed and both VS and cvtres.exe are specified as trusted applications.

With ComodoFW_3.0.16.295_XP_Vista_x32.exe VS builds run without any problems. I have not tried any other versions of CF.

In addition to this message.

Adding cvtres.exe to CMF exclusion list completely solves a problem for me. It seems it’s another conflict between СF and CMF.
Very similar case.

Edit: sorry i forgot about people not familiar with these abbreviations.
So, CF = Comodo Firewall and CMF = Comodo Memory Firewall.

sorry for my poor english

i had same problems with applications loads cygwin1.dll (ex testdisk, cdrtools (cdrecord.exe,
mkisofs.exe etc…)

Have had these problems once befor (~comodo 3.0.15 or so),but haven’t had
3.0.16~3.0.21, and problems again from 3.0.22

Exiting CMF is not enough, I must stop cmfd.sys manualy

Solved for me too.
Thanks for the info.

I’m with jtabos, solved my problems with cvtres.exe :BNC

workedaround for me too (:WIN)
i had to put cmd.exe and mcbuilder.exe in the CMF exclusionlist.
Problem “gone” remove them from the list and the problem is back.


cvtres.exe is causing me grief, too.

Vista Home Premium, SP1; Comodo

I have no idea what is starting cvtres.exe, it seems to appear on its own. Example: I was browsing the Web (Firefox 3.0RC2), while recording a VHS tape to disk (Honestech VHS to DVD,) with my email program (Thunderbird) and WordPerfect open.

Because I’ve had problems with cvtres.exe for three days or so now, I have the Task Manager open to show the CPU use. Suddenly, the computer cooling fan started running faster, and the CPU use jumped from 40-50% to 100.

I closed TWO instances of cvtres.exe, and CPU use dropped back to 40-50%.

I thought that I had told Comodo to ignore cvtres.exe, but it is quite possible that I did not do so properly, as I’m not at all certain how to do that.

Thus, more detailed instructions on how to fix this problem would be appreciated, along with any hints as to what might be calling cvtres.exe. (As far as I can tell, none of the open applications use the .exe, as turning cvtres.exe off in the Task Manager has no effect on those applications.)

Is there any sight on this being fixed in the next release ? Any admin here ?
I have a list of 15 program’s in my CMF exceptionlist now (:SAD)

I just had this problem too with mediaportal HTPC software - using CMF, cvtres.exe was reaching 100% cpu and doing nothing - after adding to the exclude list it’s fine