Custom ruleset does not appear as an option in Treat as popup [M378]

A. THE BUG/ISSUE (Varies from issue to issue)
[ol]- Summary - Give a clear summary in the topic subject, NOT here.

  • Can U reproduce the problem & if so how reliably?: yes, always
  • If U can, exact steps to reproduce. If not, exactly what U did & what happened: a) define a custom ruleset that allows all IP traffic from [Home #1] to [Home #1]
    b) set firewall setting to “Custom Ruleset”
    c) from a Command window execute “ping
    d) the firewall popup appears, but under “Treat as” there is no option to choose the above created custom ruleset
  • If not obvious, what U expected to happen: custom ruleset should be there (in the above example, I might want to be able to let pings happen on the local network, but not to the outside world)
  • If a software compatibility problem have U tried the conflict FAQ?: n/a
  • Any software except CIS/OS involved? If so - name, & exact version: no
  • Any other information, eg your guess at the cause, how U tried to fix it etc: the UI tries to be too smart: the IP does not match the ruleset, hence the ruleset is hidden ?
  • Always attach - Diagnostics file, Watch Activity process list, dump if freeze/crash. (If complex - CIS logs & config, screenshots, video, zipped program - not m’ware): diagnostic file attached; Watch Activity: printscreen of Task Manager

B. YOUR SETUP (Likely the same for each issue, so you can copy forward)
[ol]- Exact CIS version & configuration: 6.0.264710.2708

  • Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV: Firewall only
  • Have U made any other changes to the default config? (egs here.): custom ruleset
  • Have U updated (without uninstall) from a CIS 5?: no
    [li]if so, have U tried a a clean reinstall - if not please do?: no
    [/li]- Have U imported a config from a previous version of CIS: no
    [li]if so, have U tried a standard config - if not please do: n/a
    [/li]- OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:Windows 7, SP1, 64bit, UAC=on, admin, no
  • Other security/s’box software a) currently installed b) installed since OS: a=Avast b=?

------------ original message below -------------
GUI bug: custom ruleset does not appear as an option in “Treat as” popup

I have added 1 custom ruleset.
I have deleted the predefined rulesets FTP Client and Email Client.

(btw, I deleted them so that I would not need to scroll to get to my custom ruleset)

The custom ruleset does sometimes appear, but most of the time it does not. The deleted rulesets do not appear.

CIS 6.0.264710.2708
Windows Home Edition x64

[attachment deleted by admin]

Rulesets should appear when they would provide a solution to the given alert. (BTW this will require a full bug report should you in future want to report it as a bug, as more than just the GUI is involved.

Best wishes


From the information you have given I am not clear whether this is a bug/issue.

For the moment I will transfer you to help so you can work through this issue with users and mods in this forum and hopefully resolve it. I hope that is OK.

Please ask any mod to move this report back to the bugs forum if it becomes clear that it is a bug/issue.

Best wishes


Well, I do think it is a bug. And I think it is related to the GUI only (firewall works as expected).
See the attached screenshots to illustrate the problem.

[attachment deleted by admin]

If possible to see if it is a bug I’ll need all the ruleset details for ‘inhuis’ (local?) please.

Best wishes


Hi Mouse,
“inhuis” indeed means “in house”, i.e. all computers and equipment in my house.
See attached screenshots.

[attachment deleted by admin]

Not a bug then I think.

The policy is not displayed because it could not be a solution to the alert. The alert and the policy deal with different IPs

Maybe CIS is being a bit too clever?!

Best wishes


I may want to enable traffic for that particular application but not under the conditions of the current situation. If I choose “block” it will create a rule that I don’t want.

Indeed a case of a user interface trying to be too smart.
I wonder why you would rule out a choice that would block the traffic but allow it under specific conditions. It is not because the specific conditions aren’t met at the moment of the choice that the option should not be available.

If a user is smart enough to define rulesets and zones, the user interface should not try to be even smarter! :wink:

As long as you don’t ‘remember this’ a rule doesn’t get created.

I created a custom ruleset to limit access by certain applications on my system to my local network only, but when I get the popup prompt for whether to allow applications or block them or ‘treat as’ my custom ruleset is not in the list of available rules. Instead if I want to apply it to the application I have to choose to block the app from the popup (so I can dismiss the popup) then go into the advanced firewall settings and change the applicable ruleset for the particular program in there to use my custom ruleset.

I am running Comodo Firewall version 6.0.264710.2708 (you guys REALLY need to provide an option to copy the version number to the clipboard if you’re going to use such long version numbers too).

On Windows 7 Ultimate 64 bit, with an AMD FX6100 6 core processor, 8Gb DDR3 RAM.

I even tried rebooting to see if maybe the list of rulesets needed to be reloaded by CFW maybe.

I also tried switching the firewall mode from ‘Safe Mode’ to ‘Custom Ruleset’, and still my custom ruleset was not available (unless I went through the hassle of going into the advanced firewall settings and manually applying it as stated above).

If it matters I named the ruleset “Local Network Access Only” (though I would think that in the list in the popup if it were an issue with it being too long it could be truncated to something like “Local Networ…” so it would still be available.

Looking forward to hearing back on this issue, Thank you.
Edwin Barton

This issue appears to me to be the same as one already on file. Accordingly, I will merge them, if that’s OK. You can locate the merged report by following the link in the email notification.

If you don’t agree please PM any active mod with your reasons and, if appropriate, they will unmerge the issue.

Many thanks


I think we have understood this issue now, that’s why I have moved this back to bugs.

If tomvdp would like to edit the first post to create a a full bug report (not a GUI report, we need steps to replicate etc), then I will forward to format verified and track it.

Best wishes


PM reminder sent

Thanks very much for your issue report, which is much appreciated.

We have moved it to the non-format bugs board for the moment, because it is not in the standard format or too much of the information we normally need to replicate a problem and fix it is still missing.

We realize some people may not have the time to do an issue report in standard format, and therefore offer the option of a non-format report instead. But the problem is much more likely to be fixed promptly if you edit your first post to create an issue report which reflects the guidance in the Standard Format topic. (You can copy and paste the format from this topic). The reasons we ask for the information we do are given in this post.

You can get your report moved to the format verified issues board simply by ensuring that it reflects the guidance in the standard format topic, and PM’ing a mod who is active on the bug board.

Best wishes


Hi TomVDP. You are in non format at the moment but I only need the following to move you to format verified.

8. Always attach - Diagnostics file, Watch Activity process list

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again


Can you please check and see if this is fixed with the newest version? Please let us know whether it is fixed or you are still experiencing the problem.

Thank you.

PM sent.

I am still seeing the same behavior…

Thank you for checking.

I have updated the tracker.

The devs have flagged this as fixed. Thus, I will move this to Resolved.

Please let me know if you are still experiencing the issue.

Thank you.