CPF can't work well with PPP (Solved)

1:With the computer ON, CPF show no adapter, OK.
2:Then Dial PPP, the adapter OK.
3:The firefox opens a page, then close it.
4:Disconnect the PPP adapter.
5:CPF show adapter with IP:0,0,0,0.
6:Dial PPP again
7:CPF show the other adapter with correct IP when click “Next”.
8:But the Firefox and other application can’t find the correct adapter,but they can only access the adapter with IP:0,0,0,0.

Is this a bug? Or is there an operation which can solve the problem?

There will be two PPPoE adapter,and the one with IP, the other with correct IP.

Hi hahashijie, welcome to the forums.

The Adapter shown on CFPs Summary page is the active Adapter & is informational only, I don’t believe the “Next” button does anything other than display other Adapters, it doesn’t change anything in CFP. I also use PPP Dial-up. But, when I don’t have an active connection, CFP shows “No Adapter” on the Summary page. I believe PPPoE is for ADSL. So, I guess you have many Adapters? Maybe ghost Adapters of previously used hardware?

So, is the problem that after connecting, disconnecting & reconnecting Firefox does not work?

Check CFPs Log (Activity tab) to see if anything is being blocked.

Kail, all your beliefs are true. I have PPPoE and it’s ADSL. If I disconnect, CFP summary only shows my modem/NIC/Ethernet adapter IP without the next button. I don’t if that’s normal, but there’s nothing on my CFP that ever shows

Maybe this site is related: http://support.microsoft.com/kb/822123

I suspect the is a ghost adapter (hardware long time removed/disabled).

Hi,kail and soya
I use the CFP with kaspersky anti-virus together.

1:With the computer ON, CFP show no adapter, OK.
2:Then Dial PPP, the adapter OK.
3:without connection.No application connect to internet.
4:Disconnect the PPP adapter.
5:CPF show no adapter, OK. Kial,here you are right.
6:Dial PPP again
7:Any appliction connect to internet,for example:firefox. Close it or not.
8:Disconnect the PPP adapter.
9:IP displayed only on CFP,you can’t find ppp adapter from sysytem control.

The picture can’t be upload.

Hi hahashijie

The address is a reserved address and typically refers to the default route or sometimes ‘This Network’

When you have your PPP adapter connected, you probably see your IP Address and a net mask of This too is a special address, It basically means a broadcast on the entire network.

Essentially, what I believe you seeing here, with, is simply CFPs way of dealing without a connection. It simply says, ok, I have no information on where to send data, so I’ll just use the default route.

By the way, you can see the routing table easily if your on Windows… Open a comand promt and type ‘route print’ You’ll see the first entry is


very good!
the default gateway is not even the displayed on CFP when the PPP adapter is connected.
But the CFP can’t lead all the applictions to touch internet throught the correct gateway.
How can i tell CFP the correct gateway?
If the CFP get the, i must restart computer to tell that:Hi,CFP,please get the correct gateway.
Is a bug there??? Or Is there an operation to solve the problem?

Hi hahashijie

Often, such things as ADSL modem/router software, add virtual communication devices & removed hardware sometimes leave these devices behind (what I was calling “Ghost” adapters. You can see all these devices by doing the following… right click “My Computer” on desktop & select Properties. Select the Hardware tab & open the “Device Manager”. Finally, Menu item “View” & select “Show Hidden Devices”. You should now see any ghosts devices under “Modems” and/or “Network adapters”.

However, when CFP shows a adapter… does it matter? Does it have any effect? I suspect that soon as a active adapter appears CFP will switch to it automatically. Is this not happening?

No ghost device can be found.
and CFP can’t switch to the active adapter. is not an adapter.

you said: “However, when CFP shows a adapter… does it matter?Does it have any effect?”
Very bad,when the displayed,all the applications can’t access any network data.

What type of connections do you have under Control Panel > Network Connections?

Also when CFP displays what type of connection do you have active? Does anything work with CFPs Security Level set to “Allow All” (from the systray)? Is there anything in CFPs Log (Activity tab)?

network connection?just PPPoE dial-up
Active connection is PPPoE too.
Nothing in CFP log.
When there are two adapter wiht one is, my computer is isolated from internet.

For the CFP tell all the appliction the correct network destination is, no one can do nothing.

Unfortunately, CFP does not tell any applications how to connect to anything. It doesn’t work like that, CFP monitors and blocks or allows. But, it doesn’t direct network traffic or anything like that. That’s Windows job.

Does changing CFPs Security Level to “Allow All” (from the system tray) allow applications to work when is showing.

BTW I’m a bit confused about this… “when there are two adapters”, do you mean 2 adapters in Windows or CFPs Summary page?

two adapters,only on CFP summary page.
"But, it doesn’t direct network traffic or anything like that. That’s Windows job."Is it true?
Ok,I’ll test it again.
If failed, i must restart computer now.

Yes, CFP is a firewall… its job is to secure communications & prevent unauthorised access. It merely watches communication packets entering or leaving the system. The directing of network traffic (Gateway IPs, DNS routing, etc…) is a Windows function.

“Allow all” does nothing!!
I think the drivers installed by CFP do direct network traffic.
For example:
1: A want to access network.
2:A access CFP’s gate.
3:CFP check data
4:CFP tells the correct network destination.
5:A access complete.

If “Allow All” does not work, then the problem is unlikely to be CFP. With the Security Level set at “Allow ALL” CFP is, effectively, turned OFF & not doing anything.

CFPs driver: Well, yes… CFPs driver directs all network traffic through its packet inspector. That’s how CFP examines the packets. But, CFP only “allows” or “denies” packets, it does not alter them and, as such, plays no part in the actual directing of network traffic.

Odd question: If you don’t open CFPs front-end GUI and don’t look at the adapters… does it still fail/stop in the same way or does this only happen when you’re playing with the adapters on CFPs Summary page?

Sorry, I should have addressed your example directly…

CFP does not have a “gate” (see driver above), any logical gate it might have is “inside” Windows gate & not visible to the user. When you ask for comms access, you ask Windows not CFP.

CFP does check certain data… but, its only the packet data to make sure the packet is valid.