CPF BETA 32-Bit Bug Reports


First of all, I hope it’s okay if I start a bug thread for CPF BETA since there isn’t anyone.

I thought I’d start this thread with my own problem.

I installed CPF, and as usual, the first reboot was fine.
Did a second reboot, got this error message:


I’m not even using any virtualization software.

Running Windows XP 32-bit, all windows updates.

Other realtime security programs running:

SnoopFree Privacy Shield 1.0.7
Comodo Memory Guardian BETA
PSM AntiKeyLogger
Avira AntiVir PersonalEdition Classic
Spybot SD Resident a.k.a. TeaTimer

Going back to 2.4 for now, but I really liked being able to choose CPF 3 without HIPS, as most problems occur with the HIPS.

To the Comodo team, keep up the good work, I’ll be waiting for next release!



1. Computer information
2. Operating System information
3. Actively-running security and utility applications
4. Specific symptoms of the bug, and steps you can take to reproduce it.
5. Specific steps you have taken to try to resolve it.

Hi Ragwing,

This is unexpected indeed. Do you always get this error message? Or this happened only once?


The first log window that comes up will stop logging entries between 7:00pm and 12:00am my time every night. I can open the More window and they will all be listed there like they are supposed to be.

The logs will work correctly from 12:01am until 7:00pm each day. This has been the case at least for the last 3 betas.

This is a fresh install of WinXP SP2.


Found a bug with the file waiting for review feature. See screenshot.

[attachment deleted by admin]

CFP takes a long time to be initalized , when it is being initalized , I can see nothing in “View Active Connections” and “View Active Process List” , D+ protection doesn’t work , and a program can’t connect to internet which has no rule .
OS: windows XP sp2
AV: Avira Antivir

Someone has found the reason , if the system service “Terminal Services” is disabled , CFP will take a long time to be initalized .

[attachment deleted by admin]

There is a problem with cfpagent.exe. When the firewall first started if I tried to kill it it said access denied but now it lets me terminate it without saying anything. Anyone got any idea why it loses its protection?

it does take a long time to initialize. i liked the way sunbelt started before other pps and shutdown after too. can’t get utorrent and shareaza to completely allow incoming connections on selected ports

It happens everytime that CPF starts. I tried to reboot, but it didn’t solve the problem. I also tried to start it manually, but it failed too.
I doubt something went wrong during the installation, as I did it in safe mode.
Indeed, it seems strange that CPF 3 detects my computer as a virtual computer.
If you want more(like all) information about what processes and services I run and hardware information I’ll PM you it.


More trouble with that thing… I sometimes check files and mark them as safe, they don’t show up in my safe list but if I try to add them manually I’m being told they’re there.

Try not doing it in safe mode? It probably thought it was a virtual pc because in safe mode you can only access certain resources which is normal. I know you can install other apps in safe mode but all they do is write directories and files. Comodo needs to access registry, services…and yeah.
Also kernel i am sure can definitely not be installed in safe mode which is probably why comodo cannot open. The main part of it is missing.

Don’t think it is a bug justin. It is to do with the clean pc mode maybe? It lists all the files opened but does not need pending because they were classified safe at install. Probably is a bug though.

Ok thanks I’ll try. But it still doesn’t explain why it works after the first reboot but not after the second one.


Just read about privacyshield.

that guards your keyboard, screen and open windows from all spy software

I see a conflict right there. Antikeylogger can also be the cause and i do not see why it is needed with privacyshield? They look like they have the same function.

According to castlecops the only difference is compatibility.

These two anti-keyloggers are designed to detect hook based keyloggers. PSM AntiKeyLogger unlike SnoopFree Privacy Shield works on Win 98 as well as Win2K, XP

CPF 3 does the exact same thing. Best thing to do is uninstall privacyshield and/or antikeylogger and do the following settings.


CFP has exited , a program still can’t connect to internet if it has no rule .
OS : window XP sp2
AV : Avira Antivir

Probably to do with the self protection problem. Comodo is still open in the kernel/driver but the actual program interface was terminated easily so no alerts can open.

In both the old and new version I have NEVER seen the firewall’s main page indicate at least ONE inbound connection, even if I was running a P2P client.

I’m not sure anymore, because this morning when I checked it, everything was normal and files were being displayed normally ???

Mine still says 649 files, yet nothing in the list

This afternoon I checked… and wooot a new version. :BNC But after install my GUI is still ■■■■■■■ as in previous Beta. (:SAD) (See atteched pic)

Can this not be fixed? Or will CPF not show correctly at 120dpi?

1 - Operating System and Service Pack:
Windows XP Pro SP2 with all Microsoft updates on Gigabyte Motherboard AMD XP 3000+ and 1Gig RAM.

2 - Other Security Software installed:
NOD32, Windows Defender

3 - Running Windows on 120dpi (and no, I don’t want to just change my dpi. (:WIN))

[attachment deleted by admin]

I have atleast 1 because msn messenger is open. When i open utorrent it adds about 9 more.

Check the traffic box. If your p2p app is not listed than it is not making any connections (uploading/downloading). If your traffic box does not list your p2p than it is connecting in a extremely secure way or it is not connecting at al and could be blocked.