I am a user from China, I don’t speak English, I am using google translation. If there is any imperfect English word, please forgive me.。。。。。。

In the past two years, a problem with the comodo firewall has been bothering me.

My computer is a ThinkPad T420, the main hard disk location is Intel DC s3700, and the optical drive bay hard disk location is WD-BLACK-LPLX 500G.

This is a problem with this HDD. Every time I turn it on, I am used to popping up WD-LPLX, but from COMODO10, COMODO11, I will report an error.

The system now in use is LTSC (1809)

After installing MSDN Windwos 10 LTSC, install COMODO10-11, the system did not go through any settings, all errors can not eject the CD-ROM drive, and, and COMODO8.4.0.5165-OK, everything is normal, this problem only appears in COMODO10-11

The device is in use. Please close all programs and windows that may use the device and try again

BUG image has been uploaded to google-------

Sorry, I didn’t find a way to upload images in the comodo forum. .

1: Comodo Firewall version:

2: OS version:
Windows 10 enterpriseS LTSC (1809)

3: What you did:
I haven’t done anything. After installing the MSDN image completely, I will install comodo again and I will see this problem immediately.

4: What you actually saw:

5: What you expected to happen or see:
I hope to fix this bug as soon as possible, now temporarily turn off the HDD in the BIOS.

6: If possible attach a screenshot illustrating the GUI problem

BUG image has been uploaded to google-------

This bug only exists in comodo10 and 11, COModo8.4.0.5165 is normal, there is no such problem

My CD-ROM drive has been disassembled and installed with Lenovo ThinkPad 12.7mm Serial ATA Hard Drive Bay Adapter III (0A65623) with HDD-WD-BLACK-LPLX-500G installed, which is a pop-up Lenovo ThinkPad 12.7mm Serial ATA Hard Drive Bay Adapter III (0A65623) encountered a BUG

Hello there, you need to notice the format first. Take a look at this: [u];msg743135#msg743135[/u]

So there is a problem with your HDD when CIS 10 / CIS 11 has been installed, but it doesn’t appear while CIS 8.4 is running.
How about your windows version? Does the problem happen only in windows 10? Any version of windows 10?
And the problem is that you cannot eject your HDD with all default settings?

Well then, you need to edit your post to in the required bug reporting format so it can be forwarded to Comodo.

抱歉,第一次来英文论坛,已经修改格式,我只测试了EnterpriseS ltsc的system,并不知道其他版本是不是也有这个问题。

Sorry, the first time I came to the English forum, I have modified the format. I only tested the system of EnterpriseS ltsc. I don’t know if other versions have this problem.

问题好像在Comodo Internet Security v11.0.0.6744 Released已经解决了,感谢comodo

The problem seems to have been resolved in Comodo Internet Security v11.0.0.6744 Released, thanks to comodo

The Comodo Internet Security v11.0.0.6744 Released issue still exists. After upgrading to, it seems that the problem has been solved at first, but it will reappear soon. I seem to have found the problem. This problem should be related to the path of the trusted signature. I am a purely manual HIPS user, accustomed to emptying. The official signature, and then add the signature of the trust, tested several times, found the problem, that is, after running a program with a comodo signature on the HDD, and then through the cloud query, after joining the comodo signature library, the HDD cannot Popped up

Absolutely related to the signature. But it is not because of the signature. It is because a software is signed by the cloud after running on the HDD. Then I don’t know what causes the HDD to be in use and cannot be ejected smoothly.

As long as the software is not running on the WD-HDD. HDD is all right, but as long as it runs once, this problem is inevitable, and even if it is restarted, it is useless.

I am a CIS Premium user, could you export and upload your COMODO Internet Security configuration file?. You can export in configuration menu

This problem is not caused by the rules. Even if you reinstall it and use the official rules, it will not work. My rules do not apply to you. It is formed according to my own computer usage habits for many years.

Rúguǒ comodo de gōngzuò rényuán xūyào cèshì zhège BUG, kěyǐ liánxì wǒ, wǒ kěyǐ tígōng TeamViewer yuǎnchéng xiézhù, zhǎnxiàn zhège BUG.Shaopeng.Letter@gmail.Com
If the comodo staff needs to test this bug, you can contact me, I can provide TeamViewer remote assistance to show this bug.

I had a similar bug with a Toshiba external HDD, but the problem was solved by myself. The problem was caused by realtime antivirus module.

No, my computer does not have any anti-virus software, there is no anti-virus module, WD is closed, comodo I only use CFW, there is no anti-definite module, this is comodo’s own BUG, as long as HDD has copy and start exe action , will reproduce this problem

Are you using HIPS in paranoic mode or in secure mode?

Safe mode, but delete the official signature, join the trust signature, this has nothing to do with the mode, even if the newly installed system, the new installed comodo, and do not make any settings. This bug will occur as long as the HDD has motion.

Maybe some system HIPS Rules are lost, because they change when the system is updated, could you show me your HIPS settings screenshot under control options?. Could you copy these settings and answer later?

It has nothing to do with the settings. .
This issue occurs even if the new installation uses the default settings.

Maybe some blocked applications?

Or HIPS Rules?

Windows 8.1 System Rules only example

Could you take a HIPS Ruleset screenshot like above?

You don’t have to look for problems from rules or settings. The problem is not here, I am confident. . I have used CFW for more than five years. . . . The problem is in comodo itself, even if a new installation of MSDN LTSC, and a new installation of comodod, using the official default rules do not change any settings, there will be problems