Comodo won't shut down

Since upgrading to the latest Comodo I am finding that it ceases to respond to either right or left mouse click and when I come to shutdown my PC I get the classic Windows End Program box for Comodo and whatever I do I end up having to do a hardware shutdown - 5 seconds on the on/off button.

Running XP Pro SP3 with all patches.
AV is AVG, registered and paid for.

When the problem first showed, I thought it could be a dodgy update, so uninstalled Comodo, used the cleanup utility and then did a fresh download and re-install.


I am having the same issue, stops any popups from it so i cannot tell anything new to allow.

Windows xp sp3
Avast antivirus.

I had malwarebytes protection module running, since then i have disabled it, tried a clean install and a registry rebuild.

I am experiencing the same thing, but I do think it may be something to do with an AV update, because I ran trouble free for a week or two after installing version 5.

Windows XP Pro SP3
Using the whole CIS suite.

[attachment deleted by admin]

Make a notch for me on this one, too…

I got the update when it showed up recently. I’m an independent senior software consultant, and I run my own IT game in my office. I put it on one of the other laptops first, and it’s been working fine for that engineer. But I updated recently on my main Win32 (XP Pro) development machine, and it’s wreaked havoc for over a week now.

I have the same behavior as described here on this thread, but I’ll detail it a little more. After uninstalling several times, cleaning on one of them, I still am dogged by this bad behavior after ever reinstallation.

I install with firewall only, as I run alternate A/V (AVG). CIS installs the firewall fine, and I reboot, and it shows up the first boot and works fine (menu works, UI comes up when requested). Then I import my backed up config, and hum along fine for a session. Apache works fine, all my in/out apps work off my imported config from the backup, and it works like it’s supposed to

Upon rebooting, CIS either doesn’t show up in the tray at all, or it shows up in the tray and the tray animates, but I cannot get a menu on right click, and the UI does not open on left double click. I also cannot get the UI to open when I double-click the icon the installer put on the desktop. Several of my tools can no longer get to the network, though others can, and most importantly, some of my critical connectivity cannot make connections.

Of course, I cannot kill CFP.exe, though it’s running there in the process explorer. And, some of the popups do appear and can be interacted with. However, most popups don’t show up, but if you ALT+TAB, there are windows with Comodo Alert names that pile up in the window list. But you cannot get them to open or appear when you ALT+TAB to them.

Further, on shutdown, Windows XP (Pro, SP3 with all updates) takes a LOOOONNNNGGGG time to try to shut down, then it will tell you that ‘cfp.exe’ is not responding. You can tell it to terminate it, and after another LOOOOOONNNNNGGGGG time, it will finally successfully terminate it, and then will pause for another long time with “Windows is shutting down…” on the final screen.

I have now accepted this first as an update, then I have uninstalled and reinstalled with same results, and uninstalled, CIS clean.bat purged out and reinstalled, and finally just uninstalled. My computer bank uses Synergy to synchronize the mouse and keyboard between a bank of different Linux and XP computers and screens, and Comodo has pretty much killed off the XP machines for me. I had to get extra keyboard and mouse on the XP machine so that I could still interact with it. I’ve lost several partial days of work trying to reboot and get something working, but it’s really goofed up my networking something horrid.

I’m going to try to drop back to the old version if I can find it. CIS is just getting too fluffy, I’m afraid, and the unnecessary .NOT framework ■■■■ around the engine is just getting too top heavy, I’m afraid, and killing the interactive part of the product…

I ditched Zone Alarm for the same reasons… must they all go all whacky? It’s just a freakin’ security app, after all.

Funny thing, my Linux boxes are not so encumbered. It’s hard to even find security apps for Linux… there’s no niche for them over here… :slight_smile:

I’ll be happy to try something on the XP box. I write Windows apps and drivers, so I do need those machines and it’s my main Win32 dev machine that CFP pukes on. But I have XP running in VirtualBox on my Linux machines, and it doesn’t act up there. I’ll try some things on the affected XP box if I can get some concrete things to try that might actually be relevant…


try something for me, can you remove AVG and see how comodo firewall works now. I am seeing a pattern of some AV’s being incompatible with the new version of comodo.

I pulled AVG 11 off that machine, and have rebooted 3 times so far, and Comodo is, so far, behaving (I right-click gets menu, left double click opens UI). And the network problems have now stabilized on that machine.

I’ll post again later after more time to watch it. Uninstalling AVG isn’t really a solution, though…

if all is ok, why not run Comodo AV ( run the whole suite) it works just as good if not better then AVG and will give you a stable system and is free.

I am running Comodo v5 Firewall, Def+ and Sandbox with Avira v10 and have no compatibility problems whatever with this set up. I personally would prefer to use the Comodo AV but in every version since V4 I get a “oops Comodo has found a bug, and needs to close” pop up and then cmdagent shuts down and freezes up my PC. I have Win XP Home Edition SP3 and my PC is 7yrs old which I have concluded has something to do with it as other people I know with newer PC’s don’t seem to get this problem. Anyway try Avira as it works ok with v5.

I’m only running the complete suite of CIS and I have the shutdown issue as well… :-\

I’m working on a special cleaning video tonight to show everyone how I clean out my computer and what I do. This will solve a lot of problems for people.

Just wanted to say I’m having issues too with Comodo Free Firewall (v 5.0.163652.1142), but only since 2 or 3 days ago, so I’m hanging on for that video.

I’m running XP Pro SP3 with AVG Free 2011. I think the Comodo free firewall is great but I was never impressed with the AV package (mainly due to resource hogging by cmdagent) so I don’t see the full suite as an option.

I have to say I’m a little skeptical that ‘cleaning out’ my pc will fix the issue - I run a pretty tight ship and this issue seems to have appeared out of the blue for a number of people around the same time, but I’m not complaining if there’s a possibility this will fix a good and free firewall.

video is done, check it out and let me know if it works for you. I also give you verbal instructions on how I uninstall CIS Cleaning My Computer Tutorial - YouTube

The video was informative, but it didn’t provide a solution to the shutdown problem.

what you should follow is how i uninstall cis

I’ve been having the same problem of losing the UI, and the shutdown freeze due to the firewall not responding too.

I’ve uninstalled, cleaned the registry and reinstalled ‘comodo firewall only’ with no improvement.

I use AVG free on an XP home sp3 system.

This is making me paranoid, i never know whether it’s working or not!

OK…I used Revo to uninstall Comodo…I’m afraid I couldn’t use all of the suggested programs to clean out any other remnants of Comodo. Revo seemed to have done an excellant job in the past without any additional ‘cleaning’. I did reinstall Comodo and now I can’t open it by right-clicking nor will it shut down… >:( This is turning into a major pain. What to do? Things worked well before I updated Comodo and AVG.

Yes, that doesn’t address the problem at all.

If you’re suggesting that this problem is due to the way CIS uninstalls, then Comodo needs to address that… (I know there have been complaints about the thoroughness of the uninstaller for years) However, I do not believe this to be the case. At least in my situation.

That is basically the way I install/uninstall CIS with each release, other than the fact that I only use a single registry cleaner. (Auslogics) I’ve used Revo and Ccleaner for years. I also use Auslogics Defrag once a week. I use TheUltimateTroubleshooter for keeping my services and startups under control. It’s a nice way to get info on what the services actually do, and they are pretty good at recommending which are unnecessary, or even worse, are known to cause issues. (Third party application memory resident modules that cause issues, not Micro$oft services)

At any rate, I ran version 5 flawlessly for a few weeks after installation. Then recently (a week?) it started not wanting to shut down. Due to this, (and in lieu of what has happened in the past with Comodo) I suspect an AV database issue. I have no other explanation for flawless operation turning into recent shutdown issues.

I’d be interested to hear from the others reporting the problem in this thread whether or not this problem is just a recent occurrence, or if it has plagued them from installation.

I think the new AVG 2011 is the culprit. I got rid of it and all is working fine. I did try to install Comodo AV, but I couldn’t do it because I had to uninstall CIS first…rather than go through all of that , I just installed MSE… Happy days are here again!!! :smiley:

Well it isn’t AVG 2011 that is the problem as I hadn’t upgraded to that yet.

And it is still a problem with Avast which I have switched to, for other reasons, since first posting.

And it is so much of a pain that I have gone back to the Windows firewall and almost certainly will not be bothering with Comodo again.


It looks like it’s multiple things, because remedy that works for one situation fails to resolve other situations.

In my case, removal of AVG 2011 did eliminate the malfunctioning behavior. And, I did run the Comodo CIS installer “Add/Reinstall” feature later, using it to add Comodo AV, and I still have not observed the previous malfunctions.

However, Comodo AV is quite the nag. I have registered dozens of false-positives so far. I’m not sure how long I can bear it.

Hopefully Comodo will patch the problem with other AVs (and it sounds like AVG is not the only software that Comodo FWP cannot peacefully co-exist with).