Comodo usually throws error on startup

Hi, Comodo firewall almost invariably throws an error and won’t run at startup. It offers to try and fix the problem, but telling it to do so is useless.

I have a theory about this. For some reasons my Windows 7 computer won’t connect to the Internet for about the first five minutes after it starts. So my theory is that Comodo needs an internet connection to start and is failing because of that. Is this the case? If so, is there any way to tell Comodo to not try and connect?

Or could there be some other reason?

Since when does this happen? Did you recently update and if so how? I assume you are using v6.2?

What error is the firewall reporting? Can you let Diagnostics make a report and attach it here to your next post?

Please make sure there are no leftovers of security programs you had installed in the past. A possible left over can cause all sort of “strange effects”. Please run clean up tools for all security programs you had in the past. A list can be found here at the Eset website: ESET Knowledgebase .

I believe i’ve got the same problem. I have only installed the firewall from COMODO. (I also use avast antivirus.) Since the latest firewall update, a few days ago, whenever i try to start it the following error occurs:

COMODO Security Agent could not be started. Would you like to run the diagnostics tool to fix this error?
If i click yes, Diagnostics doesn't find any errors. I attached the report it created.

I never had any different security program installed, apart from the one i already mentioned.

[attachment deleted by admin]

Did you exclude the CFP folders in Avast exclusions?

Since the update seems the trigger could you see if uninstalling Avast makes a difference? We may be looking at a compatibility issue.

Yeah, i did.

Also tried deactivating avast and still couldn’t start the firewall. I have reinstalled it and now everything seems to work perfectly fine. There must have been an error during the update. Thanks anyway.

The error hasn’t happened for a while. Recently in an attempt to deal with my internet issue I reset all my services to their defaults and I thought perhaps that had fixed the problem. But it occurred today and I’m attaching the report. I forgot to note down the error, but it wasn’t very specific; it just said Comodo couldn’t start and asked if I wanted to try and fix the problem. I say go ahead, it tells me it could find no errors and then asks if I want to create a report.

This issue first happened within a week or two of my first installing comodo, which was a few months ago. I don’t know how to find the version number, but when I click “update” it tells me I am up-to-date.

[attachment deleted by admin]

You did not state if you ran the clean up tools for previously installed security programs. Did you try this? If not please do.

About running Avast. Do you have the behaviour shield of Avast active? Running two behaviour shields at the same time is not recommended. In that case choose if you want to use the behaviour shield of Avast or CIS.

Next time this happens can you see what process or module is being reported not to start? That may help narrowing down the problem.

When your internet connection is not opening for 5 minutes does that always coincide with CIS crashing?

To widen the net some. Could you check the Windows logs of around the time connection problem happened and see if there are issues reported? The logs can be found in Control Panel → Administrative Tools → Event Viewer → Windows Logs → System.

After the last update the error happened again, but i figured out what the real problem was. It had nothing to do with avast.
I am using Windows 8 and simply did not restart my computer properly since installing the update. I’ve postponed it as the message telling me to restart popped up, and then forgot about it and shut down the PC normally. After the next boot the same error message as last time appeared. After doing a reboot (a real one), everything works again.

Not sure if that is related to cherold’s problem, though.

The actual error says Comodo’s security engine can’t start, if that’s any help. I never had Avast; that was the guy who piggybacked on this thread. I did use the clean up tool link to turn of Microsoft Security Essentials, but that had no effect.

I can’t say for certain if the Internet connection issue always results in the Comodo issue. However, I would say that I always get an Internet error for another program (weather watcher) but don’t have the Comodo issue every time I start up, meaning it’s possible that it’s not an Internet issue. However, I use a program to reorder my startup items specifically to see if it would help this issue, so it’s possible, because I have Comodo set for last, that it simply is sometimes launching before my internet kicks in and sometimes isn’t.

In terms of the system logs, I do see a few errors during the startup. Here they are in the order they were reported:
Driver ACPI returned invalid ID for a child device (3).

A timeout was reached (30000 milliseconds) while waiting for the Apple Mobile Device service to connect.

The Apple Mobile Device service failed to start due to the following error:
The service did not respond to the start or control request in a timely fashion.

A timeout was reached (30000 milliseconds) while waiting for the MediaMall Server service to connect.

The nvUpdatusService service was unable to log on as .\UpdatusUser with the currently configured password due to the following error:
Logon failure: the specified account password has expired.
To ensure that the service is configured properly, use the Services snap-in in Microsoft Management Console (MMC).

The NVIDIA Update Service Daemon service failed to start due to the following error:
The service did not start due to a logon failure.

A timeout (30000 milliseconds) was reached while waiting for a transaction response from the eventlog service.

Hello. I am having the same issue. I’ve only installed the Firewall last night. Everything seemed fine; computer restarted normally. But then when I tried to open my browser or anything else on my desktop, my computer locked up.

I shut it down and when it came back up, my computer said that it did not restart properly and that it was recommended to do a startup repair. So I let it. When it finished, COMODO Firewall started to give the error message; it would say it could not automatically fix the errors and told me to create a report. I tried to just uninstall it for the time being until I could figure out what I need to clean, but it does not show up in Windows installed programs anymore.

If it helps, I had Norton Internet Security before my subscription expired, and I decided to go with a free firewall. I uninstalled it normally but chose to keep settings in case I would like to reinstall it later (also chose to keep the Norton Identity Safe Toolbar). Not sure if this is causing a conflict with COMODO Firewall, but I didn’t think so. After I uninstalled Norton Internet Security, I installed Microsoft Security Essentials, then Malwarebytes AntiMalware and then tried to install COMODO Firewall. But that’s when my computer locked up.

I’ve tried to figure if I still had some old antivirus conflicting with COMODO. I uninstalled Spybot Search & Destroy (even though their support told me it should not conflict), and I checked my event logs and noticed an error with McAfee “Framework Service failed to start,” because it could not find the specified file even though I thought I uninstalled that a LONG time ago. I ran the cleanup tool you linked, had to restart again, and when I came back, my computer was doing another startup repair. I’m thinking I should have just let it start up normally the first time…

And in my event log, when I restarted the computer from the second startup repair, for COMODO, it said “The COMODO Virtual Service Manager service failed to start due to the following error:
The system cannot find the file specified” and in details, "+ Sytem

  • EventData
    param1 COMODO Virtual Service Manager
    param2 %%2"

Not entirely sure what it’s trying to tell me…

Is there a way I could uninstall COMODO Firewall for the time being? It does not show up in my Windows Installed Programs anymore. Or if there’s anything else I could do? BTW, I’m using Windows Vista 64bit. Thanks in advance for your time.

itit seems that i have the same problem here it dont start after boot!! after checking with its tool it does not find any errors


here is the attacment with the report that it created !

[attachment deleted by admin]

What is the exact problem you are facing? Notice that in this topic several different problems are posted.

Did make sure there are no leftovers of security programs you had installed in the past? A possible left over can cause all sort of “strange effects”. Please run clean up tools for all security programs you had in the past. A list can be found here at the Eset website: ESET Knowledgebase .

Do you have other security programs installed? If so which one(s) are running in the background and which one(s) are used on demand?

The problem is that after windows are booting it comes up a message that it tells that comodo hasent started correctly and if to try to scan and fix any errors it does not find any errors and i genereted a report and attached above post! However if i start the icon of the comodo myself then it starts and everything seems fine only it seems that refuses to start at boot

No i havent any other antivirys only comodo and malwarebytes antimalware only those !! I searched at registry if after updating the comodo to last version is double registered at msconfig seems normal !!

i will try to remove and re install comodo !! and report here again !

after removing and reinstalation it seems to work properly !!

it must something has been wrong when comodo was updating from previous version !!

It seems that the problem begins after the comodo gets its virus signatures then it wont start !! i dont know why though :confused:

I assume you are using MBAM and SAS on demand only. Is that correct?

I am a bit confused. In your initial report the error happens during boot. After reinstalling CIS it happens after it updates the av signatures. Or do you mean it started happening on each boot after you did the initial av signature update? Can you shine a light here?

Yes mbam and only on demand !! yes it started happening during boot!
what i did was !!
After reinstalling the CIS and i dont let it update its database and do reboots its starts correctly and no error message appeared! After that i executed the update of its singatures and a fast scan and then voila the problem is there again!!

Also i have checked if the services of CIS are started after boot they are running !!

I have the same problem, on boot the firewall usually display an error. (I didn’t read the whole post)

Is the problem still happening with the latest version (2972)?

Vadorequest. What Windows version are you on?

Comodo firewall: 6.3.297838.2953
Windows Seven x64
So I think the last release doesn’t impact me.