COMODO Time Machine can not initialize operating system information

When installing COMODO Time Machine, I’m presented the following error:

“COMODO Time Machine can not initialize operating system information”

The setup stops and I’m not able to install CTM.

I’m using Windows 7 Profesisonal (x64)

if annyone is having an idea how to install CTM i would appriciate it.

My advice is that you first should read some of the threads here on this forum and after that decide again if you want to install CTM or not. I sure will not as long as…

hi, nbruggeman

Thank you for using CTM. Would you please provide your HardDisk info to us? You can go to “My Computer”->“Manage”->“Disk Mnagement” and do a screenshot for the disk information.

Best Regards,

I got the same error with version 2.6. I had to install version 2.5 that gives no such error.

Disk Info:

Partition 1: Pri, Active NTFS 30GB
Partition 2: Extended with three logical partitions 1.6GB, 12 GB, 100 GB all NTFS or FAT32 same result
Partition 3: Pri, 40 GB NTFS or FAT32 same result

Greetings! Just tried CT v2.6 on XPsp3Pro and received same error as OP… “Comodo Time Machine cannot initialize operating system information.”

Disk 0: C:\ Boot partition = 55gB (NTFS)
= 77.86gN
D:\ = 100.02 gB (NTFS)

System is not multiBoot and has a clean MBR.

Any help, greatly appreciated… I’d really like to try this product :slight_smile:

Followed aigle’s lead and attempted install of CTM v2.5. No operating system error any more but following CONSOLE offering, BSOD immediately followed by a hard ReBOOT, repeating endlessly. I entered the CONSOLE and used the UnINSTALL function to eliminate the app.

Would still love a working v2.6 to try again… maybe. ;D

I have this Problem too. OS WIN XP SP3 1HDD 1 Partition NTFS 32 Free Space 25 GB. Please Help.

me 2 ,the same problem.
pri 80G
pri 80G
logical 1XX G
logical 1XX G
WD500G sata notebook ,win7 32bit chinese ultimate ,no problem with partition table .

I receive the same error message when installing Comodo Time Machine v2.6.7190.166 (19.7 MB) on a newly reformatted/activated Windows Vista Ultimate Edition SP2 32-Bit desktop (Optiplex GX620).

Processor: Intel(R) Pentium (R) D CPU 2.80GHz
Memory: 3.00 GB
Disk Drive: WDC WD800JD-75MSA3 ATA Device
IDE ATA/ATAPI Controller: Intel(R) 82801 GB/GR/GH (ICH7 Family) Serial ATA Storage Controller - 27C0

From Disk Management:

Volume: (C:)
Layout: Simple
Type: Basic
File System: NTFS
Status: Healthy (System, Boot, Page File, Active, Crash Dump, Primary Partition)
Capacity: 74.50 GB
Free Space: 43.31 GB
% Free: 58%
Fault Tolerance: No
Overhead: 0%

NOTE: I installed the same CTM version on three Dell Latitudes (D620, D630, and D820) without problems.

Maybe it’s an issue with my Western Digital SATA I HDD or controller? When I try to run the CTM installer, I am asked to select my language (English). Then a green bar shows and progresses to install. After that, I receive a “please wait while the setup wizard prepares to guide you through the installation” message, followed by a noisy sound (HDD?) – after that, I receive “COMODO Time Machine can not initialize operating system information.”

I have already Disk Defragmented my HDD, and ran a scandisk prior to Windows Vista loading up. I only have one single boot volume and only one MBR.

If this is a known issue, please post more information on this. If you already have, then I am sorry and I apologize–my Google-fu is weak.

Hi Exchange Keys,
If CTM prompt “COMODO Time Machine can not initialize operating system information”, it will not be installed in your computer.

help plzz…

I got the same error with version 2.6

after reinstall win 7, I cannot install comodo time machine!

help plzz…

Hi and welcome.

Maybe you could try the new version here:;msg418550#msg418550

I’ve got the same error now with the newest build, 2.8
On an XP SP3 x32 box.

Please, give us some ideas, what conditions may generate this error?

I have spent hours, trying everything I could think of to remedy this.


olá amigos, eu achei o problema, o problema está na partição, bastou eu apagar 2 pedaços que estavam sem partição e corrigir a MBR usando um programa para este fim que um amigo nosso aqui do forum falou e ficou tudo resolvido.
o comodo time machine tem que estar com a partição perfeita (MBR) e nao pode ter espaços não particionados.

I want to step up and say that I have encountered this error to, on windows XP SP3.

I have to clone Dell D610’s using ghost and so far I have installed this on plenty of machine, and now I have encountered this error twice.

I wish we knew what it was looking at when this is being stalled that throws this error. Could we get a dev to comment on this maybe?

The installation fails with error “comodo time machine can not initialize operating system information” has been fixed, please download the new CTM version(2.9) and try again. You can get it from here:

Downloading now, going to test it out. Wish this wasnt on a beta version, but hey what can ya do!?

Thanks Flykite.

I am trying “client_setup_2.8.155286.178.exe” on Windows XP SP2 and I’m receiving the same message.
If I install the “client_setup_2.9.161985.187.exe” I obtain a BSOD.

[attachment deleted by admin]

Try update your Windows XP to SP3 and install 2.8 or 2.9beta again ! Also make sure your system has been updated with all relevant Windows patches !

Hi everyone,

I followed Mission’s advice and went on to check my disk partitions on windows 7. Turns out that windows 7 creates a 100 MB partion with 1 MB free unparttioned space before the partion.
I also had a bit of unpartitioned space on the end of the disk.

I downloaded EASEUS Partition Master 8.0.1 Home Edition

Extended all partions to take on dhe disk’s full space.


And installed Comodo Time Machine flawlessly.

Thank’s again Mission

Armando Mártires
Webdesigner -
Illustrator -