COMODO Time Machine 2.8.155286.178 released

Hi Everyone,
We are pleased to nannounce that CTM 2.8 has been released.

This is a maintanence release that should address a couple of bugs in
the previous versions.

What’s new in CTM 2.8?
FIXED! System occasionally fails to start up if operating system is installed on 2nd hard disk.
FIXED! Solved all problems of Windows Hibernation.
FIXED! Failed to install CTM when system partition is NTFS format.
FIXED! Failed to Reset Baseline when write much data in some special
FIXED! “Delayed write failed.” prompted when free space is very low.
FIXED! Failed to startup after update.
FIXED! Disable Windows defrag feature. CTM is incompatible with Windows 7’s Defrag.
FIXED! More than 30 GUI bugs.
IMPROVED! Added automatic checking for updates feature.
IMPROVED! Compatibility of installation.
IMPROVED! Pass driver verifier verification.

Known problem:
In mutli-OS environment, which means the computer is installed with
multiple OS and each OS has its own partitions. The computer will not
start if the CTM driver is moved and only part of all partitions is
The only way to avoid such issue is to protect all the partitions across
multiple OS.

Upgrade is not supported in this release:

  1. Users can not upgrade CTM from previous releases to this release.
  2. Users can not upgrade CTM from this releases to future release.

File Informations
File Name: client_setup_2.8.155286.178.exe
File Size: 19,552,056
File Version: 2.8.155286.178
MD5: C0BB7298E1A92C209A90B62479A9C9AF
SHA1: E9D1DD158AFC2BC576FF8EDE5187C7A5A21948D0

Download link:


Woo-hoow, new toy. :smiley:
TBH I’m a little bit scared by this

but I’ll bite the bullet when I’ll be home.

Wish me luck. ;D

Thanks Comodo team for another CTM release. :-TU

L.E. Well I’m home and after 15 agonizing minutes during uninstalling older version everything looks perfect fine with new version so again thanks Comodo team for another CTM release. :-TU

Now I can’t defrag system partition with my defrag software like I did before with 2.6 version.
I like to defrag system partition and reset CTM baseline without uninstalling CTM, now I assume need uninstall CTM, defrag, install CTM again.
I have no problem with 2.6 version, sa switch back to 2.6

No CTM version “allow” you to defrag. You were just increasing the snapshots size of the redirected files defragmented. The “real” file was kept there and the “new” one (defragmented) is on the snapshot (as it was changed). You need to understand that defragmentation is a no no with CTM.

Presently running the 166 version. I’m dual booting XP and Win 7 both 32bit. What is the proper uninstall procedure? I want to install the new version, Do I uninstall from Win 7 first and then XP or do I uninstall from the boot console? Be as precise as possible please

To be honest, I haven’t had any problems with the version of CTM that I am running right now. Should I still update it?

There are some serious bugs in 166 uninstallation, it is recommeded that you backup your data and uninstall your system to baseline.

You can uninstall CTM from either any OS or sub console.


Defragment CTM protected partitions with windows defrag is meaningless, because we manage disk space by ourself. We disable windows defrag in 2.8 release.


Wow, CTM has been on here way to long to go back to baseline unless I update it to today which doesn’t seem to be a problem for me. I’m almost willing to throw the dice on this and take a snapshot and uninstall to it.

You can backup your data and move on.


Installed 2.8.155286.178. Seems to be working.
It’s a pity that I’ve translated it but the translation wasn’t incorporated in this version… 88)

Thanks your good job. I will uninstall CTM 2.6 and install 2.8. Look at what’s new and if any bugs.

I suggest two intermediate steps.

  1. run chkdsk /F
  2. run a defragmentation tool
    Puran Defrag could do both at boot time automatically. Worth a try.

When your computer is ready, install the latest 178.

Reset the baseline, Uninstalled from Win 7 partition and it worked. Side note on the uninstalling with dual boot, you also have to uninstall from the other partition/OS or it doesn’t remove the installation from Program Files of that partition/OS. Getting late here, I will install new version tomorrow. I’ve already ran chkdsk/defrag/imaged. I’m tempted to go back with Eaz-Fix Pro but the version of CTM I just uninstalled was pretty sweet on my setup.

I’m talking about defrag with 3rd party software and only defrag before reset baseline. New baseline after that occupied 0 bytes - no extra space. Rolback RX have defrag switch to make defrag process less complicated - no need to uninstall - defrag - install.
I can do that with 2.6 but not with 2.8 CTM version.

At corttex,

You have gained nothing, although it may have felt better.
A baseline is always 0 size reported.
The concurrent Snapshots size reported show the size in difference from that starting point.

That starting point or Baseline size on disk is always equal to what windows saw on the disk,
at that point in time.

I hope that makes sense.

I am pleased to be able to report that the problems I was having with the beta are now resolved with this release.


Thanks Comodo team for another CTM release :-TU

Good to know. Why do they remove this feature then?

2.8.155286.178 continues to have a bug in the scheduling options.
Workday is checked, the hours are grayed out, the scheduled tasks does not run.

Tech I saw your screenshot and you don’t have a number of hours set, so I don’t think you have anything to run with that box empty.