COMODO Time Machine 2.7.150952.175 BETA Bug Reports

Please post all bug reports & BSOD’s here and make sure to include:

  1. Your Operating System (32 or 64 bit) and Service Pack revision
  2. Other Security and Utility Software Installed
  3. Step by step description to reproduce the issue
  4. How you tried to resolve the problem
  5. Upload Memory Dumps on crash if you encounter any
  6. Attach screenshots to your posts to clarify the issue further
  7. Any other information you think that might be useful

It’s vital to provide all this information, so the developers can quickly identify and fix bugs faster.


  1. Vista HP SP 1 32bit
  2. None
  3. Went to uninstall the product, selected baseline to restore to. The uninstaller did it’s thing and asked to reboot so I did, But then it didn’t remove the program. It booted back in to windows fine but CTM was still there (Boot up console too). I then got another Windows installer prompt from UAC saying it wanted to allow/block, but nothing after that. This was stright after booting in, I didn’t click anything. So I rebooted the vm myself and this time it did actually remove the product. Everything was gone.
  4. N/A
  5. N/A
  6. N/A
  7. N/A

It didn’t ■■■■■ up Windows at any point which is cool but, is it ment to do a 2 stage un-install ???

Hi antbates1991.
This is correct uninstall progress. After you uninstall CTM from Windows, and uninstaller ask you to reboot. And then sub-console of CTM will uninstall itself. Because you uninstall to baseline, It means all files will be restored to baseline before sub-console uninstall, after Windows startup. CTM will clean itself. And then, all files were cleaned.


Ah ok, thats my only issue I’ve noticed then

Thanks for your support.


I got win32k.sys blue screens after installing. Seemed like they occurred after letting computer sit for a while and coming back to it. Also if you run RootRepeal it will tell you that you have a MBR infection. Am sure this is because this program uses the MBR to function. Maybe a add on to create a MBR restore from USB stick since not many still come with a floppy drive?

I have One Care and Avast AV on this computer. Win - XP.

Controler, it is not recommened to run 2 AV’s at the same time on one system. Are you sure that this is not causing your “win32k.sys blue screens after installing” problems?

I would try disabling (or better still…uninstalling) one of your AV’s. As i said, running 2 AV’s can give unpredictable problems with your system in general. Search anywhere on the internet and the same advice will be given. :slight_smile:

Hi Controler.
Carfal is right. You can try to uninstall a AV and retry plesae. If the problem reproduce again, please post here or contact with me directly.


After using the new beta for a while (Win XP, SP3, using OA firewall, Avira paid AV and Sandboxie, if that makes any difference) and then trying to restore a snaphot, I found that I could not successfully reboot into Windows - rebooting just caused the computer to hang. (I never got past the screen with the Win XP logo.)

I tried restoring to other snapshots, but this too didn’t work. In the end I was only able to solve the problem by using my Macrium Restore disk and utilizing its option to fix boot problems.

After you fix this problem with Macrium Restore disk, can you continue to use CTM or it restore your system to baseline?

After I fixed the problem, I just decided to uninstall CTM - I can’t afford to have any more problems of this sort now…

Did you uninstall CTM from sub console or using third part tools?
Did you have flash drive or removable disk attached?


I uninstalled using Ccleaner (after finally rebooting successfully into Windows, of course), which runs the CTM uninstaller.

I had no flash drive or removable disk attached.

It happened to me on 166 version, with the difference that I got a BSOD each time.
I don’t know how to get out of this loop situation… i.e., when we can’t restore any snapshot…


Yes I do know about having two AV’s installed at the same time. I am one of the first 1000 Wilders Security Forum members. One of the first to say YES rootkits would be a legit threat while all the mods claimed scare mongering, including but not limited to DSL Reports.
I have had them in place for months without an blue screen. I do have my Smart Defrag set for auto at the moment. I did see another post on Win32K.Sys by another and he mentioned defraging.
I suppose I could look at windebug and the mini dump. I will reinstall time machine again and see what happens.

Hi controler:
I noticed that you have defragged your disk by “Smart Defrag”, for this reason, internal data of CTM might be corrupted.
In fact, we don’t recommend defrag disks after installed CTM, this is no use.

I am not seeing this problem any longer with win2k.sys. Why would one not defrag after installing this software? Does it do a defrag also?

I have a problem I noticed today. If I insert a USB stick my system locks up. I can still use task manager by Con?alt/Del but can’t get to control panel or access any of my tray items.
If I try booting up my computer with a USB stick in, the computer won’t boot at all. It does this every time.
If I uninstall Time Machine, things are back to normal.
Anyone else see this?

No. Data shouldn’t be corrupted in anyway. You’ll duplicate and increase the snapshots size hugely, but corruption shouldn’t occur.

Indeed, no use. You will redirect the disk writes to another part of the disk (free space where the snapshots are). Use the internal CTM defragmentation tool.

Then the idea is to install everything you want then defrag then install Time Machine?
I don’t get it. The way I see it is you are continuously fragmenting your drive even with Time machine.
I realize if you go back to a snapshot you lose the defrag but what if you don’t go back and keep going until you have a major crash. Your hard drive will get get fragmented won’t it?

I still can’t use it Time Machine until I get the USB stick thing resolved.