COMODO System Cleaner 2.2.129172.4 Public Release BUG REPORTS

Please post all bug reports & BSOD’s here.

Be sure to include:

  • Your Operating System (and whether it’s 32bit/64bit);
  • Security Software Installed;
  • How you produced the problem;
  • How you tried to resolve the problem;
  • Screen-shots with the error (if any);
  • Post Memory Dumps on crash if you encounter any;
  • All log files of CSC, if you had logs enabled;
  • Any other Additional Information;

For some odd reason, after changing some system settings with CSC, LastGood.tmp Diretoy began to constantly be read from my harddrive. This would occur until about 90-99% of my memory was utilized, and then would stop, begin freeing the memory, and the system began to slowly operate normally.
I used the process explorer from sysinternals to help diagnose the issue with no actual processes other than services.exe utilizing the memory.
I used filemonitor from sysinterals to view that LastGood.tmp Directory was being read repeatedly.
After uninstalling CSC the issue was resolved.

-OS: Windows XP Pro (Ver: OEM (Original RTM) and Ver: SP3)
-Security Software: None (Fresh install and CIS w/SP3)
-Steps: Installed CSC, Let it update, Edited System Settings: Hide Shortcut Arrow, Remove ShortCutTo Prefix, Disabled StartMenu profiles (Fast StartMenu Showing), Delete PageFile at shutdown.
Enabled Indexing of unknown file types. (Manually set in windows)
Disabled Fast User Switching (manually set in windows)
Update DirectX from 8 to 9.0c (latest w/dxwebsetup.exe)

  • Steps to Resolve:
    Uninstalled Perfect Disk (Reboot)
    Uninstalled Video card Drivers (Reboot)
    Uninstalled CSC (Reboot - fixed)
    Reinstalled Video Drivers (Reboot - fine)
    Reinstalled Perfect Disk (Reboot - fine)
    Reinstall CSC (Checked System Settings - Reboot - Issue)
    Uninstalled CSC (Reboot - fixed)

Comodo System Cleaner 2.2.129172.4 creates the following folders

C:\Documents and Settings\UserName\Application DataComodoGroup\CSC\Cache

instead of

C:\Documents and Settings\UserName\Application Data\ComodoGroup\CSC\Cache

It is not a huge bug obviously but this has been the case for quite a few Versions now and I would have thought that someone would have picked up on it.

System runs

  • WinXP Sp3 32bit;
  • Mcafee Viruscan Enterprise, Comodo Internet Security;
  • I tried to delete these folders but it was re-created thenext time CSC was run;

On my system, it created both and I just deleted the first one. (Application DataComodoGroup)

vista x64 sp2
CIS v4 beta
This GUI glitch on the wiper pie chart is still present. Note the white lines covering the chart.

[attachment deleted by admin]

Yes, It creates both on mine also but after deleting the erroneous one and then running System Cleaner the deleted folder gets re-created again.

Nice job, but a few errors that have been around for quite some time now:
System Info - software - Total Physical ram shows 0KB, actual (my system) is 8GB DDR3
- Hardware - Processor current clock frequency is incorrect. Actual is external clock frequency x multiplier = 3534.58MHz, multiplier is 22 in my case).


Please check those sections in System Information utility of Windows as well; and let us know if the display errors are there too. Thank you.

Clock frequency is incorrectly displayed there as well, but memory is showing up correctly.


Can you please post us a print screen on this matter, for System Information utility in Windows? Thank you.

Today the Physical memory is displayed correctly.
Attached is the pic showing the clock frequency in CSC and a pic (from CPU-Z) showing actual data.
Please note Speedstep is disabled in BIOS so the speed is consistent always.

[attachment deleted by admin]

This is not a bug. But I feel that under CSC-Miscellaneous-Diagnostics the wordings could be

Did Comodo System Cleaner report an error instead of CRC or CDC.

 I have had my system crash after approximately 2 minutes in normal mode and even in safe mode with certain intensive use the system would crash. The distinctive way it crashed in Safe Mode was that elements of the video display would disappear and the system would sit there and not respond to a normal shutdown. In normal mode the display would just go to black with a mouse pointer on the screen. I thought it was hardware related and checked all elements of my hardware. I even uninstalled Mcafee VirusScan and MalwareBytes Anti-Malware. I was about to do a Non-destructive Rebuild when while looking at AutoRuns I happened upon the cfrmd.sys that showed up as missing. When I looked up references of this on the internet i happened on this forum and the people who had system re-boots after installing this latest version. I uninstalled this version and my system has been stable as before. I never thought that this utility could have created the symptoms that I was having. 
 I must say that I had resisted updating from a previous version since the problem with existing files in the install directory causing problems. I did move these and then installed to the latest version and now this. Then there is the on-going folders that keep being incorrectly created under Local Settings. All this points to the team behind System Cleaner being a bit slap dash with the development and bug checking of this utility. I will no longer trust it again in future incarnations.
My system OS :WinXP Sp3 32Bit

Virus: Mcafee Viruscan Enterprise 8.7.0i
Firewall: Comodo Firewall
Process Lasso Pro 3.80.4
Malwarebytes Anti-Malware Ver1.44
And loads of other software too many to

By the way investigation of memory dumps never could identify the cause of the problem but did suggest “DRIVER FAULT”

Operating System: Windows Vista Home Premium 32-bit, SP2 and all the latest updates
Security Software: CIS 3.14.130099.587
How problem produced: First install and first run of CSC
The problem: Incorrect/invalid folder created by CSC?

CSC creates an invalid(?) folder called C:\Users[i]username[/i]\AppData\RoamingComodoGroup (which is empty except for two (also empty) sub-folders) in addtion to the valid folder C:\Users[i]username[/i]\AppData\Roaming\ComodoGroup which is properly populated.

Tony Cross

After updating to this version Service Control Manager is logging an error in the system events with event ID 7026 telling that CFRMD boot or system driver didn’t start up.

I’ve tried the followings to solve:

  1. Searching the CFRMD I found it is related to the CSC and located in its “drivers” folder. Recognizing that cnat.exe is placed next to the cfrmd.sys and that cnat.exe is started at system start-up from C:\system32\cnat.exe I saw the cnat.exe in the windows\system32 was older (2009-10-19) and I’ve overwritten with the one found in the CSC\drivers\fre_wxp_x86 folder. Result: nothing changed, still NOT OK

  2. Run the built-in diagnostic of CSC. Result: cscenu.dll was altered. Pushing the Repair button SW reinstalled, PC restarted, but both the altered cscenu.dll and the event 7026 with CFRMD remained.

  3. I’ve removed CSC with Revo uninstaller and reinstalled, both the cscenu.dll altered and event 7026 remained.

  • OS: XP SP3 32bit
  • Security SW: CIS (AV+Firewall)
  • CTM

I love the update on Comodo System Cleaner! However, there are scrollbars missing on some screens. I am using Vista Business

I have tried to install the CSC after i downloaded it but it only goes to the windows installer screen, stays there for a few minutes then goes away without completing the installation.

I am using windows xp professional ( 32 bit ) with service pack 3. I downloaded CSC setup 2.2.129172.4


There might be an issue with your Windows Installer (on which CSC is based on). Go to Start>Run>Cmd>type msiexec /? and press Enter. At the top of the window you will see the current version of your Windows Installer. If needed, please consider updating to the latest version: Windows Installer 4.5 is available - Microsoft Support

Thank you.

I have done what you said i should do and upgraded to windows installer 4.5 still nothing happens.

Windows XP SP3 32 bit (Swedish) 3.2.0, latest stable build (Swedish)

CRC removes OpenDocument thumbnails. I tried to restore the backup, but it didn’t help. I had to repair OO.o. See attached images of Autoruns.

Today’s CRC log attached.

[attachment deleted by admin]