COMODO System Cleaner 2.1.114194.1 Public Release BUG REPORTS

Please post all bug reports & BSOD’s here.

Be sure to include:

  • Your Operating System (and whether it’s 32bit/64bit);
  • Security Software Installed;
  • How you produced the problem;
  • How you tried to resolve the problem;
  • Screen-shots with the error (if any);
  • Post Memory Dumps on crash if you encounter any;
  • All log files of CSC, if you had logs enabled;
  • Any other Additional Information;
  • Your Operating System (and whether it’s 32bit/64bit); WinXP Pro SP3 32 bit
  • Security Software Installed; CIS 3.12.111745.560 CAV, CFP, D+ Enabled
  • How you produced the problem; Opened CSC
  • How you tried to resolve the problem; n/a
  • Screen-shots with the error (if any); n/a
  • Post Memory Dumps on crash if you encounter any; n/a
  • All log files of CSC, if you had logs enabled; n/a
  • Any other Additional Information; See below:
  1. The automatic updater still wipes out my settings for CDC Filter Entries. After the update completes, I have to enter my filter entry settings again. I maintain that it’s imperative that all personal settings remain intact after all updates. It’s a real pain to have to go through all of my settings to double check them every time I want to use CSC.

  2. The “Check for Updates” button on the main window says that there is an update available and asks if I want to install the update. I answered “Yes” and the updater wanted to install the last version (2.0.111095.7). I canceled the update.

  3. The diagnostics says: “A vital file is missing from your installation of Comodo System Cleaner. Please reinstall Comodo System Cleaner to fix the problem”. I ran the installer again and chose “Repair”. I rebooted the system when prompted. After reboot, I ran diagnostic again with the same results (file missing). It gave no clue as to which file it found missing.

I have been running CSC for a while without problems but today it crashes everytime I try to run it - Message - This program has requested the runtime to terminate in an unusual way. please contact support.
I uninstalled it and downloaded a newer version - 2.0.107697.4
I was confused as your website indicates that the latest is - 2.1.114194.1

I am running Win Vista 32.

  • Your Operating System: Vista Ultimate 32bit
  • Security Software Installed: CIS, SpywareBlaster
  • How you produced the problem: tried to open and run CSC
  • How you tried to resolve the problem: uninstalled and reinstalled CSC several times, but problem persists
  • Screen-shots with the error (if any): 1st popup says “COMODO System Cleaner has stopped working. Windows is checking for a solution to the problem.” 2nd popup attached
  • Post Memory Dumps on crash if you encounter any: NA
  • All log files of CSC, if you had logs enabled: attached
  • Any other Additional Information: The program won’t start and run on my computer, but works perfectly on my wife’s computer. Both computers are configured exactly the same. The problem with CSC blocking a PerfectDisk 10 system defrag has been corrected with this version of CSC. The system defrag ran perfectly on my wife’s computer after installing the latest version of CSC.

Problem Solved!
After uninstalling CSC, I searched the registry and removed any Comodo System Cleaner references that remained. Then I removed any files that were in the CSC folder in Program Files. I had the previous version of CSC installed on my computer until I discovered the conflict with PerfectDisk 10 system defrag. I then uninstalled CSC, but it left a minimal number of entries in the registry and a few files in the Comodo CSC Program Files folder. It was one of these left-over registry entries or files in the CSC Program Files folder that was apparently causing this problem. After deleting all these remaining registry entries and remaining files in the CSC Program Files folder, I then reinstalled the latest version of CSC. It now opens and runs like it is supposed to, without stopping and getting the error message that I had been getting before.

[attachment deleted by admin]

2.1.114194.1 is the latest version. Be sure to uninstall any old version of csc before installing latest version. It should then take care of all issues that u been seeing.

Are you running it in administrator mode ? Also it is not being block by your firewall?


  Comodo System-Cleaner allways runs in administrator mode.
  The only issue with any firewall that we know of is with Trend Micro Internet Security.
   We will inverstigate this problem and come up with an answer.

I don’t know whether this can be called a bug. This is something I accidently noted and point out just for information.

The ‘UpdateApplications’ file under CSC (in program files) describes the company and file description as TODO instead of Comodo (though it is digitally signed by Comodo).

Point No.2 of Ursu’s post here mentions that the Misc, Close tabs will not be outside the window in the next version. But, for 800x600 resolutions (96 DPI), these are still outside and I have to drag it to close CSC each time to close it. (Was this for another context like 120 DPI?).


  1. For the version of CSC (2.1), there have been made some changes in the Updates component. This means that for the current version, the personal settings made by the user cannot be kept. This will no longer be a problem starting with the next release.

2 & 3. We are aware about this issues. They will be fixed for the next release. With all that, the problem in Diagnostics doesn’t affect the application’s behavior or functionality.

Thank you for your support.

Thanks for your reply. I was curious about the diagnostics. I haven’t ran this version of CSC yet because of that warning. It’s good to know that I can ignore it until the next release.

CSC just keeps getting better! :-TU Kudos guys!

  • Your Operating System (and whether it’s 32bit/64bit); Windows XP 32Bit & Windows 7 32Bit
  • Security Software Installed;CIS Firewall 3.12 , Avira Pro
  • How you produced the problem;install CSC and try to start it up
  • How you tried to resolve the problem; Disable Avira Guard

This new version does not like Avira / Avira does not like it. Get error screen after install with Avira guard enabled and submitted it.
Removed it and installed with Avira guard disabled and now works fine.


First of all, congrats to the new release, i didn’t made my system (XP x64) freeze after the first powerclean even with the extended scan enabled.
I’ve got a few question according to this release:
In the Registry Cleaner under the Scan Locations the “System Services” is unchecked by default. I assume that this caused the services.exe issue in the previous releases. Will the issue return if you check this option in this release? You promised me that it will be fixed in the next release, but I want to go for sure. (I’m using the portable edition if that matters.)
The other thing is that when I’m using the Disk Cleaner shouldn’t the following folders (see attached pictures) be deleted also? If these don’t belong to the Windows Update Temp Files nor the Windows Temp Directory could you make a third option for them?

[attachment deleted by admin]


Please post us a screenshot with the error. Thank you.


Please post the second issue in the WishList section. As for the “System Services” option in CRC, this is unchecked by default because it’s a sensitive section to clean in. It has nothing to do with the services.exe problem.

Thank you for your support.

I have a CSC problem on my vista PC

Windows Vista Home Premium SP2 64bit
Just by running CSC
No yet.

I do have DPI on 120 setting. the close buttons don’t work, And there is no Application name in the taskbar. and no buttons at the bottom

[attachment deleted by admin]

Windows XP media center SP3

Just by running CSC
No yet.

Newest CSC crashes when i try to run it.

If you need anything Please ask.

Comodo Internet Security
Mcafee Viruscan Enterprise 8.70i

This new Version crashes each time I start it.
I have reverted toi the older Version. No problems.

I uninstalled the old version. I rebooted when it told me to.
I installed the new version.

Error Log File Attached

[attachment deleted by admin]

I had CSC installed on 2 Vista Ultimate desktops. On one of them, CSC installed just fine and worked perfectly. On the other one, CSC would crash after opening and give an error message every time, so I uninstalled the latest CSC version. I found several registry entries that remained from the uninstall of the previous version of CSC last month. I also found 4 or 5 files left in the Comodo CSC folder in Program Files from last month’s uninstall of the previous version. After deleting all the leftover registry entries and files that were left in the CSC folder in Program Files, I reinstalled the latest version of CSC and it opens and runs perfectly without crashing and giving any error messages.

You might uninstall CSC and try searching the registry for any remaining Comodo System Cleaner entries and deleting any that you find. Then look for the CSC folder under Comodo in Program Files and if it is there, delete any files that remain in that folder. Then try reinstalling the latest version of CSC and see what happens.

The screenshot of the error when Avira is enabled.

[attachment deleted by admin]

When UpdateApplications.exe runs and updates the applications.ini file, I no longer have entries in the “Perform scan in” window in both CDC and CPC. Replacing applications.ini from a backup returns the entries to both windows. Running UpdateApplications.exe again repeats the problem.

[attachment deleted by admin]