COMODO System Cleaner 1.1.63928.28 BUG REPORTS [CLOSED]

Please post all bug reports & BSOD’s here.

Be sure to include:

  • Your Operating System (and whether it’s 32bit/64bit);
  • Security Software Installed;
  • How you produced the problem;
  • How you tried to resolve the problem;
  • Screen-shots with the error (if any);
  • Post Memory Dumps on crash if you encounter any;
  • All log files of CSC, if you had logs enabled;
  • Any other Additional Information;

Still the same bug

32Bit XP SP3 Nlited version
No security products installed
When opening CSI.exe from the CSC mainscreen it crashes

here’s the log that CSC created (again)

Just a thought, but could it have something to do with this ? AFAIK, most of the Comodo products are incompatible with theme changer packages like Bricopacks, and when opening it then, they crash…


EDIT : It’s CSI.exe, not CSR.exe

Win XP Pro SP3 nlited x86
Comodo Firewall 3.5.57173.439 Firewall and Defence+ in safe mode.
Installed System Cleaner over Comodo Registry Cleaner (forgot i had installed it)
Run System Information, get window Microsoft has encountered a problem, click on info (or whatever) and it points to csi.exe.
Reboot and system hangs at Windows XP screen with 3 blue blobs continually crossing box.
Reboot in safe mode, remove System Cleaner, all ok.

  • Your Operating System: Windows Vista Ultimate 32bit
  • Security Software Installed: CIS, BOClean, SpywareBlaster, Super Antispyware, Malwarebytes AntiMalware
  • How you produced the problem: ran Disk Cleaner using Safe Delete
  • How you tried to resolve the problem: did a System Restore that I had Disk Cleaner create before cleaning
  • Screen-shots with the error (if any): NA
  • Post Memory Dumps on crash if you encounter any: NA
  • All log files of CSC, if you had logs enabled: see attachment, which doesn’t show any problems that I can see
  • Any other Additional Information:

I uninstalled CSC version 1.1.63712.27 via the Control Panel and installed the new CSC version 1.1.63928.28. I set the Registry Cleaner to create a Restore Point and a Backup before cleaning, but not to use Registry Protection. I ran the Registry Cleaner and it worked perfectly. I have not had problems with any previous versions of CRC, so I expected it to work just fine. I set the Disk Cleaner to create a Restore Point before cleaning and to use Safe Delete. I wanted to see if I was going to have the same problem I had with Safe Delete in the previous version. I ran the Disk Cleaner and it created the Restore Point and then the progress bar completed the cleaning. It then told me that I needed to reboot the computer to complete the cleaning. The computer rebooted, but hung at the blank screen with the cursor showing. It never got to the logon screen. I shut down the computer by holding the Start button down for 5 seconds and then waited a minute before restarting the computer. It booted to the screen telling me that the computer had not shut down properly and gave me several options to boot into, such as Safe Mode and Start Your Computer Normally. I went ahead and started the computer normally.

When it finished booting up and I logged on, Safe Delete popped up and UAC asked for permission to run it. I gave permission and chose Restore Files, instead of Finalize, since the computer had frozen before completely booting up. Another reason I chose Restore Files was because now my Netgear SmartWizard interface would not open and I did not have an Internet connection. But instead of restoring the files, the computer immediately started to reboot itself, just like it did with the previous version of CSC after clicking the Finalize button. This time as the computer was rebooting, I went into Safe Mode and chose to restore the computer to the Restore Point that Disk Cleaner had made before starting to remove the temp files it found. The system restore was successful and I had my Netgear SmartWizard interface and my Internet connection again. The Safe Delete function in Disk Cleaner is still not safe to use when running Disk Cleaner on my computer.

Disk Cleaner still works great and doesn’t cause any problems if I don’t use Safe Delete. After successfully restoring my computer, I ran Disk Cleaner without using Safe Delete, deleted all the temp files that it found, and then rebooted to see if I was going to have any of the problems that I experienced when using Safe Delete. I had no problems whatsoever. The Netgear SmartWizard interface opened just fine and I had Internet connectivity. I don’t know what the problem is, but on my Vista Ultimate 32bit computer, the Safe Delete function in Disk Cleaner has had serious problems ever since it was incorporated into CSC.

[attachment deleted by admin]


Can you please tell me where did you find CSR.exe ? Please post a screen shot.

Thank you for your support


Have you tried to clean-up everything(related to CRC and CSC) before installing this new version?

Also, please tell me what nLited means. i know what nLite is, but I want to know how did you modified the original Windows with it.

CSC was only tested on genuine, unmodified Windows OSes.


From what I see one of the security software blocks our SAFE DELETE process. We’ll replicate today your configuration and see if we get the same results. one reason I say this is because you say UAC pops-up asking about CSC.exe… but CSC.exe is a signed application and should not happen this.

Thank you for feedback and logs.


What is CSR.exe?

I’m sorry for the misunderstanding, it was CSI.exe (Comodo System Information)


[attachment deleted by admin]

Hi Andrei,
I bet that is the problem, because I have been running CIS with Defense+ \ Advanced \ Predefined Security Policies \ Windows System Application \ Protection Settings \ Interprocess Memory Access set to ‘Yes’ without CSC.exe being added to the Exceptions list. I had to add some other program executables you see on this list to get the programs associated with these executables to run. As you can also see, the only Protection Settings that I still have set to the default ‘No’ is Windows/WinEvent Hooks, because I still can’t figure out what executables I need to add to the Exceptions list to get Windows Explorer, Windows Install Clean Up, and the Windows Registry Editor to run. Adding just the obvious executables for these programs doesn’t do the trick. If I could ever figure that out, I would have Win/WinEvent Hooks set to ‘Yes’ also.

One thing to note, in these Predefined Security Policies settings, Trusted Application is still set to the default ‘No’ for all 4 Protection Settings, because I didn’t see any reason to have trusted programs monitored by this CIS protection. I will play around with the Interprocess Memory Access settings and add CSC.exe to see if that takes care of the problem. I attached a screenshot of all the CSC executables that are available to add, except I couldn’t get ismscsc.exe in the picture. Can you tell me specifically which CSC executable is associated with the Safe Delete function? Then I can add just that one specific executable and try Disk Cleaner again, using the Safe Delete function, to see if that takes care of the issue.

I included CSC.exe in the Exceptions list for CIS \ Advanced \ … \ Interprocess Memory Access, and then ran Disk Cleaner with Safe Delete. After rebooting, UAC asked for permission for CSC to run, which I granted, and the CSC Finalize or Restore Files choices came up. I clicked on Finalize and the computer immediately rebooted once again to the screen that says that the computer did not shut down properly and offers choices for restart, such as Safe Mode and Start Your Computer Normally. I started the computer normally and the CSC Safe Delete choices came up once again after I granted permission for CSC to run. This time I added all the other executables that are in the CSC folder to the CIS Interprocess Memory Access Exceptions list, before clicking on the CSC Finalize button again. Once again the computer immediately rebooted, just like it had every time previously using Safe Delete.

This time I rebooted into Safe Mode and restored the system to the restore point created by CSC before cleaning temp files. The computer is back to normal operation and I have removed the check in the ‘Use Safe Delete to remove files’ box again in the Disk Cleaner Settings menu tab. I am just not having any luck at all trying to use CSC Disk Cleaner’s Safe Delete function. I only tried it again to see if adding CSC executables to the CIS Exceptions list would allow it to run properly. Since I have never had a problem after deleting temp files using CSC’s Disk Cleaner without Safe Delete, I am reverting back to this option permanently. I really have no need for the Safe Delete function on my computer because the deletion of temp files goes smoothly every time without it. Safe Delete just causes problems every time I try to run Disk Cleaner with that option checked. I really like CSC and I use both the Regsitry Cleaner and the Disk Cleaner regularly without any problems, but on my Vista Ultimate computer Safe Delete is not safe.

Edit: Problem Partly Solved
I had each of the four Isolated Application and the four Limited Application settings in CIS set to ‘Yes’ when I first started having this problem. I decided to try one more thing to try to solve it. I added CDC.exe as an exception to CIS Defense+ \ Advanced \ Predefined Security Policies \ Limited Application \ Protection Settings \ Interprocess Memory Access. I didn’t have any reason why I chose this Protection Type or this particular Predefined Security Policy first, but this is the one that I added CDC.exe to. Then I ran Disk Cleaner with Safe Delete activvated. CDC created a restore point before deleting temp files, then I rebooted the computer and after rebooting successfully, I was prompted by UAC whether or not to allow CDC to run. I chose the first time to restore files, which Safe Delete successfully did. Then I ran CDC with Safe Delete activated again. After rebooting the computer, this time I chose Finalize and most of the temp files were successfully deleted. Some were not found. Having this one particular CIS Defense+ Advanced setting set to ‘Yes’ is apparently what was preventing the CDC Safe Delete function from working properly. Adding CDC.exe to this CIS Advanced \ … \ Limited Application \ Protection Settings \ Interprocess Memory Access exception allows CDC Safe Delete to work properly. The second attachment below shows the correct CIS setting. We have 2 Vista Ultimate computers configured exactly alike. This solution worked on one of them, but did not work on the other one. I don’t know what the difference is and why this solution didn’t work on both Vista Ultimate computers.

[attachment deleted by admin]

The system information module crash when it’s launched

Program version: COMODO System Cleaner 1.1.63928.28
PC: Athlon 1.5Ghz, 512MB, Nvidia Geforce2 MX200
OS + Security Soft: WinXP SP2, Sygate 5.5 + Avast 4.8
Problem trigger: When I press the “Utilities/System Information”

Screen caps and error log

Thanks in advance for any help

Have not tried cleaning everything before installing.
Nlited - i removed such things as printers, languages, music samples, keyboards, tour, speech support.

  • Your Operating System - Windows XP Home SP3
  • Security Software Installed; - CIs
  • How you produced the problem; - Clicked System Information
  • How you tried to resolve the problem - don’t know what to do to try to solve the problem.
  • Screen-shots with the error (if any) - AppName csi.exe, Offset 00030036.
  • Any other Additional Information- Closing error message appears about 3/4 way through the scan.

Program consistently crashes when attempting to read System Information


Regarding your issue, can you please post a print screen when the error occurs? Thanks for your support.



Your post is appreciated. The compatibility problem between windows nLited version with theme changer and COMODO System Information will be fixed in the next update.

Thank you.

:-TU :-TU :-TU Thanks

Could you please tell this to the VPN development group ? They have the same problem



Just wanted you to know that you were all very helpful(those that reported this bug, but I am quoting you Xan as you were the first:) ). The bug is fixed now and we’ll update next week.

Im honered :a0

:comodorocks: :comodojiggy: (V) :comodo110:


Found more: CRC conflicts with ctfmon. After run CRC ctfmon fails to respond on layout change either via keyboard or by mouse click on icon near tray.


Please post the registry backup file that was created at that clean . It will be very helpful for us to find out witch key produces the problem . Thanks