COMODO System Cleaner 1.1.63712.27 BUG REPORTS [CLOSED]

Please post all bug reports & BSOD’s here.

Be sure to include:

  • Your Operating System (and whether it’s 32bit/64bit);
  • Security Software Installed;
  • How you produced the problem;
  • How you tried to resolve the problem;
  • Screen-shots with the error (if any);
  • Post Memory Dumps on crash if you encounter any;
  • Any other Additional Information;

32Bit XP SP3 Nlited version
No security products installed
When opening CSR.exe from the CSC mainscreen it crashes

Can’t get any dumpfiles now


[attachment deleted by admin]

Well, i dont think that this is a bug, but i think that is an interface glitch. A close button of a registry cleaner dialog does nothing. I think such behavior is odd)))

[attachment deleted by admin]

EDIT: I reinstalled CSC and now this bug no longer seems to be around. I restart CSC & CPC, and CPC actually remembers my option of unchecking Driver cache. :-TU

EDIT 2: I’ve found out how it works. Changing and option and not scanning, then exit CPC, will cause CPC not to remember my choice. However, changing option and scanning (+ Clean or Cancel), then exit CPC, works. CPC remembers my choice in this case. Only you can tell if it’s by design or a bug, either way, I’m happy it’s easy to resolve. :-TU

XP SP3 32 bit
Comodo Internet Security

Forgive me if this is a feature rather than a bug:

When using Comodo Privacy Cleaner, I prefer unchecking Windows | System | Driver cache because I believe these files are important (for example, needed when inserting unknown USB sticks, as far as I know Windows looks in However, CPC does not remember that I uncheck this option. I’d appreciate if CPC did, so I don’t clean Driver cache by mistake… (though if I’m actually wrong about the USB stick event, this doesn’t matter and we should be able to safely clean the Driver cache?)

See attachment. Thanks.

[attachment deleted by admin]

XP SP3 32 bit
Comodo Internet Security

Really minor GUI bug: When starting the main CSC interface, there’s a black line under Clean My Disk. It disappears as soon as I hold the mouse over.

Furthermore, there are some other minor GUI bugs as well. The second image shows that the Help button is still pressed after I’ve done other things. And as you can see, I’m in the Miscellaneous section, yet both Miscellaneous and Summary are highlighted.

See attachment. Thanks.

[attachment deleted by admin]

XP SP3 32 bit
Comodo Internet Security

CSI never shows any Hardware information. It’s just blank, as you can see in the screen shot. I wouldn’t blame CSI unconditionally though, as I’m on a “testing” installation of XP SP3 which I’ve heavily cleaned with RegSeeker (a pretty unsafe registry cleaner if you ask me!).

See attachment. Thanks.

[attachment deleted by admin]

XP SP3 32 bit
Comodo Internet Security

Forgive me if you think this is purely related to rather than Comodo Privacy Cleaner:

I used Comodo Privacy Cleaner 1.1.63712.27 to clean all four options for 3.0

This caused the OOo to stop functioning. I launched the main application, and I got to the setup screen (see attachment). First of all I wonder - which CPC option caused this? Was it “Registration informations”?

Anyway, followed the steps in the OOo window, but when attempting to finalize - after Registration - OOo stops responding and crashes.

I suppose reinstalling OOo will solve the issue. You may however want to look into this, if people check all four cleaing options for OOo they may run into the same problem as I did… however it’s no trouble for me, as I’m only on a testing installation of XP and accordingly all software are for testing as well. :slight_smile:

See attachment. Thanks.

[attachment deleted by admin]

I have this to.

Also under System Information on the CSC summary screen its doesn’t tell the full name of Windows Vista Home Editions. It just says Windows Vista Home. I would like it to tell me weather its Home Basic or Home Premium as it did in the Beta versions of CSC

*See attached Screenshot.

[attachment deleted by admin]

Operating system: Windows XP SP3 32-bit
Security software: Avira Antivir Personal Edition, Comodo Firewall 3.5.61373.458

Comodo Registry Cleaner finds some registry values as invalid although they are valid (see a screenshot bellow for more details).

[attachment deleted by admin]


Does “K:\1” file/directory exist on your computer?

No, it doesn’t. The \1 is added to every registry value which is made in RunMRU key when you type some command in Start menu/Run.

The entry you refer was made because I typed K: to open root folder on K hard drive/partition. If I would type K:\ in Start menu/Run the value made in registry would be K:\1 and will be also incorrectly detected.


Ok. Then this must be the problem. Thank you for reporting.

  • Your Operating System: Windows Vista Ultimate 32bit
  • Security Software Installed; CIS, BOClean, SpywareBlaster, Super Antispyware, Malwarebytes AntiMalware
  • How you produced the problem: ran the Disk Cleaner using Safe Delete.
  • How you tried to resolve the problem: didn’t run Disk Cleaner using Safe Delete again
  • Screen-shots with the error (if any): NA
  • Post Memory Dumps on crash if you encounter any:
  • Any other Additional Information;

After restarting the computer and clicking on the Finalize button, the computer immediately started to reboot again and booted to the screen asking whether to start Windows normally or several other choices, such as Safe Mode. Then when Disk Cleaner was started again, it informed of the need to reboot to finish the cleaning, which had already been done prior to clicking on the Finalize button and getting the unwanted reboot. I haven’t yet rebooted again to see if this brings up the Finalize button again.

After rebooting and starting Disk Cleaner again, it again gave me the message that the computer needed to be restarted to complete the cleaning.

[attachment deleted by admin]


Was there a previous version of CSC installed on your computer? Have you updated or manually installed the current version?

Yes, the last Beta version of CSC was installed. I uninstalled it from the Control Panel before installing this public release version. The Disk Cleaner acted this same way one time in the Beta version, but I didn’t think anything about it at the time and never posted a bug report. I just simply stopped using Safe Delete. I have been using CSC since it first came out in Beta and disk cleaning has always gone smoothly without any subsequent problems. But since Safe Delete was included, it hasn’t been that safe. I understand the concept of possibly deleting files that shouldn’t be deleted, but I never experienced that, without Safe Delete. Now it seems that the Disk Cleaner is stuck in some kind of a loop where it keeps thinking that the computer needs to be rebooted to finish the cleaning, when that is not the case becasue the computer has been rebooted several times, including the unwanted, immediate reboot after clicking on the Finalize button.

I just uninstalled CSC via the Control Panel and then reinstalled it again. When I tried to run the Disk Cleaner I got the same message again, stating that I needed to reboot the computer to complete the Safe Deletion Process. I searched in Program Files \ Comodo and didn’t find any folder for CSC. I looked in AppData and deleted any CSC folders and files that I found there. I also looked in the Registry under HKLM \ Software \ Comodo Group and didn’t see any CSC keys. So I am not sure where in the registry the CSC keys are that are requesting a reboot. I haven’t done a complete search of the Registry for any CSC keys.

After uninstalling CSC and reinstalling it again, Disk Cleaner seems to be working again. This time I did not get the message that I needed to reboot the computer to complete the Safe Deletion Process. It will be interesting to try the Safe Delete function again and see if I have the same problem I described earlier.

I tried the Safe Delete again and got the same results as described above. After rebooting and clicking on Finalize, the computer immediately started reboot and the “Windows did not shut down properly” screen came up with several options, such as Safe Mode and Start Windows Normally. After rebooting and trying to run Disk Cleaner again, it would not run and told me that I needed to reboot the computer to complete the Safe Deletion Process. I continued to get this message after rebooting again, and after several uninstalls and reinstalls of CSC. I finally did a system restore to a point earlier than when I installed this public release of CSC. I then uninstalled the Beta and installed this final release of CSC again. The ONLY thing unsafe about cleaning files with Comodo Disk Cleaner on my computer is using the Safe Delete function. Then I run into all the problems I have described above. If I clean the files that Disk Cleaner finds, without using the Safe Delete function, the cleaning goes smoothly and there are none of the problems associated with the reboot of the computer using Safe Delete. Based on my experience using Comodo Disk Cleaner with Safe Delete, I would recommend that Comodo delete the Safe Delete function from CSC. Cleaning temp files from my computer has always gone smoothly using the CSC Disk Cleaner when it did not even include Safe Delete. Using the Safe Delete function has been quite an experience, because it hasn’t worked like it is supposed to on my computer.

I have a similar problem. After running a privacy cleaner and restarting a computer, a dialog box with finalize button appeared and Spybot S&D told me that CSC tries to change something in a registry. But i was not able to allow this request , because my computer stoped responding. After rebooting second time, everything was fine, and i pressed a finalize button. Unfortunately, CSC deleted my firefox cashe, despite the “Mozilla Firefox” checkbox was unchecked. Then i ran CSC again, and when i pressed “Analyze My Privacy” button, my computer rebooted again.

System: Windows XP SP2
Security software: CIS 3.5.57173.439, Avira Antivir, Spybot S&D 1.6.0

Sorry for my bad english.

Cheers, 535.

I have XPPRPSP2 32
CIS latest version
boclean latest
CSC 1.0.60093…

When updating to new version from within “the game” a few files don’t (I think it was csi.exe csr.exe among a couple more) update and the installation doesn’t end correctly. The diagnostics find problems and same thing happens when it tries to “repair”, basically it tries to reinstall the update, I take it.

Since you’ve published the new version on the board I did manage to install (clean).

So now I hafta play… thanks for a great game.

Vista home premium SP1 32 bit, CIS beta, BoClean.

Uninstalled previous version and installed new.

Temp file cleaner stopped responding so was closed after several minutes. (Registry cleaner already run). Prompted to restart but failed with BSOD.

Ran System Restore with success, so back to previous version which worked OK.

No minidump file sorry and better not try again as I only have this computer here on my boat.

Hi Andrei, please look into following error after a Power Clean reboot I got a BSOD with a BAD_POOL_CALLER error saying…
STOP:0x00000040, 0x00000000, 0x800000000, 0x00000000 I shutdown my system and restarted and no BSOD followed, I got in clean and everything’s cool, go figure ??? Running only latest CIS stable .439 Proactive config with firewall and D+ both in safe mode with CIS AV also installed and running on a Pentium 4 with 1.5 G memory XP Home 32 bit, CSC freshly installed, any clue?
Thanks and cheers :Beer
Xman 8)


I think we can trace this together. Help me with this:

  1. In CDC, CPC and CRC enable Logs to save info about everything you are trying to delete;
  2. Do the Power Clean and when asking for Reboot do not reboot yet - leave the dialog as it is;
  3. Go to the folder of CSC and save those logs into some other place;
  4. Reboot;

If you get the BSOD then send me all those txt files.

If I am correct, what’s happening in your case is this: You are deleting some system file or registry entry needed by the System… so of course you get BSOD… but because of the SAFE DELETE and REGISTRY PROTECTION you are safe as both files and registry are restored if BSOD occurs.