COMODO Programs Manager Public Release BUG REPORTS

Please post all bug reports & BSOD’s here.

Be sure to include:

  • Your Operating System (and whether it’s 32bit/64bit);
  • Security Software Installed;
  • How you produced the problem;
  • How you tried to resolve the problem;
  • Screen-shots with the error (if any);
  • Post Memory Dumps on crash if you encounter any;
  • All log files of CPM, if you had logs enabled;
  • if the issue is a BSOD, please post all the dump files in \Windows\Minidump folder (you can compress them)
  • if the issue is a crash, program stops responding or freezes please see this topic
  • if the issue is an error (not program crash or freeze) please see this topic
  • Any other Additional Information;

Running W7HP x64 and only Comodo Internet Security. Don’t know if this is a bug per se but have noticed that CPM updates unlike any other program I’ve ever seen. I.e. with any of the last couple betas, and now updating to Release CPM from Release for example:

  1. With installed and running, launch CPM_SETUP_1.3.2.30_xp_vista_server2003_win7.exe

  2. Get “Do you agree to the installation? and legal” dialog

  3. Click OK until it wants to reboot.

  4. Reboot. That’s it? No further prompts.

  5. But I look for it and note that while old CPM is gone, nor has been installed

  6. Launch CPM_SETUP_1.3.2.30_xp_vista_server2003_win7.exe again

  7. Get again “Do you agree to install…”

  8. This time get also “do you want to give us your email” and no reboot is needed

This is strange behavior as it’s possible (likely?) that some users will execute 1-4 and think new CPM has been installed, yet it has not. The only other thing I can think to add to the above is that upon reboot of this PC, I do have to logon to Windows i.e. get the Users screen and select one and enter my password. But there is nothing after reboot to suggest I need to run the installer again.


Do you have UAC enabled on your system? In the case of a manual update the setup is prevented by the UAC from being launched during system startup.

The automatic update is not affected and this issue will be addressed in a future release.

Thank you for your feedback.

Sorry, I missed your question somehow. I’m quite sure you are correct, that UAC was enabled on the PC(s) that caused me to write that post. I just updated CPM on another PC w/UAC disabled and indeed the update performed as it should i.e. after reboot the update installed without prompting from me.

I found another issue I may as well as report here. On my Acer netbook with W7HPx64 and AMD AthlonII Neo K125 CPU 1.70 GHz, 2.00 GB RAM, 64-bit, CIS Premium installed, I discovered with .21 that if I click on the Date column in Programs, to sort by installation date, I get only a very small dialog pop-up, “CPM (Red X) Unspecified error” and a button “OK”. I can sort on any of the other columns e.g. Programs, Company, Size, Status, Usage, Path and get them to change and the up/down triangle. But any clicking on Date gives me the pop-up.

So I updated to latest .30 and it does the same thing. Sort on Date doesn’t work.

Eureka, I have found the problem already! As I was clicking the various OTHER column headers to confirm THEY worked, and I’m typing this post on another PC at the same time, I noticed that I had a program with no date (a blank) in the Date column, a program that had not uninstalled properly and which wanted me to complete the uninstall. After I did that, and that entry w/no Date was removed, then the Date column started sorting again. No pop-up anymore.

Sorry I don’t recall exactly how that “partial uninstall” occurred. Perhaps I used Window’s Programs and Features to try to uninstall it instead of CPM. I just don’t remember. In any case I expect you can duplicate the strange “Unspecified error” popup simply by partially uninstalling a program such that it’s Install date goes missing. Then Sort stops working.

Running W7HP SP1 64-bit with CIS 5.5 build 1383 (latest released). Installed a program called Ghostbuster, having downloaded from the link on this page:

and although it is a .msi installer, CPM did not pop-up to say “monitored the installation” and although it appears correctly with the correct install time in the Programs listing, it shows as “Not Monitored” status. It’s been a couple days since I installed something new, but the last time I did CPM monitored just fine, and of course the cpm.exe is always running.

Here’s the Ghostbuster entry in the ApppInfoLog–advise if you need the whole thing:

10:25:31.001	: ========================
10:25:31.001	: [Software Name]
10:25:31.001	: GhostBuster
10:25:31.001	: [Company Name]
10:25:31.001	: Swiss
10:25:31.001	: [Monitored]
10:25:31.001	: Not monitored
10:25:31.001	: [Help Link]
10:25:31.001	: Not Available
10:25:31.001	: [URL About]
10:25:31.001	:
10:25:31.001	: [URL Update]
10:25:31.001	: Not Available
10:25:31.001	: [Display Version]
10:25:31.001	: 1.0.0
10:25:31.001	: [Display Icon]
10:25:31.001	: Not Available
10:25:31.001	: [Install Location]
10:25:31.001	: C:\Program Files (x86)\GhostBuster
10:25:31.001	: [Install Source]
10:25:31.001	: \\GIGALAN1\Share\downloads\Diagnostics & Tools\
10:25:31.001	: [Uninstall String]
10:25:31.001	: MsiExec.exe /I{63A47DBF-2C74-40E5-B250-99F7DDF94D0E}
10:25:31.001	: [Modify Path]
10:25:31.001	: MsiExec.exe /I{63A47DBF-2C74-40E5-B250-99F7DDF94D0E}
10:25:31.001	: [Install Date]
10:25:31.001	: 6 01.10.2011 10:24:49:702
10:25:31.001	: [Last Access Time]
10:25:31.001	: 01.10.2011 10:24
10:25:31.001	: [Key Name]
10:25:31.001	: {63A47DBF-2C74-40E5-B250-99F7DDF94D0E}
10:25:31.001	: [Has Uninstall String]
10:25:31.001	: Yes
10:25:31.001	: [System Component]
10:25:31.001	: No
10:25:31.001	: [Is Minor Upgrade]
10:25:31.001	: No
10:25:31.001	: [Windows Installer]
10:25:31.001	: Yes
10:25:31.001	: [No Modify]
10:25:31.001	: No
10:25:31.001	: [No Repair]
10:25:31.001	: No
10:25:31.001	: [Is Partially Uninstalled]
10:25:31.001	: No
10:25:31.001	: [Not In DB]
10:25:31.001	: Yes
10:25:31.001	: [Program Size]
10:25:31.001	: 892
  • Your Operating System (and whether it’s 32bit/64bit); win7 pro 32
  • Security Software Installed; cis 5.8 beta rc2
  • How you produced the problem; i opened teamviewer and received a message that there was a new version so i click update. then while installing a received a popup from CPM saying a malware installation was in progress. the install seemed to finish successfully but i checked the install with cis cloud and local sigs and nothing was found. its in the whitelist
  • How you tried to resolve the problem; na
  • Screen-shots with the error (if any); na
  • Post Memory Dumps on crash if you encounter any; na
  • All log files of CPM, if you had logs enabled; attached
  • Any other Additional Information; this makes me wonder if cpm can block real malware installs.

[attachment deleted by admin]

If you download textmonkey Boxer Software - Text Monkey Product Information
and uninstall it, CPM removes the wrong register lines.
Many programs doesn’t work anymore :frowning:

  • My OS = win xp pro sp3
  • Security Software Installed: avira premium 12, pc tools firewall plus
  • How you produced the problem: install and uninstall a software I tested
  • How you tried to resolve the problem: yes I did a system restore
  • Screen-shots with the error (if any); no screenshots


Could you check the CPM install folder and send us the following log files: ‘AppInfoLog’ and ‘UninstallAppLog’.
We also need to know what was the status of the application when you uninstalled it (Monitored, DB Monitored), in order to address the problem.

Tank you.

my OS : win 7 64-bit. firewall : comodo, antivirus : microsoft security essential

I’m installing phyton 3.2 some months ago. And two weeks ago I know about CPM. So I install CPM after phyton is installed.

now i’m unistalling phyton, after uninstaller complete, CPM just keep tell me to wait until uninstall done. It seems can’t detect whether it is done or not. Although it says “DB monitored”

OS: Windows 7 32bit
Security Software: CIS
Problem: No “Install and monitor setup using CPM” context menu for exe and msi files in virtual cd/dvd Drive(eg.Deamon Tool & WinMount).

Operating System: Windows 7 (64bit)

  • Security Software Installed: error occurs during anti-virus installation
  • How you produced the problem; BSOD when installing PCTools Spyware Doctor with Antivirus
  • How you tried to resolve the problem; Must use system restore & uninstall CPM prior to installing the Antivirus software.
  • Post Memory Dumps on crash if you encounter any; sorry already deleted. error code was Stop: 0x0000007E. Upon reboot (either normal or safe mode) Windows would stop loading with error message “A problem has been detected and Windows has been shut down to prevent damage to your computer”
  • Any other Additional Information; I haven’t tried to install CPM after installing the security software yet. I will report back with the results when I do.

Problem: Windows event log errors probably on reboot. Here is text:

Log Name:      System
Source:        Ntfs
Date:          17/07/2012 11:55:20
Event ID:      137
Task Category: (2)
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      Dell-8300-PC
The default transaction resource manager on volume ComodoEvdd encountered a non-retryable error and could not start.  The data contains the error code.
Event Xml:
<Event xmlns="">
    <Provider Name="Ntfs" />
    <EventID Qualifiers="49156">137</EventID>
    <TimeCreated SystemTime="2012-07-17T10:55:20.081379000Z" />
    <Security />

Your Operating System (and whether it’s 32bit/64bit); Win 7 Ultimate Sp1 X64

  • Security Software Installed; CIS, Keepass
  • How you produced the problem; Windows event log event probably occurs each reboot.
  • How you tried to resolve the problem; Have not
  • Screen-shots with the error (if any); N/A
  • Post Memory Dumps on crash if you encounter any; N/A
  • All log files of CPM, if you had logs enabled; Appended
  • if the issue is a BSOD, please post all the dump files in \Windows\Minidump folder (you can compress them); N/A
  • if the issue is a crash, program stops responding or freezes please see this topic: N/A
  • if the issue is an error (not program crash or freeze) please see this topic: N/A
  • Any other Additional Information; Evdd.sys is in Comodo Program Manager Directory (C:\Program Files\COMODO\COMODO Programs Manager) and system32/drivers directory.

[attachment deleted by admin]

- Your Operating System (and whether it’s 32bit/64bit);
Windows 7 SP1 32bits
- Security Software Installed;
None (besides windows firewall and Windows Defender)
- How you produced the problem;
1- Install CPM.
2- Monitor the installation of PCTools Free AV
3- After the installation completed (and sometimes while the installer is downloading updates) the computer crashes with a BSOD. After this you are unable to boot back to windows since windows crashes every time on reboot.
- How you tried to resolve the problem;
I used a system restore point to a date in time when CPM was not installed and installed PCTools.
This is not a fix for the problem since I had to do the installation of PCTools with CPM unnistalled, so…
- Post Memory Dumps on crash if you encounter any;

I’m guessing this seemingly-abandonware program isn’t likely to get updated anytime soon, but…

  • Your Operating System (and whether it’s 32bit/64bit); Vista Home Premuim, x64
  • Security Software Installed; Comodo CIS
  • How you produced the problem; It reproduces itself (see beleow)
  • How you tried to resolve the problem; Restarting the process (see below)
  • Post Memory Dumps on crash if you encounter any; Dump!!!
  • Any other Additional Information;CPMService.exe freezes as soon as it starts. I tried terminating it with the task manager, a third-party program called “process hacker”, and eventually the Microsoft Management Console/Services.msc. I finally shut the program down, but now it’s stuck on “starting”, and will not monitor my programs. CPM.exe seems to work fine, but without CPMService.exe, I may as well not be using anything at all.

Problem: CPM does not monitor installation of uTorrent 3.3.

OS: Windows 7 64-bit ultimate (clean installation in VMWare workstation 9.0.1 build-894247 with all MS updates).

Antivirus: No


I installed CPM, rebooted machine 2 times, then installed uTorrent 3.3 without adware. CPM refused to monitor it. See youtube movie: uTorrent installation - YouTube

I also tried default uTorrent installation (with adware), in this case adware was monitored, uTorrent did not again.

Yet another vaporware program from Comodo. Disappointing!