Comodo IS firewall system try icon

Hi, I am experiencing a disappearing CIS firewall icon from my system tray.
I have run the diag tool, and it was unable to ‘fix all problems’ (?) .

Not sure how to attach the resultant report, or address this issue.

I am using Win xp home, witha core2duo processor (2gb).

Recently I have installed and run ‘stopzilla’ and ‘super antispyware’ trying to track down a identified bug that avast was unable to remove.
(usually just use Comodo IS firewall, Avast and Malwarebytes).

Any advise would be welcome and apprecaited.



Check your windows event logs, there may be some information related to your issue in there. Simply run “eventvwr”.

Hope this helps



Seems my earlier reply didnt stick.

Thanks for the advise, Bulgroz, however after following the hint, I am unsure what i should be seeing or indeed how to investigate further.
They appear to be log tables however dont provide me with any leads. There are logs there for ‘applications’, av, and security…yet none of the logs in the details or title mention CIS.

If this could be the way to investigate can someone please elaborate, otherwise any further ‘clues’ would be appreciated.



when you say the icon is disappearing do you mean the icon is gone and the program is still running or does comodo crash?
check task manager to see if it is still running when the icon dissappears

Hi wasgij6,

thanks for the response

Comodo doesnt show any signs of crashing, the icon disappears, yet cmdagent process is still running…strange?



when i used v4 this used to happen to me occassionally the way i fixed it was just click the shortcut that comodo makes to run the program then it shows up and usually it didnt happen again. idk if this will work for your situation but its my only experience with this problem


Thanks for the suggestion, that precisely what I did/what i do.

Can you confirm that the process cmdagent is running, that comodo is actually still running?

I have just noticed that it has occured again (as I write this), and comodo seems to start when the icon from the desktop (in this/my case) is clicked, as suggested
The fact that the start screen is briefly displayed, doesnt given me much confidence that it would be continuing to run.


It is likely a bug in Windows XP. I had that myself on XP and found that logging on with a password stopped it happening. If you log off and log back on and it then shows that is probably what your problem is about.

There are other things you can try here;

Hi JamesFrance, thanks for the response.

For this to be a bug in win xp (which is more than possible, as I am also have issues with organising favourites in Internet explorer) I would have thought it would have been consistently doing it for sometime, however I have only noticed it relatively recently.

I tried the log off and log back in, and CIS FW icon still didnt appear.

I have disabled the ‘hide in active icons’ in the taskbar, and will test. Although when previosuly logged in this moring, it didnt immediately show CIS FW.

The link you have attached is indeed interesting, and I will try a couple of the options there.

One issue mentioned is a startup manager. I then reviewed items in my start up, and CIS FW is not mentioned. Does this need to be? Given cmdagent IS running possibly not?

There appears to be no settings to control this in the application.

I do appreciate the advise



If I look at the startup list with Winpatrol there is nothing for CIS, however in msconfig startup list I have cfp.exe.

It may be different for you as I am running the full CIS5 beta on Win7 x64.

Hi James,

You are quite right, Cfp.exe does NOT show in my start up (msxonfig/startup) or otherwise.

Looks like I am stuck with this, though confirmation that cmdagent IS the firewall running would ease my mind a little.

Thanks for the input.



I am fairly sure that cmdagent.exe is the firewall so you are protected. cfp.exe is the gui so if that doesn’t start it explains why you don’t see a tray icon.

I would suggest that you uninstall and reinstall a new copy of the firewall. If you want to keep your configuration you can export it and import it to the new installation as long as you are using the same version. The current release is 4.1.150349.920.

Many thanks James, I will do just that.



Sorry to bother again James.

But how does one uninstall CIS?
There is no uninstall app in the directory, and removing via add/remove programs does not seem to do anything?Q!?!



Hi lethal,

lf you go to Start>AllPrograms>Comodo>CIS do you see “Add and Remove Components”?

If so you can chose Remove to uninstall the program.

If not can you reinstall over it? Then uninstall and start with a fresh install.

I have not had this problem myself, but there is a solution here:;msg259617#msg259617

Hi James,

I can see Start>AllPrograms>Comodo>CIS “Add and Remove Components”, but when clicked i received the message ‘the action is only valid for products that are currently installed’…no good.

I tried to reinstall over it…however this resulted in CIS trying to install it and request a restart (continually)…so that was no good.

In regard to the link I couldnt see any link at the end of the post (registered users) …and the tool downloaded from the second or third subsequent link (non-registered users) failed with various error messages in the dos environment.

Seems I may really have a corrupt installation (cmdagent is running, yet cant see tray icon, add/remove wont work, and now this).
I have also used ccleaner and comodo system cleaner and re-tried, with no success.

Do you (or anyone) have any further suggestions, that will enable remove of CIS FW?



At the end of Ragwing’s post you should see CIS Clean-up in red which you can click to download it.

Otherwise I am out of suggestions, but maybe you could send a PM to Ragwing to see if he could help you.

thanks James,

Yes I saw the tool…it was the same one as supplied by the links (the links that worked that is)…

I will send himm one as you suggest.

I do appreciate your help to date.



It is a bug in XP that has been known for sometime. Unfortunately, starting with v4 of CIS the bug is triggered by CIS. It never happened with prior versions. It is caused by too many things loading at the same time at startup. If you get a free utility called Startdelay and use it to delay the Comodo startup entry (which is only the GUI, not the protection elements of CIS) by at least 20 seconds, the Icon will always appear and so will all the other ones that are supposed to show. The only problem I have encountered using this solution is that if you ever want to uninstall CIS, you have to remove it from the control of Startdelay or uninstall Startdelay first. Otherwise, CIS will not uninstall fully and you’ll have to run the removal tool and maybe even delete some things manually afterwards.

Hi Dch48,

Thanks for the information/opinion.
I will try the delayed start up tool (startdelay)…and indeed it is a concern that I cannot uninstall CIS (now, before startdelay).

Accordingly I will await any response from my PM to Ragwing, before proceeding. He may have a view from another ‘angle’.

At the same time it doesnt appear to me that I have a great number of items in start up, however any option/direction to resolve is a good option.