Comodo Internet Security V8.2.0.4703 (Chrome Hotfix) is released!

Hello Everyone !
Here we are again happy to announce that we have fixed the Compatibility issue with Google Chrome 45.x and COMODO Internet Security/Antivirus/Firewall V8.2.0.4703 Chrome Hotfix is reelased!

Existing CIS 6.x, CIS 7x and CIS 8.x users will receive an automatic update offer V8.2.0.4703 Chrome Hotfix Release update !

Download Location

Comodo Internet Security

Size: 216M ( 225688096 )
MD5: 0ba1bc28183f06f955b011fea48791a1
SHA1: f20daaf44758ee21cef08416dbaca69c68a9df3e
Comodo Antivirus

Size: 216M ( 225688096 )
MD5: eb8cd8abd88e4cfb891eb1cf613cba1f
SHA1: c5f588177aeb26e4fad34fa8260ed41fd525d8c7
Comodo Firewall

Size: 216M ( 225688096 )
MD5: 2a0be00850233a1dc774b84b7f12f7d6
SHA1: 3d97a319af800a578928121fdc5ec44c272cce73

BuketB, does this update fix the problem related here: Comodo Forum ???

I get a 404 when clicking the Comodo Firewall link (edit–>the link above that is, for the hotfix)

Have been having no Chrome-for-me issues like many others out there, some using Comodo and some not.
I am a Comodo Firewall user on Win 7 HP.

Just hoping to be able to use “Chrome” again…


Nope it seems whenever checking for updates that error of 0x80070002 - the system cannot find the specified file is always displayed.

Interesting, I just finished downloading the installer for cispremium_installer.exe without a problem

Ok, so I clicked on said link since you responded and it also worked fine…although I sure wasn’t expecting (among all the other things) a brand new “Chromodo” (lol) browser-particularly one that opens Yahoo! (blech). But I WAS able to open my Google Chrome page back up and make my default.

I got the 0x80070002 error code today before the hotfix, not sure what that was about as I did not normally manually update the program (if ever that I can recall).

So yeah…as well, interesting.

Updated, thank you!

Thank you for the quick fix.

Thanks for new version.
However I try to made a fresh install of Comodo Firewall into Windows 10 and receive an error “This application is not compatible with this OS version”… ? Then nothing launch.

I have a fresh install Windows 10 build 10240 x64 Pro.
Did not have any problem with the previous version (Just Chrome !).

Back to version 8.20.4874 and all Ok.

edit: Just receive upgrade notification. After upgrade done and reboot new version seems good.
Maybe the full installer had problem ?

Thank you for the new update of CISP. I just received it a half hour ago. I tried Google Chrome and the problem of it being stopped has been solved; but I uninstalled it because i am tired of the issues with Google Chrome, so I am now using the Chromodo browser which is integrated with Chrome and Dragon. A much better browser than Chrome! :slight_smile:

Doesn’t work for me. It only works if I have Chrome in the exclusions still, and/or rename it. Have updated to this version, and rebooted afterwards

Exactly the same problem affect Vivaldi web browser (based on Chrome code), with the same solution. Works better from the executable - my start menu shortcut never works any more (yes, it’s still pointing at the correct .exe).

Windows 7 64bit, Chrome 45/46, latest version of Vivaldi snapshots.

Honestly, I just want to TURN THIS OFF. Comodo should NOT be affecting programs when I turn off that “detect shellcode” option, at all, whatsoever. That’s the core of the problem, not what the filename is or what Comodo thinks it is.

Can you check the version number to see whether the update succeeded or not?

This is the correct update. Click on the ABOUT section in the Comodo Internet Security to see if you have the same version as mentioned here. If not, hit the UPDATE tab to see if there is a latest version for your PC.

I just installed Vivaldi (Developer Build) (32-bit) with the freshly updated 4703 on Vista x64 but I can’t confirm ledow’s findings. I may try another Windows version later today.

Why are you using Windows Vista? MS is not supporting that OS any more! You should be using Windows 7 and higher.

I happen to still have it. :wink: It is still supported with security updates not with updates for new functions. When a new Windows gets released I buy a new hard drive for the new windows; such an amazing timing of events. The hard drive that had XP on it started to slowly die by the time the support XP was to be stopped. :smiley: CIS supports Vista and XP by the way.

Yes you are right. Here is when Vista and other OS will no longer have MS support: Lifecycle FAQ - Windows | Microsoft Learn . If the link is unclickable, then copy and paste it into your default browser. Windows XP is definately out of the picture.

This update is for the CESM also ??

It’s in the making:

I tested on Windows 7 x64 and the latest Vivaldi snapshot, , and Vivaldi starts normally.

Can you check the version number of CIS and guard64.dll (system32 folder) and guard32.dll (SysWOW64 folder)?

Guard64 -
Guard32 -

Vivaldi - Prompts for update but cannot download update because of problem. Cannot start browser.
Latest snapshot: v. - Downloaded 32-bit setup, it installs but each run prompts for the same update.

Chrome latest stable, and then updated to Version 46.0.2490.22 beta-m (64-bit) - same problems with trying to start it still. Often get tabs that never load and all extensions “crash” (even no extensions enabled).

Exclusions listed on CIS. Also renamed executables. Desktop/Start Menu shortcuts NEVER work. Sometimes can coax it into working by killing processes and running the renamed .exe direct but the next time it will just do exactly the same.

Never happened prior to Chrome 45.

Have rebooted several times (SSD, so it takes literally a few seconds).