Comodo Internet Security v11.0.0.6622 - BETA

Hi All,
Here is the BETA v11.0.0.6622 of Comodo Internet Security that addresses some of the regression issues found in v6606 release:

BETA - Warning:
Following setup is a BETA setup and it is not recommended to test on production machine and it is intended only for beta testers.
So please try at your own risk.

You can update previous production versions either by having following hosts (c:/windows/system32/drivers/etc/hosts) entries or by defining test server IP as shown in enclosed HostSettings_for_Update.png.

At this point we are releasing only offline setup versions of this hot-fix beta, we will make online versions by Monday, 9th Jul. Additionally, we are also introducing offline setups for Comodo Antivirus and Comodo Firewall.

Offline Setup Details:
Comodo Internet Security Premium (Firewall and Antivirus only):
Size: 63M (65,826,616 bytes)
MD5: 2da656c8b027fc80d27040da206968f9
SHA1: a0c4a212a1f878d7669dd02f17455917ace32954

Comodo Antivirus Only:
Size: 63M (65,826,608 bytes)
MD5: ca7e33a4ccc792147977a2bc7ab5b257
SHA1: 4cb251ece9858de3910c0b239d3c6faf5d3732ab

Comodo Firewall Only:
Size: 63M (65,826,608 bytes)
MD5: 28afe464a2fcef7f7984971c7a273b61
SHA1: ec573e713d6fca52ac726058963ad703a9578ecf

Here is the change list:

Protected Service: This hot-fix achieves following requirement coming in Windows 10, RS5 release, which is due in Fall-2018 as explained here:

The Windows Security Center (WSC) service now requires antivirus products to run as a protected process to register. Products that have not yet implemented this will not appear in the Windows Security UI, and Windows Defender Antivirus will remain enabled side-by-side with these products.


  • Older trusted files appeared as 'Unrecognized ', treated as visual bug as stated here.

Following issues are under investigation:

  • cistray application crashes as stated here and here.

We are trying to trouble shoot above issues with respective users, we hope to have another build next week with possible fix of these issues but in the mean time any feedback on above two changes is highly appreciated.

Please try it out and let us know if you see any issue.


This is wierd. I was give a beta via Skype that worked GREAT.

Now i updated to this beta and now i’m facing again the problem of cistray not loading/running.

Hi Pixo1,
Thanks for helping with troubleshooting with test build, we have yet to finalize the fix.


Yeap, reading the whole description i saw that, sorry i was very quick to reply.

On Windows 8.1 the security center keeps on reporting the AV definitions are not up to date.

I upgraded from 6606 using the program updater. After the reboot the security center complained the AV definitions were not up to date but they were. I reset the security center and rebooted the system twice but the security center still reports the AV definitions are not up to date.

On a side note. After I reset the security center I rebooted. After the reboot cis.exe would not start; cmdagent.exe and cistray were running. It neither didn’t get started automatically nor would it start when opening CIS from the shortcut on the desktop. Sometimes the security center reset needs two reboots and this is one of those cases.

Thanks, we will check in Win 8.1

Updated from 6606 using Hosts settings. Windows Defender reports that Firewall is off and reboots don’t fix this . . . also error when downloading Recognizer. Haven’t had that Firewall issue for years

Going to uninstall and try a clean install now. . . after about 10 minutes - got the message again about both Firewalls turned off and to turn on Comodo. Everything shows as working , but Defender shows as below. Re-setting the Security Centre doesn’t help

On the plus side, the bug with the widget showing numerous unrecognized files on every start seems to have been rectified

Win10 1803 (17134.137)

No change for me, CIS tray is dead on arrival.

After installing it doesn’t load on itself, clicking the desktop icon doesn’t do anything, restarting makes no change and after a few minutes I get the crash message wanting to send these dumps that I’m uploading to mega as usual: MEGA

Now this is what is showing . . . .

Win10 1803 (17134.137)

Hi Shoonay,
That fix is yet not in there.

Following issues are under investigation: - cistray application crashes as stated here and here.


Please share OS details.

I have the same problem as EricJH on Windows 10 1803 17134.137.

Re-installed 6606 and everything back to normal with both Firewall and Antivirus settings and no error messages and also the ‘numerous unrecognized files’ bug has vanished

Win10 1803 (17134.137)

Makes me wonder what it will do with build 17711.1000

Windows 10 Security center keeps on reporting that AV definitions are not up to date also. I’m on 1803 (17134.137).

Same here but with added firewall notices . AV every hour and firewall just about 10 minutes apart. Also causing Explorer.exe restarts. I’m on 1803 (17134.137)

Win10 1803 (17134.137)

It also appears that Recognizer 6622 which was downloaded from the test servers, stopped Virtual Desktop loading

After I reinstalled 6606 (and then declined the downloaded updates), it still had Recognizer 6622 and Virtual Desktop just ran the Loading message - but never started

Once I changed the Hosts file away from the test servers, it replaced it with Recognizer 6606 again and Virtual Desktop worked and ran as normal

Win10 1803 (17134.137)

That doesn’t reproduce on Windows 8.1 x64.

Doesn’t on Win7 Pro x 64 either

Tried it on another Win10 Pro machine and couldn’t reproduce it there, so probably just this one, which I’ll clean up a little and try again

Edit: Tried the scenario again and VD worked fine with either Recognizer on Win10 1803 (17134.137) so you can ignore this one I think!