Comodo Internet Security v10.0.1.6223 Released

Everything fine here with Win10 64 (up to date w/o Creator)

Clean install and the icon annoyance has gone. Installed ISE with the installer from a mirrored drive, re-input the Logitech SetPoint fix to get rid of the annoying log entries and all is smooth running

There is still the Secure Shopping bug with use of a Logitech wireless mouse and SetPoint, but I never use that in any case
Strangely enough, the pop-up warning doesn’t seem to be as sensitive now and if I remember not to use the back / forward buttons, it’s quite useable if I ever needed it

Many thanks :slight_smile:

Well, not all is fine :frowning:
CCleaner fails to clean or even uninstall itself.


I previously had cmdAgent failing to start (all CIS 8 and 10), Windows Action Center saying I have no firewall or AV until I manually started Comodo after the failure message (all CIS 8 and 10), and the desktop with no Aero, just a basic theme and the desktop theme manager ‘unavailable’ through the prior CIS 10 versions - Windows 7 Home Premium. Using Startup Delayer to delay the start of cis.exe until after dwm.exe had finished loading removed the problems but I wasn’t happy and was going to abandon Comodo if this update didn’t fix it so that I didn’t need 3rd party software just to get Comodo running while I had an Aero theme desktop.

Very bad initial impression after the update. Following the update, and disabling Startup Delayer before the end-of update restart, following the restart I had a basic, no-Aero desktop again, cmdagent failure again, and the upgraded Comodo had even lost some of my settings, like the Comodo theme I’d been using. And to cap it all, trying to restart for a second time the computer locked up at the unpopulated desktop but pre-logoff screen stage and I ended up having to do a manual power off.

But after the second restart (and another since uninstalling startup delayer) the problems cleared (other than having to redo the lost Comodo settings) - the machine is now starting with the desktop Aero theme, and Comodo is starting without me having to do it manually.

So, terrible initial Comodo update experience (especially having to do a manual power off to get my laptop to shut down). But since the second restart the problems appear to have cleared up. Here’s hoping it stays that way.

Now to see if it will be OK if I reactivate more components than the Firewall and Antivirus. Previously it killed my browsing with Firefox, somehow causing any page with flash videos to take minutes to load (that is just to load the page, not load and play the video).

After another restart was able to install CCleaner. All settings were gone however.

OK, thanks for another update to a good program, have used this since it was first out :slight_smile:

Anyway just to make it clear, the update after installed didn’t change anything as far as the startup icon showing in task manager, ( Redstone) see pic of LAPTOP. the tray icon did however show up as it should, with no popup error. OK,

The DESKTOP has Creator, on this machine it was showing up with no problems at all before the update and now after see pic of DESKTOP

Now, I kept looking at the icon in startup on the desktop, did a right click to check the file loc and just what it was using, found it used the tray exe, so went on the laptop I opened an old start program, where I could manually add an item. Did that, restarted, and there it is :), so now I got it fixed on both machines.

Since I re installed Redstone on the laptop, I’m still waiting for the WU to kick in, instead of using the USB installer this time, But as far as Comodo, I don’t see any problems when it does.

Oh - what’s what with ‘Internet Security Essentials’? There was a screen about how it would protect against man-in-the-middle attacks during the update install, but the only option on that screen was some way below the stuff about ICE and just a tickbox for changing all searching and home pages to Yahoo - which I declined. I never saw an actual option to install ICE, or a link to download it. and it doesn’t appear to have been installed (it’s supposed to appear as a separate program in Programs And Features and be in its own Programs folder - right?)

If you had it before and uninstalled, it won’t install again due to a bug with checking to see if it is installed, it will think it is already installed even if its not.

Well, between the final CIS 8 version causing my laptop to BSOD at the login screen every time and my problems reverting to the previous version ot have a usable computer at all, and later attempts to work round CIS 10 killing my Aero desktop display, I do recall cleaning/uninstalling everything Comodo at least twice, so that explains it.

But the question then is, presuming it is worth having, how do I get it back? No installer for it listed in the first post of this thread, and I can;t find one on the main Comodo site either, just its help documentation.

Pretty much the same here (Win 7, 64bit). The update from 8 to 10 failed two weeks ago and I was having the same issues as others. I tried to remove Comodo to re-install it again. At some point, something must have gone pretty ■■■■ wrong.

What has been bothering me the most ever since the failed update is that I can’t manually remove Comodo anymore. It’s not in the list of apps/programs even though it’s still running. I tried some removal tools. Most of them won’t find Comodo as a removable program. RevoUninstaller does list Comodo, however, it’s listed as version 6.3.

Every time I try to just install Comodo with the regular installer, it tells me that I have to remove an older version first in order to proceed with installing the new version. Unfortunately, it doesn’t happen automatically or as part of the installation. That eventually brings me back to the original problem that I can’t manually remove Comodo as it’s not in the list of apps/programs.

Quite annoying, tbh. Love Comodo and have been using it for years. That said, needing to set up your system again after an update isn’t exactly what you want. I’m by no means an expert, however, I don’t think I should have to be one in order to get this thing going again.

Any help would be greatly appreciated. At this point I’m still too lazy to start from scratch with my system (and I might have been too lazy to do proper backups which is obviously my fault :wink: ).

Having lots of issues with the UI, I tried adjusting the columns and everything just auto expands outwards and now everything is completely unuseable.

Also why is C:\program files\comodo\comodo internet security\cmdagent.exe trying to connect to the internet? I have cloud lookup disabled, what is it doing, what am I blocking it doing by not giving it a firewall rule.

It delays my windows login for around 3 mins or so. It normally only takes 4 seconds for my Windows login to go from the “Wait” to “Welcome” messages, but CIS10 makes it go way longer. I’ve included the screenshot of my desktop on which you can see what CIS10 does to my Aero and the Windows Notification Center message that pops up (it’s in my native language of portuguese however). I’ve also included the diagnostics as per your request.

Weirdly enough, the Aero issue and the Center message fix themselves automatically after a couple of reboots, I did a clean install again to replicate the bugs and take the screenshots. The slow down on the login remains though. I also noticed some quick unknown application windows flashing by for like a microsecond when I’m booting Windows up, can’t figure out what they are but they’re definitely abnormal.

CIS10 also forcefully takes down my Windows Firewall at every boot, I don’t know if this is correct behaviour according to my install options or not (I basically install only the Comodo Antivirus and the Firewall, unchecking everything else).

Please follow this guide Comodo Forum

Do not use Revo unless you have the pro edition and used the monitor feature to monitor the installation of CIS. Just run the comodo removal tools and reboot after each then run the standalone installer.

It could be comodo message center, checking for program and av updates, or submission of usage statistics. What is the IP addresses it is trying to connect to?

On Windows xp to 7 the windows firewall is turned off if you install the firewall component. You shouldn’t have more than one software firewall running at the same time.

Also now File list does not show services anymore, It used to display the startup NVIDIA driver items for example and now it does not.

And now with the columns resizing, the scroll bar is soooooo long that there is insane lag causing the system to hard lock, this needs fixing asap, how can I reset the columns?

To what hosts do these IP addresses resolve? Hint: Whois - IP Address - Domain Name Lookup .

Ok thanks I’ll let umesh know and you can see same issue here.

If you mean the .sys driver file then you need to enable ‘show non-executable files’ in file list as it is disabled by default.

Resize issue is a known issue and I’m guessing you use a large display/resolution i.e. 1920x1080? To reset column you can use this workaround

Hi Im_Special,

Also why is C:\program files\comodo\comodo internet security\cmdagent.exe trying to connect to the internet? I have cloud lookup disabled, what is it doing, what am I blocking it doing by not giving it a firewall rule.

Going by connection snap you shared, it seems one IP is related to where we have AV and program updates and other is CDN behind on-cloudflare.


Yes but why if settings such as CMC, cloud lookup, and automatic program & av updates are disabled?

Let me dig deeper and get back to you…