COMODO Internet Security The removal of your hardware

It is only USB HDD, but when I removed the hardware after copying the file, it locked and error occurred

It also remains in the Windows log.How can we solve it?
To properly remove the hardware, cmdagent.exe can be completed by completing the process several times.
I heard from people I know, but at least it seems to have been a problem since version 8.

By the way, the environment is Windows 7Pro latest version COMODO version is COMODO Internet security
I have been plagued with this problem for many years. I want you to do something somehow. By the way, USB memory has no problem.

The problem occurs regardless of USB 2.0 and USB 3.0. I will add it.

This is the evidence.

I made the different pattern. Even if a file ahead of the file copy is eliminated, it’ll be an error.

The link has disappeared. Please note.

I examined later, but there was no problem with videos, music, photos and text.

Should I write more if there is missing information?

Hello nobo,

I’m not sure that I fully understand your problem.

You should take the time to look at the following two software packages that release files, folders, and drives from all processes for renaming, moving, deleting, or ejecting:

  • IObit Unlocker (the simplest and fastest, but less effective, it may be useful in some cases).
  • EMCO UnLock IT (nothing resists it, but it is slower and more complex).

I remain available for any further information.

Hi, AntonioElEspanol

I used two softwares and found that they were not locked.
Even if I delete the copied file, I get an error.
I think that it is a problem of the process of COMODO after all.
This is the Windows log.

It’s weird because I had the same problem with a hdd that I could not eject after an antivirus scan. After analyzing the drive with EMCO UnLock IT I was able to release the files “hooked” by Comodo and I was able to eject the drive without any problem.

For information, and in case, IObit Unlocker did not detect anything.

I understand a possible phenomenon. Immediately after startup. I got an error (I just just wait. It takes a long time to settle down)
It calmed down and did not become an error. Probably COMODO’s process background is working.
But I want to stop this phenomenon.

By the way, I tried repairing COMODO Internet Security, but I did not get an error.

Hi nobo,

Our developers are aware of your issue, they are working on it.

Hi Metheni,

I am relieved with this. I was anxious because I did not come for a while. thank you very much. Please do your best.

It made the portable harddisk could not eject with safety removal in Windows 10 1809.
Two laptops also had this issues when all scans of anti-virus and features are disabled excepting the firewall (Safe Mode) unless the Comodo Internet Security is exited. After that, the program was performed the task kill process about “cmdagent.exe”.

Comodo Internet Security Version:

The application \Device\HarddiskVolumeX\Program Files\COMODO\COMODO Internet Security\cmdagent.exe with process id 7652 stopped the removal or ejection for the device USB\VID_XXXX&PID_0000\XXXXXXXXXXXXXXXXXXX.

  • 225 0 3 223 0 0x8000000000000000 28839 System Administrator
  • 7652 82 \Device\HarddiskVolumeX\Program Files\COMODO\COMODO Internet Security\cmdagent.exe


Hi machiavelli,

I also have the same problem I already wrote to. Comodo Internet Security The removal of your hardware.
Already Please rest assured that Comodo has already confirmed.

Hi machiavelli,

Thank you reporting, this is known issue our developers are working on it.

Any update on this one yet? It’s driving me up the wall a bit.

Hi Durger,

Now Comodo is working ■■■■■■■ the problem. I think it will be solved in the next version. Please wait until then.


The above is,soon a link disappears.

Thank you for watching my video of the problem. Many people have this problem
I also have. Expect the next version of Comodo.

Thank you. It has disappeared this time. Please pardon.

Found the same problem. Problem may come from some file in usb have a same name(or same file) with system file. i always found this problem when i create a usb win10 installer.

Another is some file contain Comodo Alternate Data Streams ( $CmdTcID ). Comodo said they didn’t use it but they Never!! give us a permission to remove ADS from our file (What the…!).

Some case that i found is when did not connect internet i cant eject usb but after connect internet i can eject normally. soooooo wierd. (sound like telemetry thing)

[ please read this before reply. I have disable all and use only firewall feature. ]

Hi tawusaw,

Thank you very much. After disabling everything except the firewall, the USB HDD could be removed.

It does not change even if you delete Comodo alternate data stream using AlternateStreamView.

Comodo Team. Can not do without internet connection? Why can’t you do it without the firewall only?

Anyway thank you for the information.