COMODO Internet Security 6.3.300670.2970 Released!

I don’t understand what you mean by that but okay. :wink: I just like that it didn’t reschedule the scans like every other update has done

Personally I believe the way it was before worked just fine, just un-tick the things you didn’t want and continue with the installation, now it brings up a side-way installation (if one would call it that) and disguises it as a needed part to continue the installation (Whether intentional or not, I’m waiting for official statement on the mater until I believe it wasn’t intentional) Changing the “Cancel” button to something else as you suggest might fix this situation (it probably would) but I still prefer the way it was done before.

Keep up the hard work. :-TU

Exactly. When it is presented as if, you are not able “to agree and install” and you know normally clicking cancel with this, would not install the product, it is not what you would normally choose, so one would “FEEL” forced to chose one or the other. I was not aware either that this would install Privdog on my machine, not just CD… I do not use extensions/plugins on me IE, not even lastpass, which i use on my other browsers… I normally defend Comodo to people calling them shady, but this was irritating to say the least.

*easy fix sorry

It stays the same for me.

It was confusing, as clicking cancel instead of the “agree and install” button normally leads to the product not being installed. Comodo Knows better then this, they know they have to CLEARLY present these installers or people will automatically assume… So when i say “SHADY” i mean, they know this is not the proper way to present something, and of course it was intentional.

I have had no problems helping Comodo all this time, i just did not do so through their extension or homepages… I have done so, by installing CIS on many machines around the area i live in, including businesses… I have done nothing but defend them, and speak highly of the them… This little issue will look bad, because if “I” think this is not right, what do you think all those others will think that i have defended against… What are the people that i have convinced to install this product, that trust me, going to think, when they see something like this… I imagine i will be getting some calls…

So it is the principle of this, that matters.

Thanks for the updates. I am glad to see CIS development continuing actively :). Keep up the great work Comodo.

1) Trustedadssvc.exe is a PrivDog service which works in a background and provides to PrivDog plug in instances an ability to save and share common data So it constantly stays in the background to speed up communications with plugin instances.

While the cynical in me think this was intentional, at the same time i think your post was rather ‘dramatic’.

Indeed Comodo now is getting SHADY… as this quoted comment implies.

Why Comodo has done such nasty thing? As soon as comodo updater downloaded this update and was installing, I noticed the window where you can check Privdog and to set yahoo as your homepage, I noticed that If none is selected then the only option was to click “cancel” so I jumped into the forum and found that by clicking cancel the product installs.

But that’s not the main issue/topic here, the concern is that Comodo applied a nasty trick for users to either install Privdog or change the browser homepage >:(

At first when I noticed that, my first thought was “Well… Comodo now is forcing their users to install Privdog or change webpage… so I will look for another software from another developer” But before doing that I browsed the forum and found that I can click on “cancel” and CIS still updates/installs :-\

I only use the firewall from CIS, and it’s still the best firewall, but I’m not liking how Comodo is being Nasty and shady. Hope that you fix this and allow the “agree and install” button to be clicked without choosing Privdog or changing homepage (I know that Cancel do install the software, but I’m confident that several users don’t and ended installing Privdog or chancing homepages)


Are you talking about file submission issue ?


After the update has finished installing we get the option of restarting now, in 30 minutes, in 60 minutes, in 4 hours (or whatever the times are), but why not one to update when I restart the computer as usual. Sorry, but even 4 hourly popups annoy me. :slight_smile:

edit: even more annoying, and for the second time, it popped up and took focus while I was playing Borderlands in full screen. Now that really is a not on. Any program that interferes with my gaming is likely to have a very short life on my computer.

Hi all;
After updating to the newest version (6.3.300670.2970) of C.I.S on my Win-XP machine, my cpu (amd dual core) is now running between 50 % and 100 % capacity at idle.
Also my cpu temperature goes up from 35 C to 50+ Celcius.
After killing cmdagent.exe (a C.I.S. exe file) in the taskmanager, my cpu goes back to normal at 1 or 2 % idle. Please help!
Thank you.

: I’ve uninstalled this current version and tried to download a previous version. That version did not allow me to install when canceling Privdog.
Luckely I found the 6.2 version from June 19 2013 in my download map and installed it after uninstalling the current version. After updating the virus database and a quick scan everything is back to normal. Still hope you guys can fix the current version 6.3.

Thank you for the feedback cario.

Maybe it is because i have eaten a ton of ■■■■ defending this product and company, just to stumble upon something that resembles everything people have complained about, and given me ■■■■ over defending.

I have these problems after upgrade.

  1. CIS program does not update. Have look at the attachment.

  2. I use CIS Pro version and yesterday when upgrade I must agreed Privdog that I do not want, otherwise it would not let me upgrade. Why? Why do I have to install something that I do not want? It looks like another adware. Something similar is already in Dragon -restart_helper.exe.

[attachment deleted by admin]


I also get the same “The system cannot find the file specified” error as radek178. It has the same error code as displayed in radek178’s post.

Thank you for your help, and thank you for a great product.

I have the same issue as radek178 and zarniwoopz.