COMODO Internet Security 5.12.256249.2599 Released

Hi Guys,

I would like to announce the availibility of COMODO Internet Security 5.12.256249.2599.

We have also issued an update to all users who have previous versions installed.

What’s New in this release?
IMPROVED! Windows 8 Support
FIXED! PPPoE protocol driver conflicts with firewall driver in Windows 8

As you already know, we already released 5.12 before but havent updated existing users so far. However in order to reduce the Windows 8 related support load, we decided to issue an upgrade to make all comodo users fully compatible with Windows 8.

This is not CIS 6 and you will still get CIS 6 once it is released.

IF you would like to download directly, yourselves here are the links:

COMODO Firewall 5.12:
MD5: 3CDAA9F4347EDFAAFB2C0E88C8B82455
SHA-1: D9016368BF2D716E8C3E865C847FDFB3C6C11D8D

COMODO Antivirus 5.12:
MD5: ABF3C1993D138D722FAD7B700D575534
SHA-1: EC6F7F77F7ADAEC7844DB4349656B0C4F0E5A106

COMODO Internet Security 5.12:
MD5: 883C8B12D6F6FAED8CC946D3E02F4F48
SHA-1: 3A4EA58875793AFC2639B2F2765B67C4D90DBF73

EDIT: Added file hashes by user request, wasgij6

Thanks for this update, hope Windows 8 users will like it ;D

Thanks for the update, downloading now

great work guys…

I think this is the last release before a much anticipated ver 6!!! :slight_smile:

I don’t think so…
I’m sure.

Comodo was asking me to update a minute ago. I was: What? Not again! LOL! Issue with Comodo server! Need to report! And here you are! Official new update! But no thanks. Using 5.10 still. Waiting for CIS 6 RC. :slight_smile:

Thanks for this update

not a surprise autoupdate failed on WinXP Pro 64bit due some file (intrepid_m.whatever or something like that) was missing but manual install worked fine, on Vista autoupdate succeeded normally but Vista didn’t like some reboot CIS did and wanted to send error report to Microsoft. CIS on XP was fine since I reinstalled OS and CIS ~2 weeks ago and CIS diagnostics didn’t found any errors (not a surprise) and on Vista CIS hasn’t reported any problems.

i love the layout in version 5… its sad that is almost over :stuck_out_tongue:

Unfortunately the black screen problem continues =/


I think I’ll just stick with 5.10 for now since nothing changed for W7. Still, thanks for letting us know that this wasn’t a Update failure like what happened a few weeks ago. :wink:

maximise security by change for Yahoo. ???

why this commercial alliance?


Thanks for this update. I love Comodo :a0

Is this even for windows seven or, like previous 5.12, is for windows 8 only?

I have got a problem.

I exported my configuration from CIS 5.10.228257.2253 uninstalled 5.10 and
restarted computer and removed cis from non plug and play drivers in device manager
and restarted once more.

When i installed 5.12 i restarted computer and imported configuration from 5.10
and went to update CIS av database i got a firewall prompt from windows system that
it wants to connect to the internet(255.255.XXX.XXX and other ip adresses) and other
programs want to connect to the internet with same firewall prompt.
I also noticed there is no traffic notification in the tray.

I uninstalled CIS 5.12 and followed the same procedure as described above and installed
CIS 5.10 imported configuration and there where no problems.

My configuration CIS 5.10.228257.2253 Internet security premium,av database 14142
W7 SP1 - 64 bit with latest updates.

Me too. Well use version 5 until the support for it runs out which is not soon. It’s like people with ESET. Some don’t like version 5 so they use version 4. :slight_smile:

Thanks! My Win8 needed a real protection. :-TU

The same thing :-\

I have a similar problem. I have W7 SP1 64bit, today I updated CIS to v5.12.256249.2599 and some programs have stopped working. For example: my MSN messenger v7.0 (I know, it is a very old version) can’t connect since new version was installed, my other PCs in the localnet can’t connect correctly to some webs (for example: using proxy (proxy is installed in same CIS PC).
And, as Leon Outside say, i got a firewall prompt from windows system that
it wants to connect to the internet(255.255.XXX.XXX and other ip adresses) and other
programs want to connect to the internet with same firewall prompt.

How I can go back to the previous version? (I can’t remember the number of the last version and where can I donwload it)