COMODO Internet Security 3.8.61948.459 BETA Bug Reports [CLOSED]

Please post all bug reports & BSOD’s here and make sure to include:

  1. Your Operating System (32 or 64 bit) and Service Pack revision (Instructions for XP and Vista)
  2. Other Security and Utility Software Installed
  3. Step by step description to reproduce the issue
  4. How you tried to resolve the problem
  5. Upload Memory Dumps on crash if you encounter any
  6. Attach screenshots to your posts to clarify the issue further
  7. Please post any False Positive Reporting in the thread here
  8. Any other information you can think of

It’s vital to provide all this information, so the developers can quickly identify and fix bugs faster.

  1. Windows XP SP3 32bit.
  2. Comodo Internet Security (Only in Real Time), Malwarebytes’ Anti-Malware & SUPERAntiSpyware on-demand (NOT RUNNING).
  3. This was not a problem with beta 1, But now it takes about 3-10 seconds for Comodo Internet Security to initialize on startup, Usually it’s straight away with Beta 1 and current stable version. Also the “Comodo Wants you to install a trusted internet” message on a fresh install, the text is rather truncated/messed up. What you need to do is simply install CIS 3.8x Beta on a Windows XP SP3 Computer, Reboot when asked, then open up the CIS GUI quickly and it will still be initializing. You will also of course get the message about the Trusted Internet/CIS Pro and the text won’t be clear. And I don’t know if the DB is suppose to be at “1”?
  4. Tried reinstalling and didn’t do the trick, I also uninstalled Comodo EasyVPN Beta & VMware WorkStation and startup and intlizaing is a bit better… But still a problem with both text and initialization.
  5. N/A
  6. Screen shots Attached.
  7. N/A
  8. This is really odd as it didn’t happen on beta 1, But these are only minor things I noticed. All my CIS Settings are default too, See Screen shots.


[attachment deleted by admin]

  1. Windows Vista Ultimate SP1 32-bit
  2. Only Avira PE Premium is active alongside CIS (AV not installed)
  3. When there are pending files (i had about 600 in there) press purge then it starts to scroll through the entries untill CIS crashes and gives an error message.
  4. pressing remove instead of purge got rid of the pending files and CIS didn’t crash, but id prefer if the purge button would work.
  5. N/A
  6. forgot to take a screenshot of it before i removed entries, will take screen if it happens again.
  7. N/A
  8. as i said before this is exactly how it happened: There was about 650 pending files, i pressed “Purge”, it started to scroll through the entries, a second or 2 later, i get an error message about cfp.exe and CIS crashes, there were no Comodo entries in the pending files btw.
  1. Windows XP SP3 32bit
  2. None (clean virtual machine).
  3. When submitting samples this process crashes, same problem with beta 1. Scheduled (automatic) submitting results in the same crash. CIS itself remains working.
  4. No work-around.
  5. N/A
  6. Attached.
  7. N/A
  8. Same problem on beta 1, current stable version works fine.

[attachment deleted by admin]

  1. Windows XP SP3 32bit
  2. None (clean virtual machine).
  3. Firewall Part, address of Mac can’t contain 00. Same problem with the last beta.
  4. i set a rule about Mac with regedit
  5. N/A
  6. Attached.
  7. N/A
  8. Same problem on the last Beta.

[attachment deleted by admin]

1: Windows XP Service Pack 3 (32 bits)
2: AVG Virusscanner (Free) v8.0
The problem resided with an anticheat tool called GameGuard. There have been problems with comodo and Gameguard before, but they were fixed a while back up untill the last stable version. But with this new beta version there is a new problem.
The (online) game i play is called Cabal Online (i play the European version) which now uses Gameguard version 1264.
Gameguard as allways tries to get some ‘high’ priviliges and will inject itsself in every application started to see if it’s ok or not. Since i know it’s safe i have no probleming allowing gameguard to do so (making it a trusted application)
The problem is now that i can not start ANY program while gameguard is running. When i check in the taskmanager all the processes have no “user name” anymore. As soon as i close Cabal Online (and thuse gameguard) i can start all programs just fine again.
4: I tried running the game via “run as administrator” but that didn’t made any changes.
5: N/A
7: N/A
8: In the latest stable verion this problem wasn’t here.

[attachment deleted by admin]

  1. WinXP x32 sp3 all patches
  2. McAfee VirusScan Enterprise 8.5i patch 7
  3. CIS (installed without AV, TC, SS) unexpeceted rebooting the computer.
  4. N/A
  5. N/A
  6. N/A
  7. N/A
  8. This bug appearing with beta 1.

I’m actually in a bug right now…

  1. XP PRO 32 bit SP3 Nlited (+patched dlls for visual style)
  2. Comodo Internet Security, nothing else
  3. on first start-up after installation it gives an error and then shutsdown which results in no internet of course
  4. I wanted to reinstall, but the uninstaller was corrupted 88). So I started to delete some reg keys and remembered that there are back-up files, so I took the back-up files and replaced the normal ones, then it startsup without a problem, it now says that all programs are up and running, but I don’t believe it ;D. I asked the antivirus to update, but it says : Antivirus not initialised… Oh yeah, I didn’t change anything about it’s theme but it’s giving a strange style ??? Oh and it now says there’s an update available 88), pretty lol version
    EDIT : so I rebooted again, and when trying to update it says “no such interface supported”. then I tried again and after the 3rd time it just starts updating …
    EDIT : I found a problem, CIS doesn’t support TrueTransparancy, so you can’t close it anymore unless 1) you disable TT, 2) you close it while rightclicking on it…

pics attacked attached


[attachment deleted by admin]

  1. Vista x86
  2. N/A
  3. After restarting OS, the system didn’t start up. After glowing orb, there was nothing. I’ve waited several minutes, but with no results.
  4. After reseting computer, everything is normal.
  5. N/A
  6. N/A

I know CIS is not being developed for Windows 7 yet but it worked wonderfully with the beta 1 build. So hence I take the liberty of submitting a bug for Win 7 beta.

Not all programs under Win 7 beta build 7000 can connect to the internet or web page of the modem/router. The programs worked before with beta 1.

  1. Windows 7 beta build 7000

  2. Spybot Search and destroy with security center integration (sdwinsec running)
    Malwarebytes antimalware free(nothing residential running)
    Spywareblaster (nothing residential running)

  3. Do a clean install of CIS beta 2 running the installer in Vista compatibility mode, reboot when asked and fire up programs.
    Working programs:
    Opera 9.63 and Opera 10 Alpha
    Firefox 3.0.5
    Spybot Search and Destroy updater

    Not working programs:
    Internet Explorer 8 beta
    Malwarebytes anti malware updater
    Yahoo Messenger
    MSN Messenger
    Quick Time Player opening screen with web site won’t open

  4. How you tried to resolve the problem: When the Firewall doesn’t give an alert I make a rule under Network security policy; this happens f.e. when starting IE8. I make sure D+ gives permission (make it trusted). Even making rules doesn’t help to give the application web access.

  1. Vista Home Premium 64Bit SP1
  2. Avira Antivir free (only on demand), Windows Defender (on-access), Safe Surf, Boclean, MBAM, SAS (both on-demand), CVA, CSC
  3. I couldn’t connect to the internet with this beta (and the previous one as well) installed on my system. So I tried to manually input my settings but to no avail (they were exactly the same as in the stable .439 build). It’s really strange as I could see the Firewall working (it blocked a couple of intrusions) as well as Threatcast.
  4. I reinstalled CIS but I still had no connection with the internet.

I have also experienced that this beta (as well as the previous one) requires a good 2 minutes to initialise properly (its similar to Josh’s issue in the first post).

Vista Home Premium 64Bit SP1
Avira Antivir free (only on demand), Windows Defender (on-access), Safe Surf, Boclean, MBAM, SAS (both on-demand), CVA, CSC

This issue seems to appear after the second reboot onwards.


Check your Windows Event logs. Your looking to be sure that inspect.sys installed & started without any problems.

  1. Vista 64 SP1
  2. No
  3. The anti-keylogging feature is too aggressive: If you type in something in a letter box of a program this provokes a keylogger warning. For example if you type in something in the typing field of the Ghost leaktest:
    Of course it’s not a keylogger.
  4. /
  5. /

  7. /
  8. /

Same specs as in my previous posts.

I encountered a bug and it created a dumpfile, I hope this is the right one …


  1. WinXP x32 sp3 all patches
  2. McAfee VirusScan Enterprise 8.5i patch 7
  3. The following active connections are not shown in Firewall->Common Tasks->View Active Connetions:

TCP Listening 8080

TCP Listening 55555

TCP Listening 7509

TCP Listening 33333
4. N/A
5. N/A
6. N/A
7. N/A
8. CIS final releases

GHOST isn’t specifically a keylogger, but IT IS logging keystrokes. CIS, in this instance, is capturing the activity correctly.

Ewen :slight_smile:

As result of a found bug in Win 7 Beta which I reported here in the thread I followed a lead to another user to check in event viewer if the inspect service was running.

Event viewer reports Inspect service not started yet CIS doesn’t report a problem when running Deagnostics.
I checked and found the following:

  • XP SP3 all updated. No event with regards to Inspect. Clean install of CIS beta 2 after CIS 3.5 latest stable version
  • Vista 32 SP1 all updated.The following boot-start or system-start driver(s) failed to load:
    inspect Checking evenr viewer showing this is showing since the install of CIS beta 1. Both CIS beta 1 and 2 were clean installs
  • Windows 7 beta build 7000. The following boot-start or system-start driver(s) failed to load:
    inspect. Bpth CIS 1 and 2 are clean installs. Here it only happens after installing CIS 2.

What did I try to solve it? Followed a Microsoft lead to make the file that is being referred to exists. It does and has the proper version number. Noticed in the registry that the location system32\DRIVERS\inspect.sys had drivers spelled in capital letters. Changed that and rebooted to no avail.

On Vista the firewall functions properly as far as I can tell in Win 7 beta some programs don’t get access where they had access in CIS 1. Who is wrong CIS or Event viewer?

Is anybody willing to check his or her event viewer for event 7026 regarding Inspect service?

  1. Windows XP SP3 32bit.
  2. Comodo Internet Security (REAL TIME), Malwarebytes’ Anti-Malware & SUPERAntiSpyware. (ON-DEMAND).
  3. cmdagent.exe uses 95% CPU and 60MB of RAM when updating from Database 1 version to Database 2 version in this v3.8 beta version. To reproduce this, Install v3.8 BETA, Making sure the Database is version 1. Do a manual update or wait for it to automatically update the database, Then check the Memory usage of cmdagent.exe via task manager as the updates goes.
  4. n/a
  5. n/a
  6. Attached.
  7. n/a
  8. cmdagent.exe also uses 30MB RAM on startup, Which I assume is checking for virus updates then as well. The memory usage on startup has been there ever since v3.5 was released, And I only just noticed the 60MB Ram/95% CPU usage with this beta yesterday. People are having similar problems in the COMODO Internet Security 3.8.61948.459 BETA Q&A’s\Feedback Thread. Here are some quotes:

So the problem has been here for a while. But 60MB is the highest I have seen so far.


[attachment deleted by admin]

You are wrong because the 32 bit version of Comodo isn’t that sensible.