COMODO Internet Security 3.5.52396.411 BETA 3 Bug Reports [CLOSED]

Please post all bug reports & BSOD’s here and make sure to include:

  1. Your Operating System (32 or 64 bit) and Service Pack revision (Instructions for XP and Vista
  2. Other Security and Utility Software Installed
  3. Step by step description to reproduce the issue
  4. How you tried to resolve the problem
  5. Upload Memory Dumps on crash if you encounter any
  6. Attach screenshots to your posts to clarify the issue further
  7. Please put any False Positive Reporting here
  8. Any other information you can think of


Issue: minor GUI (e.g. misalignment in some links from the Summary screen, truncated text, etc.) and Log screen imperfections (I didn’t select CAVS. Therefore the log shouldn’t be there…)

  1. 32 Bit | Windows XP | Pro Service Pack 2
  2. Comodo Firewall 3.5.52396.411 Beta only security program
  3. Just open the GUI / log screen
  4. The basics like stretching/maximizing the screens didn’t help except on the Defense+ screen, which reveals the missing the letters “it” in the word “exploit”. I added cfp.exe into WindowBlinds exclusion applications, but that didn’t do anything even after I restarted CFP. So I know it’s not a WindowBlinds problem.
  5. I really think it’s a DPI issue again. Mine’s set at 120.

[attachment deleted by admin]

I would agree it is a DPI issue.
Are you still able to view easily if you increase the DPI to 150?

I would think increasing it would worsen it. What’s so special at 150?

BTW, I notice a lot of font type inconsistency even amongst the same screen.

increasing the dpi makes the letters smaller (# dots per inch).
(increasing the screen res can sometimes fix this as well)
I checked all my screens. At 1650x1080 they are all Ok (I haven’t decreased res. to see if I can duplicate your display issue, though).

Logging still doesn’t work on Czech windows, and probably some other localized versions (so, including CFP, we now have 13th release with this bug), I won’t repeat the cause as it was beaten to death in previous threads. Even if you don’t care about Czech users, you should at least fix those buffer overflows (there are at least 4) in the logging function.

I don’t know wherher it is a bug in CFP or in VirtualBox, but when I install CFP on VirtualBox it crashes just after startup. Strangely CFP beta with ThreadCast works without any problems. I would be glad if Comodo’s development team could at least determinate where the problem lies. If it’s in VirtualBox I will go report the issue there. For more information and crash dumps look here [link].

  1. 64bit Windows Vista
  2. SpywareBlaster
  3. Move masses of little files at the same time. I moved Zombie Panic Source (about 10k files and 1,2GB). Comodo will consume about ~30% (C2D 2,7GHz) of CPU time slowing down the progress.
  4. Turn off the antivirus
  1. Vista 64 / XP 64
  2. no
  3. Comodo 64 doesn’t block many leaktests so it’s maybe much weaker in fighting malware than the 32 bit version.
    Here’s the list of leaktests that are not or propably not blocked:

Zemana keylogger

tooleaky (doesn’t detect starting of IE)

awft1 (doesn’t detect starting of IE)
dnstest (doesn’t detect starting of svchost.exe)
ghost (doesn’t detect starting of IE)




flank (can start IE also on 32 bit)


socksnif (not sure)

D+ was in paranoid mode and FW in custom policy mode.

another little glitch:
For the firewall you can set up the option “Keep an alert on screen for maximum X seconds” to only 999 seconds, for D+ you can set it up to 9999 seconds. They should both have the same restriction.

  1. not possible to solve the problem by user
  2. no dumps available
  3. screenshots won’t help
  4. no fp reporting
  5. there must be something broken in D+ 64, for example the leaktest ghost of is passed but not the one from SSTS.
  1. Windows XP SP3 EN 32 Bit
  2. Comodo BOClean
  3. Go to Antivirus tab a click on Virus sigantures update link
  4. Yes, by disabling firewall, not sure what else I could try.
  5. No crashes.
  6. Not required I believe, the message I get is: “Failed to update the virus signature database.”
  7. None
  8. Check for Updates link in Miscellanelous tab works as intended, also BOClean is able to get online updates.

Unfortunately I still have a problem from BETA2 with Virus Signature updates. I just updated BETA2 via Check for Updates link to BETA3. Virus signature is still 309 and Update Virus Database link still doesn’t work. However this time it returns the error message after 5% progress is shown for a second (with BETA2 it failed almost immediately).

Someone asked me to check HOSTS file in BETA2 thread - I did and it has only standard one line, the file last changed 2.5 years ago.

Can someone please tell me what IP and port is used for Virus Signature updates? I will try to check if there is some problem with connectivity, but since CIS update works, it doesn’t seem to be likely.

I will also try completly uninstall CIS and reinstall. I will post here if it helped. :slight_smile:


EDIT: Tried the reinstall. Now my signature database is 358, but Update link still doesn’t work (fails at 5%).

Thanks. Didn’t know that. You have the same resolution as I do, but I have “perfected” my setting at 120 DPI for my needs and the GUI didn’t have some of these problems in the last CFP release version.

  1. Your Operating System (32 or 64 bit) and Service Pack: Windows XP Home CZ SP3
  2. Other Security and Utility Software Installed: Spyware Terminator, SUPERantispyware (scanner-only)
  3. Step by step description to reproduce the issue: always, same bug for months, no fix still
  4. How you tried to resolve the problem : yes, pointless, CIS freezes is best result
  5. Upload Memory Dumps on crash if you encounter any: CIS freezes

OMG, again new release with same bug, present for months. Don’t you really care at all about non-english Windows? How is it possible that CF3 and CIS are the only non-functioning software I have just because it cannot store logs in folder that is sensitive to language of Windows? Is it really that hard to make subfolder LOGS in installation folder instead of looking for folders that may contan non-english characters which your software cannot cope with.

Logging doesn’t work on systems that have non-english characters in localized name of Application Data folder. PLEASE make folder LOGS somewhere else to fix this easy bug. I don’t get it, that this important bug so easy to fix is still present after months from the first version of CF3, CF2 didnt have this problem. Firewall without logging? Funny.

+1 on this; I simply don’t see what’s so darn hard to fix here. Yeah, make it log %SYSTEMROOT%\ComodoLogs or similar instead of %APPDATA% if you application for some whacky reason can’t cope with Unicode chars even though 99.9% of other stuff has absolutely no issues whatsoever with this. >:( :-TD

My system:

Windows XP SP3 32 Bit
Running: CIS Beta 3
BOClean 427
Comodo Verification Engine
Comodo Diskshield (new beta)

I did a manual virus database update and when it was done, the date that I did the update was Thursday, 1 january 1970??? (:LGH)

I have attached a screenshot.


[attachment deleted by admin]

My system specs are:
P4 HT 3 GHz and over 1gb ram available and XP sp3 32bit, HW DEP Optout.
Other apps: Comodo Safesurf, Unlocker assistant, Speedfan, Daemon tools, COMODO Vulnerability Analyzer, Logitech Setpoint 4.60.122

CIS beta 3 was updated over Beta2 hence the old config is still in place.

As per

Termination protection is unable to prevent termination using spt 12th method.

I don’t know if that termination is not protected by design.

Adding \RPC Control\IcaApi to pseudocom protected entities will be able to trap that termination attempt indirectly.

I’ve not tested if the full CIS installation features an updated config with \RPC Control\IcaApi pipe

In addition to gibrans post:
Other processes than Comodo one’s can be terminated by using kill3f from SSTS.
Comodo asks but it doesn’t help anyway, the process gets terminated. It also doesn’t help to enable all protection settings for the application, then it gets terminated without any pop-ups of Comodo.

Comodo still doesn’t monitor two important areas in the registry on 64 bit:

*\SOFTWARE\Wow6432Node\Microsoft\Windows NT\CurrentVersion\Image File Execution Options*

Please add those lines to “My Protected Registry Keys”.

Same old issue - no logs !! - Disable AV logging option unchecked :slight_smile:

Windows XP SP3 32 bit English (installed to C: - FAT32)

CIS - (installed to D: - FAT32)

Avast antivirus 4.8, PeerGuardian2 (Others - but services / monitoring / shield / runtime protection disabled - Spybot S & D, Spywareblaster, Adware, Spware terminator, AVG Anti-Spyware 7.5, SUPERAntiSpyware, Advanced Spyware Remover)

Disable CIS - CAVS3 antivirus monitoring, and updates download. Run manual scan
There were 16 objects identified - no security breaches but passwords revealers, debuggers, security related … - (Good work).

On the actions list, did the needful used ignore, remove options. Exited, went to view antivirus logs - no details

Please act on this as an important action for new releases.

Windows XP sp2
CIS beta3
BOClean 4.27

Have download problem after installing the CIS beta3, it is not happened with the previous beta.
I use free download manager v25.728
Probably I have to adjust my configuration, can someone give some info?

Best Regards.

My old CFP Doesn’t Prompt Before Deleting Logs bug is still present.

  1. 32 Bit | Windows XP | Pro Service Pack 2
  2. Comodo Firewall 3.5.52396.411 Beta only security program
  3. Open the log screen (either within CFP or C:\Program Files\COMODO\COMODO Internet Security\cfplogvw.exe), right-click any window that has entries and click Refresh, then click File > Clear > Firewall / Defense+ Logs
  4. Sample:

What it should be doing: