Comodo Internet Security 2019 RC (v12.0.0.6818) is now available for download.

Hi All,

We are pleased to announce that Comodo Internet Security 2019 (v12.0.0.6818) is now available for download and testing feedback.

Online Setup Details:
In order to install online setups, please ensure you have following entries in Windows hosts (c:/windows/system32/drivers/etc/hosts) file:

Comodo Antivirus
Size: 5.4M ( 5625088 )
MD5: 3c732fce98b24e36d25bcd6241876fa9
SHA1: 29da07afdba05cee5b977c553a3a12fd6265fa68

Comodo Firewall
Size: 5.4M ( 5625088 )
MD5: bff825bd466bef9d6fda0763766802b4
SHA1: 39efba3b38f006719be6709ed6238dbad8387d2b

Comodo Internet Security Premium
Size: 5.4M ( 5625088 )
MD5: 07902c3f5d9edfe35737a17e7bde9a6b
SHA1: 76730f78172a30ab43632d89b9047044d321e224

Offline Setup Details:
Comodo Internet Security Premium (Firewall and Antivirus only)
Size: 74M ( 76863272 )
MD5: 318f461f48783abc92280e6f08dc5e2e
SHA1: 6c07e1e34e30f3284a8126b1587a4691a5a42d7a

New for CIS 2019

  • Added ability to remove vendors rated by Comodo from Vendor List


  • The issue where system becomes unresponsive with specific viruscope settings
  • The issue where non PE files cannot be submitted by ‘Submit Files’
  • The issue where user rating was not applied in ‘Vendor List’ for vendor with name starts with space

Please give your valuable feedback! :-TU


Tried to install it. During installation I have lost Internet connection and was prompted to restart the system… After restart Comodo Firewall wasn’t working and I was cut from Internet.

No further problems.
CIS is no longer frozen since I deleted and installed silverlight again. Everythin o.k.! :-TU

II had a similar problem but without Internet loss. It was due to my modified configuration of cruelsiter’s. I have a minimized setting for it (firewall/HIPS ruels) which allows Updates i.e. of Windows. Perhaps allow in firewall-settings the update or set fw and hips in training modus (perhaps this may help).

Was the “search” function in Vendors List also added back in this RC? Can’t check for myself right now. Thanks.

Run the official uninstaller tool and then install using the offline installer.

Search has always been available.

Did it. Same result.

Ooh sorry I haven’t installed V12 yet (still on V11). May I also ask if option to check/uncheck all vendors is also available in this RC? Thank you.

The vendor list is the same as it has always been, the only difference is now you can change rating of vendors and now you can remove any default vendor. But removing vendors won’t mark those vendors as unrecognized and any application signed by those vendors will probably still be trusted due to file lookup service. So you really need to manually change the vendor rating of those you do not want to trust.

How did you get your system back on the web? It sounds like there may have been an issue with the Inspect packet filter driver.

Do you need to change the rating before removing the vendor?

Thanks. Currently I am running with File Lookup disabled using a custom list. Some people like to set Comodo this way, so it’s good to have Remove option back.

Search function is now located near the “Vendor name” field. Just a minor change.

Clean install after removing 11.6802 . . . no problems at all

Imported my Config . . . . edited Vendor list to my preferences, then removed all trusted files and imported my own saved list and installed KillSwitch

Everything working fast and smoothly

Many thanks for giving us that extra control capability back again :smiley: :-TU

There is a problem with the inspect network driver. After upgrade from 6810 only red cross and on internet. Used uninstall tool and did fresh install to have the same problem. Removing the COMODO driver from the network gives back internet access . Running the network fix in CIS stops it again.

The moment I have uninstalled CIS I have regained connection.

To install 6818 online it failed with me, too, although I didn’t lose the internet connection. So I installed offline.

Hi everyone,

Thanks for feedback and provided logs.
We’ve localized the issue with installation and network, updated package will be uploaded in a few - no code changes, problem is in the installation package configuration.
File versions will be the same, but hashes will be different.

I’ll edit first post it the thread and will post separate message as soon as new installers are available.

No you shouldn’t remove it, otherwise the rating will get reset just like how it happens with files in the file rating list.

We’ve updated installers, sorry for inconvenience.

Zee64, ghostza, could you please try to install cis once again?

Now it works. Thanks.