Comodo Home products - 504 Gateway Time-out error

The page gives the 504 Gateway Time-out error from the CIS website. It is not downloadable.
Instead CAV is downloadable.

What page are you referring to?

Anything under “For Home” and maybe more…

It seems to affect the Home products from what I gathered. I split and moved the posts to Forum and website issues board.

Using TOR dependent on the circuit some Home products are accessible.

Iget the following errors for the 5 products accessed from Europe:
Error 504 Gateway Time-Out:

[b]Too many redirects:[b]

Can you see what branches of the CDN are working and which not? I think the structure is as follows:

  • Europe
  • Americas (North and South)
  • Afrika and Middle East
  • Asia with New Zealand and Australia

Some tested TOR circuits :

United States - Italy - Iceland -
United States - Czech Republic - Austria -
United States - Ukraine - Germany -
United States - Netherlands - Austria -
United States - France - Netherlands -
United States - France - Germany -
United States - Italy - United States -
United States - Luxembourg - Germany -

Accessible Home products : Antivirus Software / Mobile Security
Not accessible Home products : Comodo Internet Security (504 Gateway Time-out)

I didn’t check the “Dragon Browser” and “Security Plugins” links.
It seems no TOR circuit can establish a connection to the “Comodo Internet Security” Home product. (I will try some more to check.)

Note: The TOR circuits do change (they deviate from the Home page) when establishing a connection to a certain Home product.

The same issues are encountered here in China.


Thank you for bringing this to our notice, We will rectify the problem.

Downloading the offline installer from the Comodo Internet Security 2020 v12.2.2.8012 Released thread seems not to be working as well (the online installer downloads do work).

The offline installer download works when using TOR browser (workaround).

CIS and Dragon links now working from UK as is the Offline CIS Installer link

Still redirect issues with the other 3

When using TOR all “For Home” product links are working again including “Dragon Browser” and “Security Plugins”.

Looks like all links are now up and running normally again . . . in the UK :-TU

Here in the Netherlands too.

I had to clean browser cache in the process though. I would initially get the too many redirects error for the three products but clearing browser cache and restarting the browser fixed it.

Using regular Firefox (on both IPv4 and IPv6) “The page isn’t redirecting properly” error for Home product links:

Antivirus Software
Mobile Security
Security Plugins

The other Home products links are working.

There are still other “The page isn’t redirecting properly” issues…

For example:

Go to “For Home → Comodo Internet Security” scroll down to “Integrated Firewall” then click on “Learn More”, doesn’t work or me.

Could you please check now?

Sorry, still getting the same “The page isn’t redirecting properly” errors on some of the Home products and on the “Learn More” button.


The odd (or the good) thing is that all Home product links and the “Learn More” button do work in TOR.

In regular Firefox still the same “The page isn’t redirecting properly” errors.