Comodo Firewall won't update

Hi Guys,

I’m using Comodo Firewall 7.0 under Windows 7 64-bit.

The firewall is working fine, but it won’t update. When I try to update it gets 2 errors, then gets to 53%, then I get the following error message:

“A connection with the server could not be established”.

There’s nothing wrong with my internet connection, it’s working perfectly.

Anyone can help? Thanks!

Update: I have installed the latest version of CIS (7.0.317799.4142) but get the same error when trying to update.

Anyone have any advice?


try reinstalling given the advice in this post:

Thanks, wasgij, but I have already followed the advice in that page step-by-step and reinstalled to the latest version, and still I get this error.

Any other thoughts?

are you using any other security software?

try removing the remnants of past installed security software these can cause weird problems

Thanks, wasgij.

I’m only using the Firewall part of CIS, not the anti-virus.

For my AV, I am using Avast! Free Antivirus. I have tried disabling it and disabling other security software running in the background - IoBit Malware Fighter and Spybot.

But I still get the following error:

Error: 0x80072efd - A connection with the server could not be established

Do you have any other thoughts? Many thanks.

This might be related to hosts resolution problems. If that’s the case, please try this work-around:

  1. Go to \System32\drivers\etc
  2. Edit hosts file with notepad (using administrator rights) – note: hosts file might be set to read-only
  3. Add the following line :
  4. Restart
  5. Update
  6. Post results

Thanks again, but I’m still getting exactly the same error… :frowning:

Do you use a proxy? Please check if proxy connection is enabled.

Can you download this test file?

Hi qmarius,


I use a proxy for my browser (Comodo IceDragon) but not for my network connection, as far as I know.

Yes, I could download that file no problems :slight_smile:

Did you run a diagnostics?

If you experience such problems then please create a bug report here with the required format.

Thanks, qmarius.

I tried the Diagnostics - it said there was nothing wrong with my software.

But saving the Diagnostics file produced an error - I tried multiple times.

I have submitted a bug report.