Comodo Firewall systray icon invisible [M2419]

Hello, just installed the CF latest version, after uninstalling the previous one, and if I leave the Animation Traffic option on, everything is ok, as soon as I turn it off and I reboot, in the systray CF icon is fully invisible

Hi AndyWarrior,

Thank you for reporting we are checking this issue. Could you please let me know your windows version.

Windows 10 Pro 1903 x64 (full specs in my signature)

The same strange problem happen also to my ASUS EB1036 Desktop with the same Windows
As soon as the Animation Traffic is disabled, the Comodo systray icon is still visible and the animation stops (but with some arrow stuck, sometimes), after reboot it is fully invisible

That’s happen on both of my Desktop Computers (I’ll not try on my two laptops, I’ll leave the CF previous version for now)

Yes I can confirm this.

I have the same problem. SOMETIMES if I run the setup file again, it will make the icon appear, but not permanently.

Should be fixed with beta 2 please check.

Just upgraded to version 12.2, if I disable the firewall animation traffic, the CF icon in the systray become invisible.
This issue had been already reported months ago for the 12.1 version, I’m very happy to see users feedback time completely wasted
Good, very good (:AGY)

Hello AndyWarrior,
Thank you for reporting.We will check this and notify you.
Have a nice day!

Kind Regards,

Just updated also on another PC, the icon is working fine, so now I lost the right way…
I try to rebuild icon cache → nothing
Deleted 2 registry keys → nothing
I really don’t know why just on this PC the icon is invisible (blank space)

In all PC where I update the CF to this latest version, with the animation traffic OFF, the icon is visible, but as soon as I set the firewall to disabled, it change with an X in the middle of the icon. Nothing to say right now.
Unfortunately in all the computers, as soon as I set the firewall back to Custom Rules (ON) that icon doesn’t change, it remain in the same way as it was OFF.
To restore the systray icon to the CF’s correct status I have to reboot…

1: CIS version:

V12.2.2.7036 (Firewall only)

2: OS version:

Windows 7 Ultimate 64-bit

3: What you did:

[ol]- Go to “Firewall->Firewall Settings->Enable Firewall” and set to “Block All”.

  • Perform a windows reboot.[/ol]

4: What you actually saw:

The CIS tray icon does not appear. Even after waiting for hours it did not show up.
Instead of the CIS tray icon there is an empty (blank) placeholder. When hovering the mouse over it it says “COMODO Firewall”.
Right clicking on the empty placeholder shows the normal COMODO Firewall context menu with all items working normally.
Comodo status is Secure, All systems are active and running.
So only the tray icon does not appear after a reboot when Firewall is in Block All mode.

5: What you expected to happen or see:

CIS tray icon to show up after a reboot when Firewall is in Block All mode.

6: If possible attach a screenshot illustrating the GUI problem

See attachments.

Hello AndyWarrior & CISfan,

Reported to CIS team and developers are working in it.Once resolved,let me inform you.
Have a nice day!

Kind Regards,

Hi, I got the same issue.

HP Laptop 14-cf0xxx
Microsoft Windows 10 Enterprise LTSC 10.0.17763 Build 17763 (LTSC 2019)

Comodo Internet Security

I’ve installed CIS for about 3 days. All was fine until this morning suddenly the tray icon became invisible. Hovering mouse over the blank spot shows it is there. Double click still envokes the windows. So everything is normal except the icon.

FYI, restarting my computer fixed the problem.

Hello comblaster,

Thank you for your response and info.
Have a nice day!

Kind Regards,

hi guys, i see something strange here.

yesterday i downloaded the windows 10 2004 rtm iso and turned off all cis modules to work/edit the iso. then I enabled all modules and all good.

today i powered on the computer and the cis tray does not shows anymore.

I know cis is running and protecting my pc but what is going on with the tray icon?

latest cis
windows 10 1909 pro x64
all updated.

the invisible tray is a very … old bug, you can mouse hover the icon even if its invisible and open it normally, at reboot it will work again (at least for me)

its funny. the icon is really there but invisible… :stuck_out_tongue:

It’s a known problem, the icon is there but it is not visible it. If you click right on it you will get the context menu. As a workaround close the application from the systray and start it again. Then the icon will show until the next reboot.

I am on a clean installed Windows 10 2004 x64 and the tray icon is not visible with practically each boot. During the first couple of days it would show more often and I have no idea why. On Windows 10 1809 it shows more often. It’s a minor bug but it is a bit of a sore to the eye.

The tray icon is quite buggy, not just becoming invisible. When I disabled some components, the tray icon turned to an X icon; but when I enabled the components back, the tray icon remained X.

I tried that in both cases (invisibility and remaining an X icon), it didn’t work. My successful workaround was to turn on traffic animation in firewall settings.