Comodo Firewall Pro Released [CLOSED]

Hi just noticed CFP has been released.

32 Bit

64 Bit

Zos (Kevin)

Here’s what they’ve fixed:
Fixed! Windows Vista 64 UI Problems.
Fixed! SafeSurf crashes applications on x64 based operating systems.


Install went fine. Running fine, even though it was for x64 Vista

Another flawless update. Same install since February ans still going strong. (R) (S) (B)

They never give everything in the changelog, but it did silently fixed the slight GUI bug that affected all platforms (not just Vista) :-TU

What? Where was bug, I didn’t notice it?
BTW, I updated and everything went fine…

Ah sorry, here it was

Hi Guys,

I performed clean install of .25 anticipating that at least this one will offer SurfSafe & ToolBar as .23 at very first clean reinstall.
That did not happen again.
I was presented with accepting Network Zone screen after 5th or 6th Reboot ???
Compare to all previous versions I cannot Import any of the saved Network Rules
Not impressed (:SAD)

My regards

Why did you do a clean install. No reason to. Did you select and apply your settings after?

Update went Flawlessly.

Cheers. (V)


Hi Vettetech,

As I said above I wanted toolbar back :slight_smile: and I thought the bug with SurfSafe was fixed as well
So I did as in the book - reg cleaning including famous CFP cleaning batch.

I don’t see imported to Apply after import. That happened sumetimes before but after reboot I was able to see them. Now my old settings never appear

In addition to what is written. This version does not keep settings:

  • Now it asks about Private Net Zone every restart
  • It is learning but after restart it is learning and re-asking, say about BOClean (what else?) and others.
  • balloon unchecked —> checked back after reboot;
  • Import reporting success but I cannot see new (rather my old beloved) entries to restart doesn’t help.

woW!.. so many bugs at the same time all of a sudden.

all started when Toolbar was declined in fresh 23 but I had SurfSafe.
after next (clean) reinstall of 23 and all subsequent versions there is no SurfSafe offer anymore… but at least Import worked and yeah! current new settings were preserved after reboots.

Should I return to 22 ??? and start all over?


I must say that i always get excited when i see that there are updates from Comodo.
Not that i need any updates.It works perfectly,except posisibly. the GUI wont stay where i put it.
We must be the last people on the planet to get the updates.
I have noticed that we in the UK don’t get any updates until later in the day.
I always use auto updates never reinstall.I prefer it that way.
Anyway,keep up the good work.I am sure we do need the updates.
What a great security program.
Best Regards

Yes, This is a known issue with most users.


Hi rambo,

Nobody argue: it IS (J) and (R) and :-TU

and I never had any major issues and auto update worked and works now fine.
When you need clean reinstall is if you want SurfSafe and Toolbar with built in Buffer Overflow protection. That’s what I want. But I stupidly declined Toolbar first time.
But neither 2nd clean reinstall of 23 nor any subsequent clean reinstallation offer SurfSafe anymore.
clean reinstall of .25 brought those problems I described above.
I hope there is an answer(s) and fix(s)

Other than that (V) & Cheers :Beer :Beer :Beer

Toolbars,i definately don’t want.
Buffer overflow will in due course be written into the main program until then i am quite happy to wait.

Yep, That’s the plan.


Great to have confirmation,thanks
Still waitimg for updates.About 6.30PM i estimate.Now 8.40AM
Patience is a virtue,possess it if you can,seldom in a woman never in a man
Best Regards

We have updates,well almost
We also have that !!! Error 113.
Did i say something about patience.

Updates? For?


Great.We now have the latest updates

I too experience the SafeSurf absence from the installer as well.

The way to reproduce it is to:

  1. Perform a clean install of one of the versions of CFP that have the toolbar and uncheck all three options on that screen from installing the toolbar.
  2. Uninstall CPF and clean out the registry.
  3. Try to reinstall CFP with a CFP version that contains SafeSurf and you will not be presented with the screen with the three boxes about Comodo search and toolbar.

This leads me to believe that there is an installer registry key or file in the installer directory that is not being removed and the installer for Comodo doesn’t overwrite it, but uses it and it causes to the install to bypass that screen since all options are unchecked.

Now to find the rouge installer option.