Comodo Firewall Pro RC2 Released

We are not able to make setups of all the languages live today which are supposed to be released with version 2.4 of firewall.

Following are the setups and addons which can be installed on top of already installed firewall, which must be installed from one of the English setups mentioned below:

AddOn Setups

English_ Setups

English Alone Setup

Following are the changes:

  1. Fixed : Incompatibility when McAfee + Daemon Tools + CFP installed.
  2. Fixed : GUI Issues reported in previous language setups.
  3. Fixed : Files could not be submitted using previous BETA setups, now you should be able to.

We will try to place Languages setups, which are still left to be done by tomorrow and if we do not have anything critical we go live on thursday.

Thanking all the translators for their efforts.


Technical information:

***STOP: 0x00000050 (0xF79DE000, 0x00000001, 0x805813B7, 0x00000000)

Still get this BSOD every time windows starts with this build. Last working build I used was

Can you please send the memory dump generated by windows?

Is there anything done about the delay issue reported by many users in previous beta?

Just had for the first time ever with this or any firewall - Firefox TCP Out Destination port 0! Port zero?
I didn’t know there was a port 0.
Was never asked that in previous betas.

Was also asked for Firefox TCP In connections for the first time ever as well. I created a block rule.

As I’m typing, I’m just being asked by Spamihilator.exe and avgemc.exe the same TCP Out port 0 connections. And now Spamihilator as Parent for Thunderbird
Is this another way of expressing localhost? I have “Skip loopback TCP connections” ticked.
If it is kosher, fine, but this is a definite change in behaviour over previous versions and betas.

The “Skip Parent when Invisible Connection set” bug is still there, of course. Doesn’t look like you’re interested in fixing that.



Same here. :-[

Just like with RC1 I get this exact same PAGE_FAULT_IN_NONPAGED_AREA message.

Have gone back to which is last version that works ok for me.

Really hope you guys solve this one before the go-live.

Still experience the same problem with RC1, i.e., User Profile Hive Cleanup (UPHClean) service wouldn’t launch automatically.

A check with event viewer got this: "User profile hive cleanup service was unable to load and start a required driver. "

Another new problem is, Avast automatic update would display “Update failed” message during start up… (:AGY)

Guys this does not help. Can you please post the windows memory dump urgently so that we can analyze the issue?

Thank you very much

your “average gamer” is installing.

I expect no issues.
will see.

For those who use the Portuguese (Continental) Translation, try this version and search for possible translation issues… :wink:

Well, I´m a McAfee + Alcohol120 user and now
this Beta runs without BSOD, reboot, freezes or something else (:CLP)

I got the same strange port 0 connection warnings like MSB.
And a TCP in connection to firefox.exe too. I block it for now but firefox works fine.

I backup my setting with the ver 1.5 script from panic und inport the seetings after rc2 installing and it seems to work :slight_smile:

sorry to insist guys but I posted a message about a crash of RC1, with uploaded stuff,now the topic is closed, could you please have a look? thanks.,5071.msg37800.html#msg37800



USA / english language ONLY install
relatively fresh install of XP SP2, no antivirus installed, or any other brand of FW.
Spybot S&D, Spyware Blaster

uninstall RC1
re boot
Install RC2
re boot

no rules installed, default config.

Shields Up: (all service ports test) Stealth + passed ping test

Comodo CPIL : all 3 tests produced popups, which I of course, clicked DENY.

install went clean as a whistle.
running fine, no hassles.

Comodo is still the KING! (CWY) (CNY) (CLY) (R) (B)

HELP? The addon haven’t contained the help file so i just wonder if you’ll later add it or not or… ?

I don’t know if this is a firewall issue or not! I’ve uninstalled ati catalyst, removed old 9700, installed new ati 1600 xt and now i can only install simple drivers but the whole catalyst pack causing me a reboot (i’m not able to see the screen where you can choose users). I haven’t got BSOD.

How i’ve resolved this above ATI problem:

  • I’ve removed CPF;
  • I’ve downloaded/installed new .Net Framework 3.0 (thought maybe .Net problem).
  • I’ve installed full catalyst package.
  • I didn’t reboot but opened display and switched back everything to minimum.
  • I’ve opened the catalyst page (initializing took a while…) then i switched everything to quality or “let the application decide”.
  • After reboot everything was ok.
  • Rebalanced display settings.
  • I installed CPF RC2 Hun.
  • Reboot.

Seems ok.

Windows generated any memory dumps for that? If so, can you please send us?


Until now, this version is working fine on my system…

Thanks for maj
french version congratulation
vista mode no


I have just installed the latest RC2. I am using the english version, no addons.

I have a Windows XP SP2 with all the very latest (including todays) updates applied.

I am now getting an annoying delay when a “allow/deny” window pops up.

I can click on “allow” but the window will just sit there and stall. Then after ~10 seconds it sort of “unfreezes” and I have to click on allow again. Any other challenges that have appeared during the freeze I can also click on without delay.

But if I don’t get any notifications for a minute or so, then get another one, I get the werid delay again.

I realise this is a rather ■■■■■■ bug report, I’m not sure how I can make it clearer though. Comodo seems to be working fine otherwise, but this annoying GUI delay is a pain.

Thanks, please let me know what other information I can provide to assist in making this a better bug report.

  • You’ve solved the two tab problems i’ve reported earlier, thanks.
  • You haven’t solved cutted text problems, yet.

HTML report isn’t working (i haven’t test this earlier), won’t generate detailed infos:

<head><META HTTP-EQUIV="Content-Type" content="text/html; ch****t=Windows-1200"></head>
<table width=100%% bgcolor=#CFCFE5><tr> <td> <font face=arial size=+2>Comodo t<pre><b>Dátum/Id<pre><b>Dátum/Id<pre><b>Dátum/Id<pre><b>Dátum/Id<pre><b>Dátum/Id<pre><b>Dátum/Id<pre><b>Dátum/Id<pre><b>Dátum/Id<pre><b>Dátum/Id<pre><b>Dátum/Id<pre><b>Dátum/Id<pre><b>Dátum/Id<pre><b>Dátum/Id<pre><b>Dátum/Id<pre><b>Dátum/Id<pre><b>Dátum/Id<pre><b>Dátum/Id<pre><b>Dátum/Id<pre><b>Dátum/Id<pre><b>Dátum/Id<pre><b>Dátum/Id<pre><b>Dátum/Id<pre><b>Dátum/Id<pre><b>Dátum/Id<pre><b>Dátum/Id<pre><b>Dátum/Id<pre><b>Dátum/Id<pre><b>Dátum/Id<pre><b>Dátum/Id<pre><b>Dátum/Id<pre><b>Dátum/Id<pre><b>Dátum/Id<pre><b>Dátum/Id<pre><b>Dátum/Id<pre><b>Dátum/Id<pre><b>Dátum/Id<pre><b>Dátum/Id<pre><b>Dátum/Id<pre><b>Dátum/Id<pre><b>Dátum/Id<pre><b>Dátum/Id<pre><b>Dátum/Id<pre><b>Dátum/Id<pre><b>Dátum/Id</td>
<table width=100% height=20 bgcolor=#CFCFE5><tr><td><font face=arial size=+1>End of The Report</font></table></body></html>

EDIT: Note that it’s with Hungarian language, English works.

EDIT2: “End of The Report” isn’t localized.